summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-13 21:43:50 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:28 +0200
commitc83fae0b6bb3ad92678d1818d48af378d18a2df2 (patch)
tree21e06a14fa394185d390d3f27760ca154718af05 /meta-perl
parent8571e98823b96d0223c7abd90059b567b3217ee0 (diff)
downloadmeta-openembedded-c83fae0b6bb3ad92678d1818d48af378d18a2df2.tar.gz
libimport-into-perl: add 1.002004 recipe
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libimport/libimport-into-perl_1.002004.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libimport/libimport-into-perl_1.002004.bb b/meta-perl/recipes-perl/libimport/libimport-into-perl_1.002004.bb
new file mode 100644
index 000000000..af08d630a
--- /dev/null
+++ b/meta-perl/recipes-perl/libimport/libimport-into-perl_1.002004.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Import::Into - import packages into other packages"
2DESCRIPTION = "Writing exporters is a pain. Some use \"Exporter\", some use \
3\"Sub::Exporter\", some use \"Moose::Exporter\", some use \
4\"Exporter::Declare\"... and some things are pragmas.\
5\
6Exporting on someone else's behalf is harder. The exporters don't provide a \
7consistent API for this, and pragmas need to have their import method called \
8directly, since they effect the current unit of compilation. \
9\
10\"Import::Into\" provides global methods to make this painless."
11
12SECTION = "libs"
13
14HOMEPAGE = "https://metacpan.org/pod/Import-Into/"
15
16LICENSE = "Artistic-1.0 | GPL-1.0+"
17LIC_FILES_CHKSUM = "file://README;beginline=209;endline=223;md5=3cf363f1e405dea6db2c6cd0ef23680c"
18
19SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Import-Into-${PV}.tar.gz"
20SRC_URI[md5sum] = "70f2f3b08a5b706ee382a8448c346cb1"
21SRC_URI[sha256sum] = "decb259bc2ff015fe3dac85e4a287d4128e9b0506a0b2c5fa7244836a68b1084"
22
23S = "${WORKDIR}/Import-Into-${PV}"
24
25inherit cpan
26
27RDEPENDS_${PN} = " libmodule-runtime-perl \
28 perl-module-strict \
29 perl-module-warnings \
30"
31
32BBCLASSEXTEND = "native"