diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2019-06-27 21:52:22 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-07-10 09:24:32 -0700 |
commit | df3ccf9e43a3a911dc37e01817c023e305e33203 (patch) | |
tree | 00ec1640541b8ab63026094386d655970959e14f /meta-perl | |
parent | ac46a6d0c307ba545db1399f3eb9cd1bb54c5c81 (diff) | |
download | meta-openembedded-df3ccf9e43a3a911dc37e01817c023e305e33203.tar.gz |
libtest-warn-perl: add recipe for 0.36
ptest dependency for libcgi-perl
NAME
Test::Warn - Perl extension to test methods for warnings
DESCRIPTION
A good style of Perl programming calls for a lot of diverse regression tests.
This module provides a few convenience methods for testing warning based-code.
If you are not already familiar with the Test::More manpage now would be the time to go take a look.
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb b/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb new file mode 100644 index 000000000..c336da80f --- /dev/null +++ b/meta-perl/recipes-perl/libtest/libtest-warn-perl_0.36.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | SUMMARY = "Test::Warn - Perl extension to test methods for warnings" | ||
2 | DESCRIPTION = "This module provides a few convenience methods for testing \ | ||
3 | warning based code. \ | ||
4 | \ | ||
5 | If you are not already familiar with the Test::More manpage now would be \ | ||
6 | the time to go take a look. \ | ||
7 | " | ||
8 | |||
9 | SECTION = "libs" | ||
10 | HOMEPAGE= "https://metacpan.org/release/Test-Warn" | ||
11 | |||
12 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
13 | LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a" | ||
14 | |||
15 | CPAN_PACKAGE = "Test-Warn" | ||
16 | CPAN_AUTHOR = "BIGJ" | ||
17 | |||
18 | SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz" | ||
19 | |||
20 | SRC_URI[md5sum] = "3d958f43d36db263994affde5da09b51" | ||
21 | SRC_URI[sha256sum] = "ecbca346d379cef8d3c0e4ac0c8eb3b2613d737ffaaeae52271c38d7bf3c6cda" | ||
22 | |||
23 | S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}" | ||
24 | |||
25 | inherit cpan ptest-perl | ||
26 | |||
27 | do_install_ptest() { | ||
28 | cp -r ${B}/blib ${D}${PTEST_PATH} | ||
29 | chown -R root:root ${D}${PTEST_PATH} | ||
30 | } | ||
31 | |||
32 | RDEPENDS_${PN} += " \ | ||
33 | libsub-uplevel-perl \ | ||
34 | perl-module-blib \ | ||
35 | perl-module-carp \ | ||
36 | perl-module-test-builder \ | ||
37 | perl-module-test-builder-tester \ | ||
38 | perl-module-test-tester \ | ||
39 | " | ||
40 | |||
41 | RDEPENDS_${PN}-ptest += " \ | ||
42 | perl-module-file-spec \ | ||
43 | perl-module-test-more \ | ||
44 | " | ||
45 | |||
46 | BBCLASSEXTEND = "native nativesdk" | ||