diff options
author | Tim Orling <tim.orling@konsulko.com> | 2024-02-23 10:51:05 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-26 08:13:21 -0800 |
commit | 57de043dd67d9bdeaa6edc9d10d17a9361bd8dbc (patch) | |
tree | 4e82186f04fb54225af205f34ed7606393f32eba /meta-perl | |
parent | 53cdb1c38d7bcd2ed0e854f4da2ec4dbb5025f5c (diff) | |
download | meta-openembedded-57de043dd67d9bdeaa6edc9d10d17a9361bd8dbc.tar.gz |
libencode-perl: drop recipe
Encode.pm is packaged in perl itself and users should
instead RDEPENDS on perl-module-encode
This was originally added a long time ago when I did not understand
the way the packages split was done.
See the other Encode::* sub-packages in:
https://git.openembedded.org/openembedded-core/tree/meta/recipes-devtools/perl/files/perl-rdepends.txt#n313
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
3 files changed, 0 insertions, 112 deletions
diff --git a/meta-perl/conf/include/ptest-packagelists-meta-perl.inc b/meta-perl/conf/include/ptest-packagelists-meta-perl.inc index bb6796f81..717fde29d 100644 --- a/meta-perl/conf/include/ptest-packagelists-meta-perl.inc +++ b/meta-perl/conf/include/ptest-packagelists-meta-perl.inc | |||
@@ -36,7 +36,6 @@ PTESTS_PROBLEMS_META_PERL ="\ | |||
36 | libnet-dns-perl \ | 36 | libnet-dns-perl \ |
37 | libnet-dns-sec-perl \ | 37 | libnet-dns-sec-perl \ |
38 | libnet-ldap-perl \ | 38 | libnet-ldap-perl \ |
39 | libencode-perl \ | ||
40 | libextutils-installpaths-perl \ | 39 | libextutils-installpaths-perl \ |
41 | libfile-slurper-perl \ | 40 | libfile-slurper-perl \ |
42 | libhtml-parser-perl \ | 41 | libhtml-parser-perl \ |
diff --git a/meta-perl/recipes-core/packagegroups/packagegroup-meta-perl.bb b/meta-perl/recipes-core/packagegroups/packagegroup-meta-perl.bb index 2672ab584..c49b3b5a2 100644 --- a/meta-perl/recipes-core/packagegroups/packagegroup-meta-perl.bb +++ b/meta-perl/recipes-core/packagegroups/packagegroup-meta-perl.bb | |||
@@ -100,6 +100,3 @@ RDEPENDS:packagegroup-meta-perl-ptest-packages = "\ | |||
100 | " | 100 | " |
101 | 101 | ||
102 | EXCLUDE_FROM_WORLD = "1" | 102 | EXCLUDE_FROM_WORLD = "1" |
103 | |||
104 | # perl-module-encode is preferred over libencode-perl | ||
105 | # libencode-locale-perl depends on libencode-perl | ||
diff --git a/meta-perl/recipes-perl/libencode/libencode-perl_3.20.bb b/meta-perl/recipes-perl/libencode/libencode-perl_3.20.bb deleted file mode 100644 index 6a083420a..000000000 --- a/meta-perl/recipes-perl/libencode/libencode-perl_3.20.bb +++ /dev/null | |||
@@ -1,108 +0,0 @@ | |||
1 | # NOTE: | ||
2 | # You should use perl-module-encode rather than this package | ||
3 | # unless you specifically need a version newer than what is | ||
4 | # provided by perl. | ||
5 | |||
6 | SUMMARY = "Encode - character encodings" | ||
7 | DESCRIPTION = "The \"Encode\" module provides the interfaces between \ | ||
8 | Perl's strings and the rest of the system. Perl strings are sequences \ | ||
9 | of characters." | ||
10 | |||
11 | HOMEPAGE = "https://metacpan.org/release/Encode" | ||
12 | SECTION = "lib" | ||
13 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" | ||
14 | LIC_FILES_CHKSUM = "file://META.json;beginline=8;endline=10;md5=b12e3be1e17a7e99ca4f429ff32c28b5" | ||
15 | |||
16 | SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz" | ||
17 | SRC_URI[sha256sum] = "ced8fc06c54c05f227bfd9db38c1ed48a5a295db89f497d42b335afbf1f73517" | ||
18 | |||
19 | UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" | ||
20 | |||
21 | S = "${WORKDIR}/Encode-${PV}" | ||
22 | |||
23 | #EXTRA_CPANFLAGS:append = "PERL=../recipe-sysroot-native/usr/bin/perl-native/perl" | ||
24 | inherit cpan ptest-perl | ||
25 | do_install:prepend() { | ||
26 | # Requires "-T" (taint) option on command line | ||
27 | rm -rf ${B}/t/taint.t | ||
28 | # Circular dependency of perl-module-open on perl-module-encode | ||
29 | # and we cannot load perl-module-encode because we are providing | ||
30 | # an alternative | ||
31 | rm -rf ${B}/t/use-Encode-Alias.t | ||
32 | } | ||
33 | |||
34 | do_install:append() { | ||
35 | sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native||g" ${S}/*/*.exh ${S}/*.exh | ||
36 | } | ||
37 | |||
38 | do_install_ptest() { | ||
39 | mkdir ${D}${PTEST_PATH}/bin | ||
40 | cp -r ${B}/bin/piconv ${D}${PTEST_PATH}/bin | ||
41 | cp -r ${B}/blib ${D}${PTEST_PATH} | ||
42 | chown -R root:root ${D}${PTEST_PATH} | ||
43 | } | ||
44 | |||
45 | # file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 | ||
46 | # file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 | ||
47 | # file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 | ||
48 | RCONFLICTS:${PN} = "perl-misc perl-module-encode" | ||
49 | |||
50 | RDEPENDS:${PN} += " \ | ||
51 | perl-module-bytes \ | ||
52 | perl-module-constant \ | ||
53 | perl-module-parent \ | ||
54 | perl-module-storable \ | ||
55 | perl-module-xsloader \ | ||
56 | " | ||
57 | |||
58 | RPROVIDES:${PN} += " \ | ||
59 | libencode-alias-perl \ | ||
60 | libencode-byte-perl \ | ||
61 | libencode-cjkconstants-perl \ | ||
62 | libencode-cn-perl \ | ||
63 | libencode-cn-hz-perl \ | ||
64 | libencode-config-perl \ | ||
65 | libencode-ebcdic-perl \ | ||
66 | libencode-encoder-perl \ | ||
67 | libencode-encoding-perl \ | ||
68 | libencode-gsm0338-perl \ | ||
69 | libencode-guess-perl \ | ||
70 | libencode-jp-perl \ | ||
71 | libencode-jp-h2z-perl \ | ||
72 | libencode-jp-jis7-perl \ | ||
73 | libencode-kr-perl \ | ||
74 | libencode-kr-2022_kr-perl \ | ||
75 | libencode-mime-header-perl \ | ||
76 | libencode-mime-name-perl \ | ||
77 | libencode-symbol-perl \ | ||
78 | libencode-tw-perl \ | ||
79 | libencode-unicode-perl \ | ||
80 | libencode-unicode-utf7-perl \ | ||
81 | libencoding-perl \ | ||
82 | libencode-internal-perl \ | ||
83 | libencode-mime-header-iso_2022_jp-perl \ | ||
84 | libencode-utf8-perl \ | ||
85 | libencode-utf_ebcdic-perl \ | ||
86 | " | ||
87 | |||
88 | RDEPENDS:${PN}-ptest += " \ | ||
89 | perl-module-blib \ | ||
90 | perl-module-charnames \ | ||
91 | perl-module-file-compare \ | ||
92 | perl-module-file-copy \ | ||
93 | perl-module-filehandle \ | ||
94 | perl-module-findbin \ | ||
95 | perl-module-integer \ | ||
96 | perl-module-io-select \ | ||
97 | perl-module-ipc-open3 \ | ||
98 | perl-module-mime-base64 \ | ||
99 | perl-module-perlio \ | ||
100 | perl-module-perlio-encoding \ | ||
101 | perl-module-perlio-scalar \ | ||
102 | perl-module-test-more \ | ||
103 | perl-module-tie-scalar \ | ||
104 | perl-module-unicore \ | ||
105 | perl-module-utf8 \ | ||
106 | " | ||
107 | |||
108 | BBCLASSEXTEND = "native" | ||