diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2019-06-02 11:43:17 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-06-15 16:45:33 -0700 |
commit | 46b52235a3d662731cecc96195e3326f4e15e6a3 (patch) | |
tree | e147d67d31c27ec1a985f7981a252c92fa024dd5 /meta-perl | |
parent | bc9447a9b30cf7bad8067aa91f297d46e3ceb5b3 (diff) | |
download | meta-openembedded-46b52235a3d662731cecc96195e3326f4e15e6a3.tar.gz |
libxml-libxml-perl: enable ptest
Enable ptest and add ptest dependencies
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb | 26 |
1 files changed, 25 insertions, 1 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb index 9753520ae..6fabf2684 100644 --- a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb +++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb | |||
@@ -35,7 +35,7 @@ SRC_URI[libxml.sha256sum] = "f0bca4d0c2da35d879fee4cd13f352014186cedab27ab5e191f | |||
35 | 35 | ||
36 | S = "${WORKDIR}/XML-LibXML-${PV}" | 36 | S = "${WORKDIR}/XML-LibXML-${PV}" |
37 | 37 | ||
38 | inherit cpan | 38 | inherit cpan ptest-perl |
39 | 39 | ||
40 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}" | 40 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}" |
41 | 41 | ||
@@ -45,3 +45,27 @@ CFLAGS += " -D_GNU_SOURCE " | |||
45 | BUILD_CFLAGS += " -D_GNU_SOURCE " | 45 | BUILD_CFLAGS += " -D_GNU_SOURCE " |
46 | 46 | ||
47 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/" | 47 | FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/" |
48 | |||
49 | RDEPENDS_${PN}-ptest += " \ | ||
50 | liburi-perl \ | ||
51 | perl-module-encode-byte \ | ||
52 | perl-module-encode-unicode \ | ||
53 | perl-module-locale \ | ||
54 | perl-module-perlio-scalar \ | ||
55 | perl-module-test-more \ | ||
56 | " | ||
57 | |||
58 | do_install_prepend() { | ||
59 | # test requires "-T" (taint) command line option | ||
60 | rm -rf ${B}/t/pod.t | ||
61 | # this only applies to author build | ||
62 | rm -rf ${B}/t/pod-files-presence.t | ||
63 | } | ||
64 | |||
65 | do_install_ptest() { | ||
66 | cp -r ${B}/t/data ${D}${PTEST_PATH}/t/ | ||
67 | cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/ | ||
68 | cp -r ${B}/example ${D}${PTEST_PATH} | ||
69 | cp -r ${B}/test ${D}${PTEST_PATH} | ||
70 | chown -R root:root ${D}${PTEST_PATH} | ||
71 | } | ||