diff options
author | Jens Rehsack <sno@netbsd.org> | 2020-01-06 14:39:57 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-01-06 19:22:25 -0800 |
commit | 02525e8e0b3a199045ba149775fdd7b7c9752585 (patch) | |
tree | 19e59b193e12954d106c8aa1f9c1fe57769085dd /meta-perl | |
parent | 87234e9d98b1b0a2d82b9f43808ce2e4472121e7 (diff) | |
download | meta-openembedded-02525e8e0b3a199045ba149775fdd7b7c9752585.tar.gz |
libconfig-autoconf-perl: add recipe
Introduce Config::Autoconf module to meta-perl which will allow some
probes can be run without leaving perl5 context.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.318.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.318.bb b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.318.bb new file mode 100644 index 000000000..e4f8fe7e2 --- /dev/null +++ b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.318.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | # Copyright (C) 2020 Jens Rehsack <sno@netbsd.org> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | SUMMARY = "A module to implement some of AutoConf macros in pure perl" | ||
5 | DESCRIPTION = "Config::AutoConf is intended to provide the same opportunities to Perl \ | ||
6 | developers as GNU Autoconf <http://www.gnu.org/software/autoconf/> does for \ | ||
7 | Shell developers." | ||
8 | |||
9 | HOMEPAGE= "https://metacpan.org/release/Config-AutoConf" | ||
10 | |||
11 | SECTION = "libs" | ||
12 | LICENSE = "Artistic-1.0 | GPL-1.0+" | ||
13 | |||
14 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
15 | file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d" | ||
16 | |||
17 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RE/REHSACK/Config-AutoConf-${PV}.tar.gz" | ||
18 | |||
19 | SRC_URI[md5sum] = "0bea721ad3996e20324b84b3b924ec71" | ||
20 | SRC_URI[sha256sum] = "33c930feec3003de251ca222abe8bbeb74610ad07f65fc16f27d74d195eeab34" | ||
21 | RDEPENDS_${PN} += "libcapture-tiny-perl" | ||
22 | RDEPENDS_${PN} += "perl-module-base" | ||
23 | RDEPENDS_${PN} += "perl-module-carp" | ||
24 | RDEPENDS_${PN} += "perl-module-config" | ||
25 | RDEPENDS_${PN} += "perl-module-constant" | ||
26 | RDEPENDS_${PN} += "perl-module-file-basename" | ||
27 | RDEPENDS_${PN} += "perl-module-file-spec" | ||
28 | RDEPENDS_${PN} += "perl-module-file-temp" | ||
29 | RDEPENDS_${PN} += "perl-module-extutils-cbuilder" | ||
30 | RDEPENDS_${PN} += "perl-module-extutils-cbuilder-platform-unix" | ||
31 | RDEPENDS_${PN} += "perl-module-scalar-util" | ||
32 | RDEPENDS_${PN} += "perl-module-strict" | ||
33 | RDEPENDS_${PN} += "perl-module-text-parsewords" | ||
34 | RDEPENDS_${PN} += "perl-module-warnings" | ||
35 | RRECOMMENDS_${PN} += "libfile-slurper-perl" | ||
36 | |||
37 | S = "${WORKDIR}/Config-AutoConf-${PV}" | ||
38 | |||
39 | inherit cpan ptest-perl allarch | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||