summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-08-14 09:13:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:28 +0200
commitdb7471aeb93d50134793dd6d65fa86d91f6c8b66 (patch)
tree795494ba193dbf3a5bc9e7a213e32fe6042cb05c /meta-perl
parent8adc0fffdea86059533baba84e0efd1ba1028050 (diff)
downloadmeta-openembedded-db7471aeb93d50134793dd6d65fa86d91f6c8b66.tar.gz
libstrictures-perl: add 2.000001 recipe
Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000001.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000001.bb b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000001.bb
new file mode 100644
index 000000000..c1de4e7f4
--- /dev/null
+++ b/meta-perl/recipes-perl/libstrictures/libstrictures-perl_2.000001.bb
@@ -0,0 +1,45 @@
1SUMMARY = "strictures - turn on strict and make all warnings fatal"
2DESCRIPTION = "I've been writing the equivalent of this module at the top \
3of my code for about a year now. I figured it was time to make it shorter. \
4\
5Things like the importer in \"use Moose\" don't help me because they turn \
6warnings on but don't make them fatal -- which from my point of view is \
7useless because I want an exception to tell me my code isn't warnings-clean. \
8\
9Any time I see a warning from my code, that indicates a mistake. \
10\
11Any time my code encounters a mistake, I want a crash -- not spew to STDERR \
12and then unknown (and probably undesired) subsequent behaviour. \
13\
14I also want to ensure that obvious coding mistakes, like indirect object \
15syntax (and not so obvious mistakes that cause things to accidentally compile \
16as such) get caught, but not at the cost of an XS dependency and not at the \
17cost of blowing things up on another machine. \
18\
19Therefore, \"strictures\" turns on additional checking, but only when it \
20thinks it's running in a test file in a VCS checkout -- although if this \
21causes undesired behaviour this can be overridden by setting the \
22PERL_STRICTURES_EXTRA environment variable."
23
24SECTION = "libs"
25
26HOMEPAGE = "https://metacpan.org/pod/strictures"
27
28LICENSE = "Artistic-1.0 | GPL-1.0+"
29LIC_FILES_CHKSUM = "file://README;beginline=246;endline=262;md5=43be558cf4f19823cdd6af22135cf5f8"
30
31SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/strictures-${PV}.tar.gz"
32SRC_URI[md5sum] = "fb1350b4af50a2f6ba053c1cfd97e920"
33SRC_URI[sha256sum] = "1e738a8ad63ce8c9b447111c8304ae124a3277c2dc17953b4f647581525e20d3"
34
35S = "${WORKDIR}/strictures-${PV}"
36
37inherit cpan
38
39RDEPENDS_${PN} = " perl-module-carp \
40 perl-module-strict \
41 perl-module-test-more \
42 perl-module-warnings \
43"
44
45BBCLASSEXTEND = "native"