summaryrefslogtreecommitdiffstats
path: root/meta-perl
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2014-08-14 17:13:32 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-21 21:35:05 +0200
commit4a63fbc4f198fb009c457efd49921347c8a58b03 (patch)
tree4279bc5f6dbcc749c26661d3b034bd74f507ecdf /meta-perl
parentd26c204d09c3f69b9b4702244e908bddb2d24e41 (diff)
downloadmeta-openembedded-4a63fbc4f198fb009c457efd49921347c8a58b03.tar.gz
libauthen-sasl-perl: add recipe
Add recipe for libauthen-sasl-perl. Inherit ptest to enable build -ptest sub-package and add file 'run-ptest'. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl')
-rw-r--r--meta-perl/recipes-perl/libauthen/files/run-ptest16
-rw-r--r--meta-perl/recipes-perl/libauthen/libauthen-sasl-perl_2.16.bb30
2 files changed, 46 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libauthen/files/run-ptest b/meta-perl/recipes-perl/libauthen/files/run-ptest
new file mode 100644
index 000000000..c9f9ca94d
--- /dev/null
+++ b/meta-perl/recipes-perl/libauthen/files/run-ptest
@@ -0,0 +1,16 @@
1#!/bin/sh
2
3for case in `find t -type f -name '*.t'`; do
4 perl $case >$case.output 2>&1
5 ret=$?
6 cat $case.output
7 if [ $ret -ne 0 ]; then
8 echo "FAIL: ${case%.t}"
9 elif grep -i 'SKIP' $case.output; then
10 echo "SKIP: ${case%.t}"
11 else
12 echo "PASS: ${case%.t}"
13 fi
14
15 rm -f $case.output
16done
diff --git a/meta-perl/recipes-perl/libauthen/libauthen-sasl-perl_2.16.bb b/meta-perl/recipes-perl/libauthen/libauthen-sasl-perl_2.16.bb
new file mode 100644
index 000000000..361bdf157
--- /dev/null
+++ b/meta-perl/recipes-perl/libauthen/libauthen-sasl-perl_2.16.bb
@@ -0,0 +1,30 @@
1SUMMARY = "SASL Authentication framework for Perl"
2DESCRIPTION = "SASL is a generic mechanism for authentication used by several network \
3protocols. Authen::SASL provides an implementation framework that all \
4protocols should be able to share."
5HOMEPAGE = "http://search.cpan.org/dist/Authen-SASL/"
6SECTION = "libs"
7
8LICENSE = "Artistic-1.0|GPL-1.0+"
9LIC_FILES_CHKSUM = "file://lib/Authen/SASL/Perl.pm;beginline=1;endline=3;md5=17123315bbcda19f484c07227594a609"
10
11DEPENDS = "perl"
12RDEPENDS_${PN} = "libdigest-hmac-perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/G/GB/GBARR/Authen-SASL-${PV}.tar.gz \
15 file://run-ptest \
16 "
17SRC_URI[md5sum] = "7c03a689d4c689e5a9e2f18a1c586b2f"
18SRC_URI[sha256sum] = "6614fa7518f094f853741b63c73f3627168c5d3aca89b1d02b1016dc32854e09"
19
20S = "${WORKDIR}/Authen-SASL-${PV}"
21
22inherit cpan ptest
23
24do_install_ptest () {
25 cp -r ${B}/t ${D}${PTEST_PATH}
26}
27
28PACKAGE_ARCH = "all"
29BBCLASSEXTEND = "native"
30