summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-06-02 11:43:14 -0700
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:33 -0700
commit4058e65f3c4e17ad04423f4c9edf8607fe6fdb4f (patch)
treeea837ad664b6d77755d3a9d3e43dccae9f3e63d6 /meta-perl/recipes-perl
parentcf55ebde9c6bfa01f248992bcefb75236d1fabc5 (diff)
downloadmeta-openembedded-4058e65f3c4e17ad04423f4c9edf8607fe6fdb4f.tar.gz
libhtml-tagset-perl: add recipe for v3.20
This module contains data tables useful in dealing with HTML. It provides no functions or methods. This is a dependency for libhtml-paser-perl. Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl')
-rw-r--r--meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb b/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb
new file mode 100644
index 000000000..d6483cc5f
--- /dev/null
+++ b/meta-perl/recipes-perl/libhtml/libhtml-tagset-perl_3.20.bb
@@ -0,0 +1,29 @@
1SUMMARY = "HTML::Tageset - data tables useful in parsing HTML"
2DESCRIPTION = "This module contains several data tables useful in various \
3kinds of HTML parsing operations."
4HOMEPAGE = "https://metacpan.org/release/HTML-Tagset"
5SECTION = "libs"
6LICENSE = "Artistic-1.0 | GPL-1.0+"
7
8LIC_FILES_CHKSUM = "file://README;beginline=62;endline=66;md5=aa91eed6adfe182d2af676954f06a7c9"
9
10SRC_URI = "${CPAN_MIRROR}/authors/id/P/PE/PETDANCE/HTML-Tagset-${PV}.tar.gz"
11SRC_URI[md5sum] = "d2bfa18fe1904df7f683e96611e87437"
12SRC_URI[sha256sum] = "adb17dac9e36cd011f5243881c9739417fd102fce760f8de4e9be4c7131108e2"
13
14S = "${WORKDIR}/HTML-Tagset-${PV}"
15
16
17inherit cpan ptest-perl
18
19
20RDEPENDS_${PN} += "perl-module-strict perl-module-vars"
21
22RDEPENDS_${PN}-ptest += "perl-module-test"
23
24do_install_prepend() {
25 # requires "-T" (taint) command line option
26 rm -rf ${B}/t/pod.t
27}
28
29BBCLASSEXTEND = "native"