diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2023-10-24 12:12:38 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-10-24 09:08:45 -0700 |
commit | 79e0a9d237343ad0af0a40128494155ccaa131ec (patch) | |
tree | ecf48a6497b2c492e4254246d20b6ed8e21357d8 /meta-perl/recipes-perl | |
parent | e1b332f2eff7df2336ff87917cd48249edf763a2 (diff) | |
download | meta-openembedded-79e0a9d237343ad0af0a40128494155ccaa131ec.tar.gz |
meta-perl: Drop broken BBCLASSEXTEND variants
The command "bitbake universe -c fetch" currently throws a ton of warnings
as there are many 'impossible' dependencies.
In some cases these variants may never have worked and were just added by copy
and paste of recipes. In some cases they once clearly did work but became
broken somewhere along the way. Users may also be carrying local bbappend files
which add further BBCLASSEXTEND.
Having universe fetch work without warnings is desireable so clean up the broken
variants. Anyone actually needing something dropped here can propose adding it
and the correct functional dependencies back quite easily. This also then
ensures we're not carrying or fixing things nobody uses.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl')
5 files changed, 1 insertions, 7 deletions
diff --git a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb index 5db0bb426..5c3701f16 100644 --- a/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb +++ b/meta-perl/recipes-perl/libconfig/libconfig-autoconf-perl_0.319.bb | |||
@@ -38,4 +38,4 @@ S = "${WORKDIR}/Config-AutoConf-${PV}" | |||
38 | 38 | ||
39 | inherit cpan ptest-perl | 39 | inherit cpan ptest-perl |
40 | 40 | ||
41 | BBCLASSEXTEND = "native nativesdk" | 41 | BBCLASSEXTEND = "native" |
diff --git a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.083.bb b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.083.bb index 4d793a4e3..028d9e916 100644 --- a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.083.bb +++ b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_2.083.bb | |||
@@ -52,5 +52,3 @@ RDEPENDS:${PN}-ptest += "\ | |||
52 | do_install_ptest:append () { | 52 | do_install_ptest:append () { |
53 | cp -r ${B}/t/certs ${D}${PTEST_PATH} | 53 | cp -r ${B}/t/certs ${D}${PTEST_PATH} |
54 | } | 54 | } |
55 | |||
56 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.40.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.40.bb index 65616136c..e30125ab7 100644 --- a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.40.bb +++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.40.bb | |||
@@ -62,4 +62,3 @@ python __anonymous () { | |||
62 | d.getVar('TCLIBC')) | 62 | d.getVar('TCLIBC')) |
63 | } | 63 | } |
64 | 64 | ||
65 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb index dcc5ea88b..a77381dce 100644 --- a/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb +++ b/meta-perl/recipes-perl/libnet/libnet-ldap-perl_0.68.bb | |||
@@ -41,5 +41,3 @@ RDEPENDS:${PN}-ptest += " \ | |||
41 | perl-module-perlio \ | 41 | perl-module-perlio \ |
42 | perl-module-test-more \ | 42 | perl-module-test-more \ |
43 | " | 43 | " |
44 | |||
45 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb index c568ade99..cf290d990 100644 --- a/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb +++ b/meta-perl/recipes-perl/libstatgrab/libunix-statgrab_0.112.bb | |||
@@ -37,4 +37,3 @@ export LD = "${CCLD}" | |||
37 | 37 | ||
38 | inherit cpan pkgconfig ptest-perl | 38 | inherit cpan pkgconfig ptest-perl |
39 | 39 | ||
40 | BBCLASSEXTEND = "native" | ||