diff options
author | Sakib Sajal <sakib.sajal@windriver.com> | 2021-12-10 12:33:03 -0500 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-10 18:52:10 -0800 |
commit | daf59fe55a8d8848f4f472154ddf8afe28b5ff5a (patch) | |
tree | 6723df84c994865b78a149475dba5f818c5264a9 /meta-perl/recipes-perl | |
parent | c5e327605ae048015003f0e4e8b88966ecd6e955 (diff) | |
download | meta-openembedded-daf59fe55a8d8848f4f472154ddf8afe28b5ff5a.tar.gz |
io-compress-lzma-perl: add recipe for version 2.096
Add recipe for io-compress-lzma-perl and all the dependencies.
Signed-off-by: Sakib Sajal <sakib.sajal@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl')
5 files changed, 143 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libio/compress-raw-bzip2-perl_2.096.bb b/meta-perl/recipes-perl/libio/compress-raw-bzip2-perl_2.096.bb new file mode 100644 index 000000000..272f7c5f3 --- /dev/null +++ b/meta-perl/recipes-perl/libio/compress-raw-bzip2-perl_2.096.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \ | ||
2 | compression/uncompression functions from the bzip2 compression library." | ||
3 | |||
4 | SECTION = "libs" | ||
5 | LICENSE = "Artisticv1 | GPLv1+" | ||
6 | |||
7 | MAINTAINER= "Poky <poky@yoctoproject.org>" | ||
8 | HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Bzip2" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" | ||
12 | |||
13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-2.096.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "4fdb7ea5071e4b774c52c37331386355" | ||
16 | SRC_URI[sha256sum] = "a564e7634eca7740c5487d01effe1461e9e51b8909e69b3d8f5be98997958cbe" | ||
17 | |||
18 | DEPENDS += "bzip2" | ||
19 | |||
20 | S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}" | ||
21 | |||
22 | inherit cpan | ||
23 | |||
24 | export BUILD_BZIP2="0" | ||
25 | export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}" | ||
26 | |||
27 | do_compile() { | ||
28 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
29 | cpan_do_compile | ||
30 | } | ||
31 | |||
32 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libio/compress-raw-lzma-perl_2.096.bb b/meta-perl/recipes-perl/libio/compress-raw-lzma-perl_2.096.bb new file mode 100644 index 000000000..38655892a --- /dev/null +++ b/meta-perl/recipes-perl/libio/compress-raw-lzma-perl_2.096.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | DESCRIPTION = ""Compress::Raw::Lzma" provides an interface to the in-memory \ | ||
2 | compression/uncompression functions from the lzma compression library." | ||
3 | |||
4 | SECTION = "libs" | ||
5 | LICENSE = "Artisticv1 | GPLv1+" | ||
6 | |||
7 | MAINTAINER= "Poky <poky@yoctoproject.org>" | ||
8 | HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Lzma" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" | ||
12 | |||
13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Lzma-2.096.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "b5079bb43712fcd1e74b80777fa376ed" | ||
16 | SRC_URI[sha256sum] = "f3afb267b1303b0f125976e9e4a70c6a4a205e35e7c99b408911f5e5c6578217" | ||
17 | |||
18 | DEPENDS += "xz" | ||
19 | |||
20 | S = "${WORKDIR}/Compress-Raw-Lzma-${PV}" | ||
21 | |||
22 | inherit cpan | ||
23 | |||
24 | export LIBLZMA_INCLUDE="-I${STAGING_DIR_HOST}${includedir}" | ||
25 | export LIBLZMA_LIB="-I${STAGING_DIR_HOST}${libdir}" | ||
26 | |||
27 | do_compile() { | ||
28 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
29 | cpan_do_compile | ||
30 | } | ||
31 | |||
32 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libio/compress-raw-zlib-perl_2.096.bb b/meta-perl/recipes-perl/libio/compress-raw-zlib-perl_2.096.bb new file mode 100644 index 000000000..8b2ab1459 --- /dev/null +++ b/meta-perl/recipes-perl/libio/compress-raw-zlib-perl_2.096.bb | |||
@@ -0,0 +1,31 @@ | |||
1 | DESCRIPTION = "The *Compress::Raw::Zlib* module provides a Perl interface to the *zlib* \ | ||
2 | compression library (see "AUTHOR" for details about where to get *zlib*)." | ||
3 | |||
4 | SECTION = "libs" | ||
5 | LICENSE = "Artisticv1 | GPLv1+" | ||
6 | |||
7 | MAINTAINER= "Poky <poky@yoctoproject.org>" | ||
8 | HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Zlib" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" | ||
12 | |||
13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Zlib-2.096.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "4144ecdd901231553447998cf8035e4a" | ||
16 | SRC_URI[sha256sum] = "cd4cba20c159a7748b8bc91278524a7da70573d9531fde62298609a5f1c65912" | ||
17 | |||
18 | DEPENDS += "zlib" | ||
19 | |||
20 | S = "${WORKDIR}/Compress-Raw-Zlib-${PV}" | ||
21 | |||
22 | inherit cpan | ||
23 | |||
24 | export BUILD_ZLIB="0" | ||
25 | |||
26 | do_compile() { | ||
27 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
28 | cpan_do_compile | ||
29 | } | ||
30 | |||
31 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libio/io-compress-lzma-perl_2.096.bb b/meta-perl/recipes-perl/libio/io-compress-lzma-perl_2.096.bb new file mode 100644 index 000000000..a5c773551 --- /dev/null +++ b/meta-perl/recipes-perl/libio/io-compress-lzma-perl_2.096.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "This module provides a Perl interface that allows writing lzma compressed \ | ||
2 | data to files or buffer." | ||
3 | |||
4 | SECTION = "libs" | ||
5 | LICENSE = "Artisticv1 | GPLv1+" | ||
6 | |||
7 | MAINTAINER= "Poky <poky@yoctoproject.org>" | ||
8 | HOMEPAGE= "https://metacpan.org/release/IO-Compress-Lzma" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" | ||
12 | |||
13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-Lzma-2.096.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "6c1b70740605b8073e4fbb5ba1e7bbdb" | ||
16 | SRC_URI[sha256sum] = "2f29125f19bb41d29c4b5a2467e3560b7bce5d428176a046b7c8a51609dce6e8" | ||
17 | RDEPENDS:${PN} += "compress-raw-lzma-perl" | ||
18 | RDEPENDS:${PN} += "io-compress-perl" | ||
19 | |||
20 | S = "${WORKDIR}/IO-Compress-Lzma-${PV}" | ||
21 | |||
22 | inherit cpan allarch | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libio/io-compress-perl_2.096.bb b/meta-perl/recipes-perl/libio/io-compress-perl_2.096.bb new file mode 100644 index 000000000..01580db03 --- /dev/null +++ b/meta-perl/recipes-perl/libio/io-compress-perl_2.096.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "This module is not intended for direct use in application code. Its sole \ | ||
2 | purpose is to be sub-classed by IO::Compress modules." | ||
3 | |||
4 | SECTION = "libs" | ||
5 | LICENSE = "Artisticv1 | GPLv1+" | ||
6 | |||
7 | MAINTAINER= "Poky <poky@yoctoproject.org>" | ||
8 | HOMEPAGE= "https://metacpan.org/release/IO-Compress" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d" | ||
12 | |||
13 | SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/IO-Compress-2.096.tar.gz" | ||
14 | |||
15 | SRC_URI[md5sum] = "18ad197cad5ca87bc3a7d2538998e017" | ||
16 | SRC_URI[sha256sum] = "9d219fd5df4b490b5d2f847921e3cb1c3392758fa0bae9b05a8992b3620ba572" | ||
17 | RDEPENDS:${PN} += "compress-raw-bzip2-perl" | ||
18 | RDEPENDS:${PN} += "compress-raw-zlib-perl" | ||
19 | |||
20 | S = "${WORKDIR}/IO-Compress-${PV}" | ||
21 | |||
22 | inherit cpan allarch | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||