summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb
diff options
context:
space:
mode:
authorWenzong Fan <wenzong.fan@windriver.com>2015-07-13 14:43:03 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:03:26 +0200
commit81d8056d4b9bddd002e05c893af70ec58df2ee21 (patch)
treec540ae67cc1467f9711bc5f2996744088b75de68 /meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb
parent92dfaeb997483a4ebc1e51cf0ae612e8ead8515b (diff)
downloadmeta-openembedded-81d8056d4b9bddd002e05c893af70ec58df2ee21.tar.gz
libxml-libxml-perl: update from 2.0116 to 2.0121
update to 2.0121 and clean unused logic: - do_configure_prepend() { - rm -rf ${S}/.pc/* - } Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb
new file mode 100644
index 000000000..8997a0457
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0121.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Perl interface to the libxml2 library"
2DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
3with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
4interface and a XML::XPath-like interface to XPath API of libxml2. \
5The module is split into several packages which are not described in this \
6section; unless stated otherwise, you only need to use XML::LibXML; in \
7your programs."
8
9HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
10SECTION = "libs"
11LICENSE = "Artistic-1.0|GPLv1+"
12DEPENDS += "libxml2 \
13 libxml-sax-perl-native \
14 zlib \
15"
16RDEPENDS_${PN} += "libxml2 \
17 libxml-sax-perl \
18 libxml-sax-base-perl \
19 zlib \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
23 file://disable-libxml2-check.patch \
24 file://fix-CATALOG-conditional-compile.patch \
25 file://using-DOCB-conditional.patch \
26"
27LIC_FILES_CHKSUM = "file://debian/copyright;md5=75e021e35a906347f46c9ff163653e2a \
28 file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446"
29SRC_URI[libxml.md5sum] = "1544ab9ac110f5da296015346561ce02"
30SRC_URI[libxml.sha256sum] = "ec431011cb37a04640fd2316f64d0405a274eece2c6f3847f7fbd336eb1c0dc9"
31
32S = "${WORKDIR}/XML-LibXML-${PV}"
33
34inherit cpan
35
36EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
37
38BBCLASSEXTEND = "native"
39
40CFLAGS += " -D_GNU_SOURCE "
41BUILD_CFLAGS += " -D_GNU_SOURCE "
42
43FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"