diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2018-10-16 23:11:41 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-10-16 23:27:56 -0700 |
commit | 632a6d1221c063c31e03452a45a1065f0da86979 (patch) | |
tree | 7f749aff2a91b58f76f3fa2d6329104ddf0f74c2 /meta-perl/recipes-perl/libnet | |
parent | 104a87a02e1ac810f44bb69be5befc14ee907a81 (diff) | |
download | meta-openembedded-632a6d1221c063c31e03452a45a1065f0da86979.tar.gz |
libnet-dns-perl: upgrade 1.17 -> 1.18; enable ptest
* Add UPSTREAM_CHECK_REGEX to ignore DEV releases
* Add RDEPENDS that were missing
* Enable ptest and add RDEPENDS for tests
* Add RRECOMMENDS for libnet-dns-sec-perl
* Upstream release notes:
"""
**** 1.18 Sep 21, 2018
Documentation revised to remove ambigous use of "answer" which
has been used to refer to both the answer section of a packet
and the entire reply packet received from a nameserver.
Fix rt.cpan.org #127018
Net::DNS::ZoneFile->parse() fails if include directory specified.
Fix rt.cpan.org #127012
DNS resolution broken when options ndots used in /etc/resolv.conf
"""
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libnet')
-rw-r--r-- | meta-perl/recipes-perl/libnet/libnet-dns-perl_1.17.bb | 27 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb | 66 |
2 files changed, 66 insertions, 27 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.17.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.17.bb deleted file mode 100644 index 79583551f..000000000 --- a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.17.bb +++ /dev/null | |||
@@ -1,27 +0,0 @@ | |||
1 | DESCRIPTION = "This package contains the DNS.pm module with friends." | ||
2 | HOMEPAGE = "http://www.net-dns.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "MIT" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=27db37b42cd1a5173a53922d67072bcb" | ||
7 | |||
8 | DEPENDS += "perl" | ||
9 | |||
10 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "28fcbcbf4483a9f23f75be4b9e3e45c8" | ||
13 | SRC_URI[sha256sum] = "9a79fd8fea1a708726c18d193ae4437479206ccb20ffa7f0971371e172e2c2e0" | ||
14 | |||
15 | S = "${WORKDIR}/Net-DNS-${PV}" | ||
16 | |||
17 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" | ||
18 | |||
19 | inherit cpan | ||
20 | |||
21 | RDEPENDS_${PN} = "perl-module-integer" | ||
22 | |||
23 | do_compile() { | ||
24 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" | ||
25 | cpan_do_compile | ||
26 | } | ||
27 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb new file mode 100644 index 000000000..4e0c9c446 --- /dev/null +++ b/meta-perl/recipes-perl/libnet/libnet-dns-perl_1.18.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | DESCRIPTION = "This package contains the DNS.pm module with friends." | ||
2 | HOMEPAGE = "http://www.net-dns.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "MIT" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://README;beginline=252;endline=269;md5=27db37b42cd1a5173a53922d67072bcb" | ||
7 | |||
8 | DEPENDS += "perl" | ||
9 | |||
10 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/N/NL/NLNETLABS/Net-DNS-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "67af7e5c1c339f60c45c1054374bd8ee" | ||
13 | SRC_URI[sha256sum] = "52ce1494fc9707fd5a60ed71db5cde727157b7f2363787d730d4d1bd9800a9d3" | ||
14 | |||
15 | UPSTREAM_CHECK_REGEX = "Net\-DNS\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" | ||
16 | |||
17 | S = "${WORKDIR}/Net-DNS-${PV}" | ||
18 | |||
19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" | ||
20 | |||
21 | inherit cpan ptest-perl | ||
22 | |||
23 | RDEPENDS_${PN} = " \ | ||
24 | libdigest-hmac-perl \ | ||
25 | perl-module-base \ | ||
26 | perl-module-constant \ | ||
27 | perl-module-digest-md5 \ | ||
28 | perl-module-digest-sha \ | ||
29 | perl-module-file-spec \ | ||
30 | perl-module-integer \ | ||
31 | perl-module-io-file \ | ||
32 | perl-module-io-select \ | ||
33 | perl-module-io-socket \ | ||
34 | perl-module-io-socket-ip \ | ||
35 | perl-module-mime-base64 \ | ||
36 | perl-module-scalar-util \ | ||
37 | perl-module-test-more \ | ||
38 | perl-module-time-local \ | ||
39 | " | ||
40 | |||
41 | RRECOMMENDS_${PN} += " \ | ||
42 | libnet-dns-sec-perl \ | ||
43 | " | ||
44 | |||
45 | RDEPENDS_${PN}-ptest += " \ | ||
46 | perl-module-encode \ | ||
47 | perl-module-encode-byte \ | ||
48 | perl-module-extutils-mm \ | ||
49 | perl-module-extutils-mm-unix \ | ||
50 | perl-module-overload \ | ||
51 | " | ||
52 | |||
53 | python __anonymous () { | ||
54 | # rather than use "find" to determine libc-*.so, | ||
55 | # statically export the known paths for glibc and musl | ||
56 | import os | ||
57 | if d.getVar('TCLIBC') == "glibc": | ||
58 | os.environ["LIBC"] = "${STAGING_BASELIBDIR}/libc.so.6" | ||
59 | elif d.getVar('TCLIBC') == "musl": | ||
60 | os.environ["LIBC"] = "${STAGING_LIBDIR}/libc.so" | ||
61 | else: | ||
62 | raise bb.parse.SkipRecipe("incompatible with %s C library" % | ||
63 | d.getVar('TCLIBC')) | ||
64 | } | ||
65 | |||
66 | BBCLASSEXTEND = "native" | ||