summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmodule
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-05-21 00:43:36 -0700
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-06-04 09:52:53 +0100
commit3cdd29838bcf60e4fc0c3c8da59b04d46d182b55 (patch)
tree4fbf719792a157df7ec638a72594dca77a2c9d63 /meta-perl/recipes-perl/libmodule
parentf7a12fddc82bc0565c8364a7647450394cb4bb7a (diff)
downloadmeta-openembedded-3cdd29838bcf60e4fc0c3c8da59b04d46d182b55.tar.gz
libmodule-runtime-perl: add 0.014
[Description from CPAN] The functions exported by this module deal with runtime handling of Perl modules, which are normally handled at compile time. This module avoids using any other modules, so that it can be used in low-level infrastructure. * Add ${CPAN_MIRROR} option * License line numbers changed from 0.013, same LICENSE. Signed-off-by: Tim Orling <TicoTimo@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libmodule')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.014.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.014.bb b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.014.bb
new file mode 100644
index 000000000..d68ae2a88
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.014.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Module::Runtime - runtime module handling"
2DESCRIPTION = "The functions exported by this module deal with runtime \
3handling of Perl modules, which are normally handled at compile time. This \
4module avoids using any other modules, so that it can be used in low-level \
5infrastructure. \
6The parts of this module that work with module names apply the same syntax \
7that is used for barewords in Perl source. In principle this syntax can vary \
8between versions of Perl, and this module applies the syntax of the Perl on \
9which it is running. In practice the usable syntax hasn't changed yet, but \
10there's a good chance of it changing in Perl 5.18. \
11The functions of this module whose purpose is to load modules include \
12workarounds for three old Perl core bugs regarding require. These workarounds \
13are applied on any Perl version where the bugs exist, except for a case where \
14one of the bugs cannot be adequately worked around in pure Perl."
15SECTION = "libs"
16
17HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/"
18
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20LIC_FILES_CHKSUM = "file://README;beginline=43;endline=44;md5=62e24a93342fede7221d66335c716f34"
21
22SRC_URI = "${CPAN_MIRROR}/authors/id/Z/ZE/ZEFRAM/Module-Runtime-${PV}.tar.gz"
23SRC_URI[md5sum] = "a6597bc25536a30476f0d75b64d35734"
24SRC_URI[sha256sum] = "4c44fe0ea255a9fd00741ee545063f6692d2a28e7ef2fbaad1b24a92803362a4"
25
26S = "${WORKDIR}/Module-Runtime-${PV}"
27
28inherit cpan_build
29
30RDEPENDS_${PN} = " perl-module-test-more \
31 perl-module-strict \
32 perl-module-build \
33"
34
35BBCLASSEXTEND = "native"