summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-07-31 07:25:29 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-18 11:38:08 +0200
commiteaf6a6bc51bdc1d5c6f0c8c4fa22f943533be78c (patch)
tree17818eb00c3f4c9b1850c2a5c2f57a5d1fa76b27 /meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb
parent011d69713c7c8439ffccba49c61c72f64e4b52da (diff)
downloadmeta-openembedded-eaf6a6bc51bdc1d5c6f0c8c4fa22f943533be78c.tar.gz
libmodule-runtime-perl: update to 0.015
* Convert from Module::Build to ExtUtils::MakeMaker * Temporarily use github repository until upstream merges change Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb
new file mode 100644
index 000000000..b92842c46
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-runtime-perl_0.015.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Module::Runtime - runtime module handling"
2DESCRIPTION = "The functions exported by this module deal with runtime \
3handling of Perl modules, which are normally handled at compile time. This \
4module avoids using any other modules, so that it can be used in low-level \
5infrastructure. \
6The parts of this module that work with module names apply the same syntax \
7that is used for barewords in Perl source. In principle this syntax can vary \
8between versions of Perl, and this module applies the syntax of the Perl on \
9which it is running. In practice the usable syntax hasn't changed yet, but \
10there's a good chance of it changing in Perl 5.18. \
11The functions of this module whose purpose is to load modules include \
12workarounds for three old Perl core bugs regarding require. These workarounds \
13are applied on any Perl version where the bugs exist, except for a case where \
14one of the bugs cannot be adequately worked around in pure Perl."
15SECTION = "libs"
16
17HOMEPAGE = "http://search.cpan.org/~zefram/Module-Runtime/"
18
19LICENSE = "Artistic-1.0 | GPL-1.0+"
20LIC_FILES_CHKSUM = "file://README;beginline=45;endline=46;md5=62e24a93342fede7221d66335c716f34"
21
22SRCNAME = "module-runtime"
23SRC_URI = "https://github.com/moto-timo/${SRCNAME}/archive/${PV}.tar.gz"
24SRC_URI[md5sum] = "ad6ca179c978aa02ac8aa29244ef9beb"
25SRC_URI[sha256sum] = "59effa82b3f6986d28de6154a8f2428157691004d951f936a81e851f4dbcb045"
26
27S = "${WORKDIR}/${SRCNAME}-${PV}"
28
29inherit cpan
30
31RDEPENDS_${PN} = " perl-module-test-more \
32 perl-module-strict \
33"
34
35BBCLASSEXTEND = "native"