summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libdb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-08-12 08:00:20 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:30 +0200
commitf89374806bbe26cd367b22043b15e16b758a0d67 (patch)
tree98887191a42d30ed2b802606ead640b3c7b892c4 /meta-perl/recipes-perl/libdb
parentf6c27c3479422c54f949feff7346e5f272a7e3e7 (diff)
downloadmeta-openembedded-f89374806bbe26cd367b22043b15e16b758a0d67.tar.gz
libdbi-perl: add version 1.628
The DBI is a database access module for the Perl programming language. It defines a set of methods, variables, and conventions that provide a consistent database interface, independent of the actual database being used. |<- Scope of DBI ->| .-. .--------------. .-------------. .-------. | |---| XYZ Driver |---| XYZ Engine | | Perl | | | `--------------' `-------------' | script| |A| |D| .--------------. .-------------. | using |--|P|--|B|---|Oracle Driver |---|Oracle Engine| | DBI | |I| |I| `--------------' `-------------' | API | | |... |methods| | |... Other drivers `-------' | |... `-' [YOCTO #4128] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libdb')
-rw-r--r--meta-perl/recipes-perl/libdb/libdbi-perl_1.628.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdb/libdbi-perl_1.628.bb b/meta-perl/recipes-perl/libdb/libdbi-perl_1.628.bb
new file mode 100644
index 000000000..38bdf614b
--- /dev/null
+++ b/meta-perl/recipes-perl/libdb/libdbi-perl_1.628.bb
@@ -0,0 +1,26 @@
1SUMMARY = "The Perl Database Interface"
2DESCRIPTION = "DBI is a database access Application Programming Interface \
3(API) for the Perl Language. The DBI API Specification defines a set \
4of functions, variables and conventions that provide a consistent \
5database interface independent of the actual database being used. \
6"
7HOMEPAGE = "http://search.cpan.org/dist/DBI/"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10RDEPENDS_${PN} = " perl-module-carp \
11 perl-module-exporter \
12 perl-module-exporter-heavy \
13 perl-module-dynaloader \
14"
15
16LIC_FILES_CHKSUM = "file://DBI.pm;beginline=8147;endline=8151;md5=7d9e154a9ca3c093d2422f7c692d5861"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz"
19SRC_URI[md5sum] = "4273f8cc6ee3979ce448c7eb3f8a6a5a"
20SRC_URI[sha256sum] = "46c834f4ba1b28c8d8a2db8095835a67fc69a9585761523aea3a74437a969b52"
21
22S = "${WORKDIR}/DBI-${PV}"
23
24inherit cpan
25
26BBCLASSEXTEND = "native"