summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-02-08 08:26:27 +0800
committerKhem Raj <raj.khem@gmail.com>2022-02-08 08:59:08 -0800
commitc13fd3c677127e9010b4db8f90cd22e247787b4a (patch)
tree91506d3fb1b2e6eb32c60336510c90a0df73cd5c /meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb
parent50f547acb715fc4420e2c1d35b553af9bec6292b (diff)
downloadmeta-openembedded-c13fd3c677127e9010b4db8f90cd22e247787b4a.tar.gz
libcgi-perl: upgrade 4.53 -> 4.54
Changelog: ========= - fix use of cache when calling ->cookie - thanks to Sergey Panteleev for the PR Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb')
-rw-r--r--meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb b/meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb
new file mode 100644
index 000000000..bca20f6a4
--- /dev/null
+++ b/meta-perl/recipes-perl/libcgi/libcgi-perl_4.54.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "CGI.pm is a stable, complete and mature solution for processing and preparing \
2HTTP requests and responses. Major features including processing form \
3submissions, file uploads, reading and writing cookies, query string generation \
4and manipulation, and processing and preparing HTTP headers."
5HOMEPAGE = "http://search.cpan.org/~leejo/CGI-4.28/lib/CGI.pod"
6SECTION = "libs"
7LICENSE = "Artistic-2.0 | GPL-2.0"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=415fc49abed2728f9480cd32c8d67beb"
10
11SRC_URI = "http://search.cpan.org/CPAN/authors/id/L/LE/LEEJO/CGI-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "9608a044ae2e87cefae8e69b113e3828552ddaba0d596a02f9954c6ac17fa294"
14
15S = "${WORKDIR}/CGI-${PV}"
16
17inherit cpan ptest-perl
18
19RDEPENDS:${PN} += "\
20 libhtml-parser-perl \
21 perl-module-base \
22 perl-module-deprecate \
23 perl-module-if \
24"
25
26do_install:prepend() {
27 # requires "-T" (taint) command line option
28 rm -rf ${B}/t/push.t
29 rm -rf ${B}/t/utf8.t
30 # tests building of docs
31 rm -rf ${B}/t/compiles_pod.t
32}
33
34RDEPENDS:${PN}-ptest += " \
35 libtest-deep-perl \
36 libtest-warn-perl \
37 perl-module-bytes \
38 perl-module-file-find \
39 perl-module-filehandle \
40 perl-module-findbin \
41 perl-module-lib \
42 perl-module-perlio \
43 perl-module-perlio-scalar \
44 perl-module-test-more \
45 perl-module-utf8 \
46"
47
48RPROVIDES:${PN} += "perl-module-cgi"
49
50BBCLASSEXTEND = "native"