diff options
author | Kai Kang <kai.kang@windriver.com> | 2015-12-21 16:24:13 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-04 14:57:09 +0100 |
commit | 40d6a19aa300eb114ea4aa2de3c27a3fc22706f7 (patch) | |
tree | 6d7b46f47a1a1a6e8f96b323783875fc78189775 /meta-perl/recipes-extended | |
parent | 7a87ed81ed67daa5016a3871a78c0093b5082be7 (diff) | |
download | meta-openembedded-40d6a19aa300eb114ea4aa2de3c27a3fc22706f7.tar.gz |
mime-construct: move from meta-networking to meta-perl
mime-construct only provides a perl script and depends on many perl
modules that cause layer meta-networking depends on meta-perl.
Move mime-construct from meta-networking to meta-perl to avoid the
layer dependency.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-perl/recipes-extended')
-rw-r--r-- | meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch | 39 | ||||
-rw-r--r-- | meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb | 22 |
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch b/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch new file mode 100644 index 000000000..5e4281d4e --- /dev/null +++ b/meta-perl/recipes-extended/mime-construct/files/fix-mime-construct-help-return-value.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From 2b9ed06850410d70371b31de5f131e484ba1c851 Mon Sep 17 00:00:00 2001 | ||
2 | From: Lu Chong <Chong.Lu@windriver.com> | ||
3 | Date: Thu, 17 Oct 2013 16:06:04 +0800 | ||
4 | Subject: [PATCH] fix mime-construct --help return value | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Lu Chong <Chong.Lu@windriver.com> | ||
9 | |||
10 | --- | ||
11 | mime-construct | 5 +++-- | ||
12 | 1 file changed, 3 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/mime-construct b/mime-construct | ||
15 | index cad7d0e..707ed19 100755 | ||
16 | --- a/mime-construct | ||
17 | +++ b/mime-construct | ||
18 | @@ -39,7 +39,7 @@ usage: $Me switch... | ||
19 | |||
20 | Global settings: | ||
21 | --debug turn debugging on | ||
22 | - --help show this and then die | ||
23 | + --help show this | ||
24 | --output don\'t mail, output to stdout (loses bcc info) | ||
25 | --subpart generate subpart rather than whole message (turns | ||
26 | on --output, changes other semantics a bit) | ||
27 | @@ -150,7 +150,8 @@ sub xwarn { | ||
28 | |||
29 | sub usage { | ||
30 | xwarn @_ if @_; | ||
31 | - die $Usage; | ||
32 | + print $Usage; | ||
33 | + exit 0; | ||
34 | } | ||
35 | |||
36 | sub init { | ||
37 | -- | ||
38 | 1.7.9.5 | ||
39 | |||
diff --git a/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb new file mode 100644 index 000000000..9f1a77982 --- /dev/null +++ b/meta-perl/recipes-extended/mime-construct/mime-construct_1.11.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "Construct and optionally mail MIME messages" | ||
2 | DESCRIPTION = "Constructs and (by default) mails MIME messages. \ | ||
3 | It is entirely driven from the command line, it is \ | ||
4 | designed to be used by other programs, or people who act \ | ||
5 | like programs." | ||
6 | HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct" | ||
7 | SECTION = "mail" | ||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96" | ||
10 | |||
11 | SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \ | ||
12 | file://fix-mime-construct-help-return-value.patch \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "73834ea780fbea81b89dbd9b2fb54f58" | ||
16 | SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303" | ||
17 | |||
18 | inherit cpan | ||
19 | |||
20 | RDEPENDS_${PN} = "libmime-types-perl libproc-waitstat-perl msmtp \ | ||
21 | perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \ | ||
22 | " | ||