summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:54 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commitf9ce43cdf6639acaa59d6144aabee798970ca3b6 (patch)
tree4cd53cb95eb5e514d834a65cdbdfa1d8739532c8 /meta-oe
parente5f01cae3885030f8b3c585e62e7dd7f84a278d9 (diff)
downloadmeta-openembedded-f9ce43cdf6639acaa59d6144aabee798970ca3b6.tar.gz
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb2
-rw-r--r--meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb2
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb2
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb2
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb2
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb6
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb2
-rw-r--r--meta-oe/recipes-support/opencv/opencv_3.1.bb2
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc2
9 files changed, 2 insertions, 20 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
index 303a032fb..aeec195fa 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial-native_3.4.1.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/mercurial-${PV}"
14inherit native 14inherit native
15 15
16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ 16EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
17 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} PREFIX=${prefix}" 17 PREFIX=${prefix}"
18 18
19do_configure_append () { 19do_configure_append () {
20 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile 20 sed -i -e 's:PYTHON=python:PYTHON=${STAGING_BINDIR_NATIVE}/python-native/python:g' ${S}/Makefile
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
index a2747c350..e203198af 100644
--- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
+++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
@@ -24,8 +24,6 @@ EXTRA_OECMAKE = "-DLIB='${baselib}' \
24 -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}" 24 -DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}"
25 25
26do_configure_prepend() { 26do_configure_prepend() {
27 export HOST_SYS=${HOST_SYS}
28 export BUILD_SYS=${BUILD_SYS}
29 export STAGING_LIBDIR=${STAGING_LIBDIR} 27 export STAGING_LIBDIR=${STAGING_LIBDIR}
30 export STAGING_INCDIR=${STAGING_INCDIR} 28 export STAGING_INCDIR=${STAGING_INCDIR}
31 export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR} 29 export ENV_INSTALL_PATH=${PYTHON_SITEPACKAGES_DIR}
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
index 86628b14b..9848e5ac1 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -15,8 +15,6 @@ DEPENDS += "cups python libusb"
15 15
16inherit autotools-brokensep python-dir pythonnative pkgconfig 16inherit autotools-brokensep python-dir pythonnative pkgconfig
17 17
18export BUILD_SYS
19export HOST_SYS
20export STAGING_INCDIR 18export STAGING_INCDIR
21export STAGING_LIBDIR 19export STAGING_LIBDIR
22 20
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
index 52b271c11..af9633d40 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.2.bb
@@ -39,8 +39,6 @@ EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
39 " 39 "
40 40
41do_configure_prepend() { 41do_configure_prepend() {
42 export HOST_SYS=${HOST_SYS}
43 export BUILD_SYS=${BUILD_SYS}
44 export STAGING_INCDIR=${STAGING_INCDIR} 42 export STAGING_INCDIR=${STAGING_INCDIR}
45 export STAGING_LIBDIR=${STAGING_LIBDIR} 43 export STAGING_LIBDIR=${STAGING_LIBDIR}
46} 44}
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
index 73a5d0e5b..a43e77029 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.5.4.bb
@@ -50,8 +50,6 @@ EXTRA_OECONF = " \
50 --disable-rpath \ 50 --disable-rpath \
51" 51"
52 52
53export BUILD_SYS
54export HOST_SYS
55export STAGING_LIBDIR 53export STAGING_LIBDIR
56export STAGING_INCDIR 54export STAGING_INCDIR
57 55
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index aef9b138a..6b883a87e 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -55,9 +55,6 @@ do_compile_prepend() {
55 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}" 55 export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
56 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config" 56 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
57 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}" 57 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
58
59 export BUILD_SYS="${BUILD_SYS}"
60 export HOST_SYS="${HOST_SYS}"
61} 58}
62 59
63do_install() { 60do_install() {
@@ -65,9 +62,6 @@ do_install() {
65 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config" 62 export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
66 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}" 63 export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
67 64
68 export BUILD_SYS="${BUILD_SYS}"
69 export HOST_SYS="${HOST_SYS}"
70
71 export DESTDIR="${D}" 65 export DESTDIR="${D}"
72 # prefix is used for RPATH and DESTDIR/prefix for instalation 66 # prefix is used for RPATH and DESTDIR/prefix for instalation
73 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \ 67 ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index eb38a5a6a..83e7de8c0 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -50,8 +50,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
50 50
51inherit distutils-base pkgconfig cmake 51inherit distutils-base pkgconfig cmake
52 52
53export BUILD_SYS
54export HOST_SYS
55export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" 53export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
56export PYTHON="${STAGING_BINDIR_NATIVE}/python" 54export PYTHON="${STAGING_BINDIR_NATIVE}/python"
57 55
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb
index 789512f9e..961b9cba0 100644
--- a/meta-oe/recipes-support/opencv/opencv_3.1.bb
+++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb
@@ -70,8 +70,6 @@ PACKAGECONFIG[v4l] = "-DWITH_V4L=ON,-DWITH_V4L=OFF,v4l-utils,"
70 70
71inherit distutils-base pkgconfig cmake 71inherit distutils-base pkgconfig cmake
72 72
73export BUILD_SYS
74export HOST_SYS
75export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}" 73export PYTHON_CSPEC="-I${STAGING_INCDIR}/${PYTHON_DIR}"
76export PYTHON="${STAGING_BINDIR_NATIVE}/python" 74export PYTHON="${STAGING_BINDIR_NATIVE}/python"
77export JAVA_HOME="${STAGING_DIR_NATIVE}/usr/bin/java" 75export JAVA_HOME="${STAGING_DIR_NATIVE}/usr/bin/java"
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index 288a2d183..32ffe190b 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -113,7 +113,7 @@ python populate_packages_prepend() {
113do_configure() { 113do_configure() {
114 # do_configure_prepend 114 # do_configure_prepend
115 # make sure configure finds python includdirs with these envs 115 # make sure configure finds python includdirs with these envs
116 export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ 116 export \
117 STAGING_INCDIR=${STAGING_INCDIR} \ 117 STAGING_INCDIR=${STAGING_INCDIR} \
118 STAGING_LIBDIR=${STAGING_LIBDIR} 118 STAGING_LIBDIR=${STAGING_LIBDIR}
119 119