summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-05-23 11:55:00 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-24 10:11:28 -0700
commite6d9392ebb2a666290b31c4a67d1c9205ce642ed (patch)
tree05946f3ee17b3f46fd0a941a2f106df34a5f7db4 /meta-oe
parent4ef340551ff3e0ec74f1e10959108ba7e57f18c9 (diff)
downloadmeta-openembedded-e6d9392ebb2a666290b31c4a67d1c9205ce642ed.tar.gz
funyahoo-plusplus, icyque, pidgin-sipe, purple-skypeweb: add couple plugins for pidgin
* import from luneos to make pidgin here in meta-oe a bit more useful Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb25
-rw-r--r--meta-oe/recipes-support/pidgin/icyque_git.bb27
-rw-r--r--meta-oe/recipes-support/pidgin/pidgin-sipe_1.24.0.bb34
-rw-r--r--meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb26
4 files changed, 112 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb b/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
new file mode 100644
index 000000000..3a437659e
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/funyahoo-plusplus_git.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Protocol plugin for New Yahoo (2016) for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
3LICENSE = "GPLv3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
5
6DEPENDS = "pidgin json-glib glib-2.0"
7
8inherit pkgconfig
9
10SRC_URI = "git://github.com/EionRobb/funyahoo-plusplus;branch=master;protocol=git"
11SRCREV = "fbbd9c591100aa00a0487738ec7b6acd3d924b3f"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 oe_runmake CC="${CC}" CXX="${CXX}" EXTRA_INCLUDES="${TARGET_CFLAGS}" AR="${AR}";
17}
18
19do_install() {
20 oe_runmake DESTDIR="${D}" install;
21}
22
23FILES_${PN} += " \
24 ${libdir} \
25"
diff --git a/meta-oe/recipes-support/pidgin/icyque_git.bb b/meta-oe/recipes-support/pidgin/icyque_git.bb
new file mode 100644
index 000000000..0f32dc3a3
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/icyque_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "WIM Protocol plugin for ICQ for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
3LICENSE = "GPLv3.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6DEPENDS = "pidgin json-glib"
7
8PV = "0.1+gitr${SRCPV}"
9
10inherit pkgconfig
11
12SRC_URI = "git://github.com/EionRobb/icyque"
13SRCREV = "513fc162d5d1a201c2b044e2b42941436d1069d5"
14
15S = "${WORKDIR}/git"
16
17do_compile() {
18 oe_runmake;
19}
20
21do_install() {
22 oe_runmake DESTDIR="${D}" install;
23}
24
25FILES_${PN} += " \
26 ${libdir} \
27"
diff --git a/meta-oe/recipes-support/pidgin/pidgin-sipe_1.24.0.bb b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.24.0.bb
new file mode 100644
index 000000000..beae281a3
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/pidgin-sipe_1.24.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Protocol plugin for Office 365/Lync/OCS for Adium, Pidgin, Miranda and Telepathy IM Framework"
2SECTION = "webos/services"
3LICENSE = "GPLv2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6DEPENDS = "pidgin intltool-native glib-2.0-native"
7
8inherit pkgconfig
9inherit autotools
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/sipe/pidgin-sipe-${PV}.tar.xz \
12"
13
14SRC_URI[md5sum] = "b91106d28c235b347a63dcb676f7b66a"
15SRC_URI[sha256sum] = "958803722b23d869131f76bd90df9da19116d4ca5a873e5253371479b7390f43"
16
17PACKAGECONFIG ??= "nss krb5"
18PACKAGECONFIG[nss] = "--enable-nss=yes,--enable-nss=no,nss"
19PACKAGECONFIG[openssl] = "--enable-openssl=yes,--enable-openssl=no,openssl"
20PACKAGECONFIG[krb5] = "--with-krb5=yes,--with-krb5=no,krb5"
21#PACKAGECONFIG[voice_and_video] = "--with-vv=yes,--with-vv=no,libnice gstreamer"
22PACKAGECONFIG[telepathy] = "--enable-telepathy=yes,--enable-telepathy=no,telepathy-glib gmime"
23#PACKAGECONFIG[gssapi_only] = "--enable-gssapi-only=yes,--enable-gssapi-only=no,krb5"
24PACKAGECONFIG[debug] = "--enable-debug=yes,--enable-debug=no,valgrind"
25
26FILES_${PN}-dev += " \
27 ${libdir}/purple-2/*.la \
28"
29
30FILES_${PN} += " \
31 ${libdir}/purple-2/libsipe.so \
32 ${datadir}/appdata \
33 ${datadir}/metainfo \
34"
diff --git a/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb b/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb
new file mode 100644
index 000000000..092e6059b
--- /dev/null
+++ b/meta-oe/recipes-support/pidgin/purple-skypeweb_git.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Skype protocol plug-in for libpurple"
2SECTION = "webos/services"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://skypeweb/gpl3.txt;md5=d90260d32cef39f3c8d6c0f05d3adb8e"
5
6DEPENDS = "pidgin json-glib glib-2.0 zlib"
7
8inherit pkgconfig
9
10SRC_URI = "git://github.com/EionRobb/skype4pidgin;branch=master;protocol=git"
11SRCREV = "14f1b69b6292bbdc98cca484b050ec8359394c4e"
12
13S = "${WORKDIR}/git"
14PV = "1.5+git${SRCPV}"
15
16do_compile() {
17 oe_runmake -C skypeweb;
18}
19
20do_install() {
21 oe_runmake -C skypeweb DESTDIR="${D}" install;
22}
23
24FILES_${PN} += " \
25 ${libdir} \
26"