summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-18 17:15:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-24 15:31:50 +0200
commitd98907203cc2653eee1db998e30d129c9c9a063a (patch)
treeaa942bf377f455d06d7120da61acaf85bb80f442 /meta-oe
parent1a6e16bcb1145df51b15c19df0d7ef655b683f5e (diff)
downloadmeta-openembedded-d98907203cc2653eee1db998e30d129c9c9a063a.tar.gz
syslog-ng: Various fixes
* Add PACKAGECONFIG for floating json dependency * Add PACKAGECONFIG for floating tcp-wrappers dependency * Disable mongodb host infection problem * Disable rabbitmq host infection problem * Add patch for dbi host include flags issue (making dbi conditionall really work) * Fix configure automake flags handling Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.patch31
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/dbifix.patch20
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc4
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb2
4 files changed, 57 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.patch b/meta-oe/recipes-support/syslog-ng/files/configure.patch
new file mode 100644
index 000000000..136bb5eb1
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/files/configure.patch
@@ -0,0 +1,31 @@
1Index: syslog-ng-3.5.4.1/configure.ac
2===================================================================
3--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 13:49:36.794141441 +0000
4+++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 14:23:57.738197606 +0000
5@@ -8,15 +8,16 @@
6 dnl BINARY_BRANCH - the value is added to all source/binary packages
7 dnl SOURCE_REVISION - Revision of the source-tree, will added to the version string
8 dnl
9-AC_INIT(syslog-ng/main.c)
10+AC_INIT(syslog-ng, 3.5.4.1)
11+AC_CONFIG_SRCDIR(syslog-ng/main.c)
12 AC_CONFIG_MACRO_DIR([m4])
13 m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
14
15 dnl ***************************************************************************
16 dnl definitions
17
18 PACKAGE="syslog-ng"
19 VERSION="`cat $srcdir/VERSION`"
20
21 dnl ***************************************************************************
22 dnl dependencies
23@@ -53,7 +56,7 @@
24 CURRDATE=`date +"%a, %d %b %Y %H:%M:%S %Z"`
25 fi
26
27-AM_INIT_AUTOMAKE($PACKAGE, $VERSION, [foreign no-define subdir-objects])
28+AM_INIT_AUTOMAKE([foreign no-define subdir-objects])
29 _AM_PROG_TAR([ustar])
30 if test -n "$SNAPSHOT_VERSION"; then
31 VERSION=$VERSION+$SNAPSHOT_VERSION
diff --git a/meta-oe/recipes-support/syslog-ng/files/dbifix.patch b/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
new file mode 100644
index 000000000..15dfb6885
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/files/dbifix.patch
@@ -0,0 +1,20 @@
1Index: syslog-ng-3.5.4.1/configure.ac
2===================================================================
3--- syslog-ng-3.5.4.1.orig/configure.ac 2014-07-18 14:35:03.134215740 +0000
4+++ syslog-ng-3.5.4.1/configure.ac 2014-07-18 15:31:52.510308653 +0000
5@@ -576,13 +576,14 @@
6 dnl ***************************************************************************
7
8 AC_CHECK_LIB(dl, dlsym, DL_LIBS="-ldl")
9+if test "x$enable_sql" != "xno"; then
10 PKG_CHECK_MODULES(LIBDBI, dbi >= $LIBDBI_MIN_VERSION, libdbi_pkgconfig_not_found="0", libdbi_pkgconfig_not_found="1")
11
12 if test "$libdbi_pkgconfig_not_found" -eq 1; then
13 dnl if libdbi has no .pc file, try it without one
14 AC_CHECK_LIB(dbi, dbi_initialize, LIBDBI_LIBS="-ldbi"; LIBDBI_CFLAGS="-I/usr/include")
15 fi
16-
17+fi
18 if test "x$enable_sql" = "xauto"; then
19 AC_MSG_CHECKING(whether to enable SQL support)
20 if test "x$LIBDBI_LIBS" != "x"; then
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 01c9b202c..3cedba65b 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -30,6 +30,8 @@ EXTRA_OECONF = " \
30 --sysconfdir=${sysconfdir}/${BPN} \ 30 --sysconfdir=${sysconfdir}/${BPN} \
31 --with-module-dir=${libdir}/${BPN} \ 31 --with-module-dir=${libdir}/${BPN} \
32 --with-sysroot=${STAGING_DIR_HOST} \ 32 --with-sysroot=${STAGING_DIR_HOST} \
33 --with-libmongo-client=no --disable-mongodb \
34 --with-librabbitmq-client=no \
33" 35"
34 36
35PACKAGECONFIG ??= "openssl \ 37PACKAGECONFIG ??= "openssl \
@@ -44,6 +46,8 @@ PACKAGECONFIG[pcre] = "--enable-pcre,--disable-pcre,libpcre,"
44PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi," 46PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi,"
45PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet," 47PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet,"
46PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp," 48PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp,"
49PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
50PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers,"
47 51
48do_configure_prepend() { 52do_configure_prepend() {
49 eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}" 53 eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
index 12b0dc32b..d5939e462 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng_3.5.4.1.bb
@@ -11,6 +11,8 @@ SRC_URI += " \
11 file://free-global-LogTemplateOptions.patch \ 11 file://free-global-LogTemplateOptions.patch \
12 file://logwriter-still-free-the-unconsumed-item.patch \ 12 file://logwriter-still-free-the-unconsumed-item.patch \
13 file://syslog-ng-verify-the-list-before-del.patch \ 13 file://syslog-ng-verify-the-list-before-del.patch \
14 file://configure.patch \
15 file://dbifix.patch \
14" 16"
15 17
16SRC_URI[md5sum] = "ff3bf223ebafbaa92b69a2d5b729f368" 18SRC_URI[md5sum] = "ff3bf223ebafbaa92b69a2d5b729f368"