summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-04-11 09:50:13 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 11:19:09 +0200
commitcba5550dd801c8ef1f61af799319010d31442d04 (patch)
tree655cf428a55d1e8087b6cc399a04b0cbcd9c84ab /meta-oe
parent3852219dcd40834a359d01d01633036ab970b834 (diff)
downloadmeta-openembedded-cba5550dd801c8ef1f61af799319010d31442d04.tar.gz
bonnie++: update to version 1.03e
Changes: * use BPN in the file name in SRC_URI. * install binaries in bindir and sbindir instead of base_bindir and base_sbindir. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb32
-rw-r--r--meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb30
2 files changed, 30 insertions, 32 deletions
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
deleted file mode 100644
index bff0d727e..000000000
--- a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03c.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "Tests large file IO and creation/deletion of small files"
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
5
6SRC_URI = "http://www.coker.com.au/bonnie++/bonnie++-${PV}.tgz \
7 file://gcc-4.3-fixes.patch \
8"
9SRC_URI[md5sum] = "77a1ba78f37bdd7f024b67e1e36ad151"
10SRC_URI[sha256sum] = "c674f1182f4c20f1e6d038feceb0a6617fc3e7658dfbbac89396043b49612a26"
11
12inherit autotools
13
14SCRIPTS = "bon_csv2html bon_csv2txt"
15EXES = "bonnie++ zcav"
16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19do_install () {
20 install -d ${D}/bin
21 install -d ${D}/sbin
22 install -m 0755 ${EXES} ${D}/sbin
23 install -m 0755 ${SCRIPTS} ${D}/bin
24}
25
26PACKAGES =+ "bonnie-scripts"
27
28FILES_${PN} = "${base_sbindir}"
29FILES_bonnie-scripts = "${base_bindir}"
30
31
32
diff --git a/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb
new file mode 100644
index 000000000..828d762ea
--- /dev/null
+++ b/meta-oe/recipes-benchmark/bonnie/bonnie++_1.03e.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Tests large file IO and creation/deletion of small files"
2HOMEPAGE = "http://www.coker.com.au/bonnie++/"
3SECTION = "benchmark/tests"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://copyright.txt;md5=cd4dde95a6b9d122f0a9150ae9cc3ee0"
6
7SRC_URI = "http://www.coker.com.au/bonnie++/${BPN}-${PV}.tgz \
8 file://gcc-4.3-fixes.patch \
9"
10SRC_URI[md5sum] = "750aa5b5051263a99c6c195888c74968"
11SRC_URI[sha256sum] = "cb3866116634bf65760b6806be4afa7e24a1cad6f145c876df8721f01ba2e2cb"
12
13inherit autotools
14
15SCRIPTS = "bon_csv2html bon_csv2txt"
16EXES = "bonnie++ zcav"
17
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20do_install () {
21 install -d ${D}/${bindir}
22 install -d ${D}/${sbindir}
23 install -m 0755 ${EXES} ${D}/${sbindir}
24 install -m 0755 ${SCRIPTS} ${D}/${bindir}
25}
26
27PACKAGES =+ "bonnie-scripts"
28
29FILES_${PN} = "${sbindir}"
30FILES_bonnie-scripts = "${bindir}"