summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-10-11 12:06:57 -0400
committerKhem Raj <raj.khem@gmail.com>2019-10-11 17:09:41 -0700
commita73d898f31236cd83d82c33754a594898acf3016 (patch)
tree954f185d8488ce83aaeb0dc9085880bea25db00a /meta-oe
parent663493e98883ada2a13a6e873700ed0eda654bb3 (diff)
downloadmeta-openembedded-a73d898f31236cd83d82c33754a594898acf3016.tar.gz
rsyslog: fix CVE-2019-17040
Backport CVE-2019-17040 fix to zeus. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog/0001-Out-of-bounds-issue.patch31
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.1908.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog/0001-Out-of-bounds-issue.patch b/meta-oe/recipes-extended/rsyslog/rsyslog/0001-Out-of-bounds-issue.patch
new file mode 100644
index 000000000..b494ca687
--- /dev/null
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog/0001-Out-of-bounds-issue.patch
@@ -0,0 +1,31 @@
1From b0894088b680666035a3418326e13bc99d4fed49 Mon Sep 17 00:00:00 2001
2From: Philippe Duveau <pduveau@users.noreply.github.com>
3Date: Tue, 24 Sep 2019 20:45:25 +0200
4Subject: [PATCH] Out of bounds issue
5
6Add a new sanity check after determining the level len.
7---
8 contrib/pmdb2diag/pmdb2diag.c | 4 ++++
9 1 file changed, 4 insertions(+)
10
11Upstream-Status: Backport [https://github.com/rsyslog/rsyslog/commit/b0894088b6]
12CVE: CVE-2019-17040
13Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
14diff --git a/contrib/pmdb2diag/pmdb2diag.c b/contrib/pmdb2diag/pmdb2diag.c
15index 2b5916301..5810eb4df 100644
16--- a/contrib/pmdb2diag/pmdb2diag.c
17+++ b/contrib/pmdb2diag/pmdb2diag.c
18@@ -134,6 +134,10 @@ CODESTARTparse2
19 ABORT_FINALIZE(0);
20 }
21
22+ /* let recheck with the real level len */
23+ if(pMsg->iLenRawMsg - (int)pMsg->offAfterPRI < pInst->levelpos+lvl_len)
24+ ABORT_FINALIZE(RS_RET_COULD_NOT_PARSE);
25+
26 DBGPRINTF("db2parse Level %d\n", pMsg->iSeverity);
27
28 end = (char*)pMsg->pszRawMsg + pMsg->iLenRawMsg ;
29--
302.17.1
31
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.1908.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.1908.0.bb
index bbb4b119a..bd0dbc1a2 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.1908.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.1908.0.bb
@@ -23,6 +23,7 @@ SRC_URI = "http://www.rsyslog.com/download/files/download/rsyslog/${BPN}-${PV}.t
23 file://rsyslog.logrotate \ 23 file://rsyslog.logrotate \
24 file://use-pkgconfig-to-check-libgcrypt.patch \ 24 file://use-pkgconfig-to-check-libgcrypt.patch \
25 file://run-ptest \ 25 file://run-ptest \
26 file://0001-Out-of-bounds-issue.patch \
26" 27"
27 28
28SRC_URI_append_libc-musl = " \ 29SRC_URI_append_libc-musl = " \