summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-08-27 12:16:11 +0800
committerKhem Raj <raj.khem@gmail.com>2018-08-27 10:53:58 -0700
commita24b4c1bbead01a94d8ac26adb4657c29592cb52 (patch)
tree8c86d1b2f1664db21009c3a47edf2f2b3a20c886 /meta-oe
parenteac9bd96cefbddb131ee5ec30a02c08749fbb6ca (diff)
downloadmeta-openembedded-a24b4c1bbead01a94d8ac26adb4657c29592cb52.tar.gz
lmbench: fix usrmerge install path
Rework the patch use-base_libdir-instead-of-hardcoded-lib.patch to 0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch to fix the below do_install error when usrmerge enabled in DISTRO_FEATURES and also fix the lib name from lmbench.a to libmbench.a | if [ ! -d /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64 ]; then mkdir /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64; fi | mkdir: cannot create directory /poky-build/tmp-glibc/work/core2-64-wrs-linux/lmbench/3.0-a9-r2/image/usr/usr/lib64 No such file or directory | Makefile:141: recipe for target 'install-target' failed | make[1]: *** [install-target] Error 1 Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch (renamed from meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch)24
-rw-r--r--meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb3
2 files changed, 16 insertions, 11 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch
index c6e9465ac..04cef960f 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/use-base_libdir-instead-of-hardcoded-lib.patch
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch
@@ -1,30 +1,34 @@
1From 73fdc58ca4eb9e2f24d854b3af3a4e5daac5a33e Mon Sep 17 00:00:00 2001 1From ea683a0dbaa30a0bf101adb09a1a2531c7112c62 Mon Sep 17 00:00:00 2001
2From: Ting Liu <b28495@freescale.com> 2From: Mingli Yu <Mingli.Yu@windriver.com>
3Date: Fri, 22 Nov 2013 15:20:08 +0800 3Date: Mon, 27 Aug 2018 11:02:45 +0800
4Subject: [PATCH] use base_libdir instead of hardcoded /lib 4Subject: [PATCH] src/Makefile: use libdir instead of hardcoded /lib
5 5
6Upstream Status: Inappropriate [configuration] 6use libdir instead of hardcoded /lib
7 7
8Signed-off-by: Ting Liu <b28495@freescale.com> 8Upstream-Status: Inappropriate [configuration]
9 9
10Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
10--- 11---
11 src/Makefile | 4 ++-- 12 src/Makefile | 4 ++--
12 1 file changed, 2 insertions(+), 2 deletions(-) 13 1 file changed, 2 insertions(+), 2 deletions(-)
13 14
14diff --git a/src/Makefile b/src/Makefile 15diff --git a/src/Makefile b/src/Makefile
15index c7a8c79..c7e4e3c 100644 16index 4678d54..b73ddb6 100644
16--- a/src/Makefile 17--- a/src/Makefile
17+++ b/src/Makefile 18+++ b/src/Makefile
18@@ -143,10 +143,10 @@ install-target: 19@@ -141,10 +141,10 @@ install-target:
19 if [ ! -d $(BASE) ]; then mkdir $(BASE); fi 20 if [ ! -d $(BASE) ]; then mkdir $(BASE); fi
20 if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi 21 if [ ! -d $(BASE)/bin ]; then mkdir $(BASE)/bin; fi
21 if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi 22 if [ ! -d $(BASE)/include ]; then mkdir $(BASE)/include; fi
22- if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi 23- if [ ! -d $(BASE)/lib ]; then mkdir $(BASE)/lib; fi
23+ if [ ! -d $(BASE)$(base_libdir) ]; then mkdir $(BASE)$(base_libdir); fi 24+ if [ ! -d $(DESTDIR)$(libdir) ]; then mkdir $(DESTDIR)$(libdir); fi
24 cp $(EXES) $(BASE)/bin 25 cp $(EXES) $(BASE)/bin
25 cp $(INCS) $(BASE)/include 26 cp $(INCS) $(BASE)/include
26- cp $O/lmbench.a $(BASE)/lib/libmbench.a 27- cp $O/lmbench.a $(BASE)/lib/libmbench.a
27+ cp $O/lmbench.a $(BASE)$(base_libdir) 28+ cp $O/lmbench.a $(DESTDIR)$(libdir)/libmbench.a
28 cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install 29 cd ../doc; env MAKEFLAGS="$(MAKEFLAGS)" make CC="${CC}" OS="${OS}" BASE="$(BASE)" install
29 30
30 31
32--
332.7.4
34
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
index 593b62f01..8e6e803a8 100644
--- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
+++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb
@@ -19,13 +19,13 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \
19 file://update-results-script.patch \ 19 file://update-results-script.patch \
20 file://obey-ranlib.patch \ 20 file://obey-ranlib.patch \
21 file://update-config-script.patch \ 21 file://update-config-script.patch \
22 file://use-base_libdir-instead-of-hardcoded-lib.patch \
23 file://lmbench_result_html_report.patch \ 22 file://lmbench_result_html_report.patch \
24 file://fix-lmbench-memory-check-failure.patch \ 23 file://fix-lmbench-memory-check-failure.patch \
25 file://0001-avoid-gcc-optimize-away-the-loops.patch \ 24 file://0001-avoid-gcc-optimize-away-the-loops.patch \
26 file://0001-lat_http.c-Add-printf-format.patch \ 25 file://0001-lat_http.c-Add-printf-format.patch \
27 file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \ 26 file://0001-Check-for-musl-define-guard-before-redefining-sockle.patch \
28 file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \ 27 file://0002-build-Adjust-CFLAGS-LDFLAGS-to-append-values-passed-.patch \
28 file://0001-src-Makefile-use-libdir-instead-of-hardcoded-lib.patch \
29 " 29 "
30SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" 30SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf"
31SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" 31SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551"
@@ -66,6 +66,7 @@ do_install () {
66 fi 66 fi
67 67
68 oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \ 68 oe_runmake BASE="${D}${prefix}" MANDIR="${D}${mandir}" \
69 DESTDIR="${D}" \
69 -C src install 70 -C src install
70 mv ${D}${bindir}/line ${D}${bindir}/lm_line 71 mv ${D}${bindir}/line ${D}${bindir}/lm_line
71 install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/ 72 install -m 0755 ${WORKDIR}/lmbench-run ${D}${bindir}/