summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2013-01-25 19:24:26 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-01-27 22:35:42 +0100
commit2248f8557e9b741bbe1417f128fd35fc51013d33 (patch)
tree19ddd331c64924ab1dc07f7f8f39829c708ca0d6 /meta-oe
parenta4ad72a9919ab58305c034ca9caf53baa54264f3 (diff)
downloadmeta-openembedded-2248f8557e9b741bbe1417f128fd35fc51013d33.tar.gz
gnuradio : Use PACKAGECONFIG so users can tweak build options.
I hear from users that they are fiddling with the recipe to build gnuradio with different options for various purposes. Start adding PACKAGECONFIG support to reduce user editing of the recipe. Currently these options are supported: uhd : enable support for UHD based hardware. grc: Build gnuradio companion. qtgui: Build the qtgui component. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb30
1 files changed, 26 insertions, 4 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index e1a023f54..85f52fcde 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -4,8 +4,17 @@ SECTION = "apps"
4LICENSE = "GPLv3" 4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6 6
7DEPENDS = "uhd gsl fftwf python alsa-lib boost cppunit \ 7DEPENDS = "gsl fftwf python alsa-lib boost cppunit \
8 swig-native python-numpy python-pygtk orc qt4-x11-free qwt" 8 swig-native python-numpy python-cheetah-native orc"
9
10#Available PACKAGECONFIG options are qt grc uhd
11PACKAGECONFIG ??= "qtgui grc uhd"
12
13PACKAGECONFIG[uhd] = "-DENABLE_GR_UHD=ON,-DENABLE_GR_UHD=OFF,uhd,"
14PACKAGECONFIG[grc] = "-DENABLE_GRC=ON,-DENABLE_GRC=OFF,python-pygtk python-cheetah, "
15
16PACKAGECONFIG[qtgui] = "-DENABLE_GR_QTGUI=ON,-DENABLE_GR_QTGUI=OFF,qt4-x11-free qwt, "
17
9 18
10inherit distutils-base cmake pkgconfig 19inherit distutils-base cmake pkgconfig
11 20
@@ -16,8 +25,9 @@ RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
16 python-lang python-textutils python-shell python-pickle \ 25 python-lang python-textutils python-shell python-pickle \
17 python-compiler python-pkgutil python-pydoc python-mmap \ 26 python-compiler python-pkgutil python-pydoc python-mmap \
18 python-netclient python-difflib \ 27 python-netclient python-difflib \
19 python-pprint python-numpy python-pygtk python-lxml \ 28 python-pprint python-numpy \
20 " 29 "
30RDEPENDS_${PN}-grc = "python-pygtk python-lxml python-cheetah"
21 31
22C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 32C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
23 33
@@ -68,7 +78,19 @@ S="${WORKDIR}/git"
68OECMAKE_BUILDPATH = "${S}/build" 78OECMAKE_BUILDPATH = "${S}/build"
69OECMAKE_SOURCEPATH = "${S}" 79OECMAKE_SOURCEPATH = "${S}"
70 80
71EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE -DENABLE_GR_QTGUI=ON -DENABLE_GR_WXGUI=OFF -DENABLE_GR_VIDEO_SDL=OFF -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore -DQT_LIBRARY_DIR=${STAGING_LIBDIR} -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so -DENABLE_GR_FCD=OFF -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt" 81EXTRA_OECMAKE = "-DENABLE_GR_ATSC=FALSE \
82 -DENABLE_GR_FCD=OFF \
83 -DENABLE_GR_WXGUI=OFF \
84 -DENABLE_GR_VIDEO_SDL=OFF \
85 -DIMPORT_EXECUTABLES=${S}/gr-vocoder/lib/generate_codebook.txt \
86 -DQT_HEADERS_DIR=${STAGING_INCDIR}/qt4 \
87 -DQT_QTCORE_INCLUDE_DIR=${STAGING_INCDIR}/qt4/QtCore \
88 -DQT_LIBRARY_DIR=${STAGING_LIBDIR} \
89 -DQT_QTCORE_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtCore.so \
90 -DQT_QTGUI_LIBRARY_RELEASE=${STAGING_LIBDIR}/libQtGui.so \
91"
92
93inherit distutils-base cmake pkgconfig
72 94
73EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}" 95EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
74 96