summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-18 15:31:23 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commit1c2c30c1439c64fe8c8c68e5ceeadf4148befaa4 (patch)
tree6947e3f62c8c83e869ca2330b77340935ccfb89a /meta-oe
parent3dc38c444b5fc88f9f0ba342a2e7db4c6566719f (diff)
downloadmeta-openembedded-1c2c30c1439c64fe8c8c68e5ceeadf4148befaa4.tar.gz
numactl: 2.0.11 -> 2.0.12
License-Update: license file name updated format changed, but most content is remain add mail of related person. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch35
-rw-r--r--meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch28
-rw-r--r--meta-oe/recipes-support/numactl/numactl_git.bb8
3 files changed, 39 insertions, 32 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch b/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch
new file mode 100644
index 000000000..0497613dd
--- /dev/null
+++ b/meta-oe/recipes-support/numactl/numactl/0001-fix-NULL-pointer-problem.patch
@@ -0,0 +1,35 @@
1From 5c16beff9909b28f55f25f48ed7ddbf98d8b1d5c Mon Sep 17 00:00:00 2001
2From: Roy Li <rongqing.li@windriver.com>
3Date: Wed, 18 Jul 2018 09:43:55 +0800
4Subject: [PATCH] fix NULL pointer problem
5
6return 0 if distance_table is NULL
7
8Upstream-Status: Pending
9
10read_distance_table() maybe return 0, but distance_table is not set,
11if distance_table is used, and will lead to SEGFAULT
12
13Signed-off-by: Roy Li <rongqing.li@windriver.com>
14
15Signed-off-by: Changqing Li <changqing.li@windriver.com>
16---
17 distance.c | 2 ++
18 1 file changed, 2 insertions(+)
19
20diff --git a/distance.c b/distance.c
21index 8d472af..6a6e886 100644
22--- a/distance.c
23+++ b/distance.c
24@@ -113,6 +113,8 @@ int numa_distance(int a, int b)
25 int err = read_distance_table();
26 if (err < 0)
27 return 0;
28+ if(!distance_table)
29+ return 0;
30 }
31 if ((unsigned)a >= distance_numnodes || (unsigned)b >= distance_numnodes)
32 return 0;
33--
342.7.4
35
diff --git a/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch b/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch
deleted file mode 100644
index 53952aef9..000000000
--- a/meta-oe/recipes-support/numactl/numactl/fix-null-pointer.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1[PATCH] return 0 if distance_table is NULL
2
3Upstream-Status: Pending
4
5read_distance_table() maybe return 0, but distance_table is not set,
6if distance_table is used, and will lead to SEGFAULT
7
8Signed-off-by: Roy Li <rongqing.li@windriver.com>
9---
10 distance.c | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/distance.c b/distance.c
14index 4a26972..c6ca021 100755
15--- a/distance.c
16+++ b/distance.c
17@@ -113,6 +113,8 @@ int numa_distance(int a, int b)
18 int err = read_distance_table();
19 if (err < 0)
20 return 0;
21+ if (!distance_table)
22+ return 0;
23 }
24 return distance_table[a * distance_numnodes + b];
25 }
26--
271.7.10.4
28
diff --git a/meta-oe/recipes-support/numactl/numactl_git.bb b/meta-oe/recipes-support/numactl/numactl_git.bb
index b9cbcf09d..c1c387986 100644
--- a/meta-oe/recipes-support/numactl/numactl_git.bb
+++ b/meta-oe/recipes-support/numactl/numactl_git.bb
@@ -9,13 +9,13 @@ RDEPENDS_${PN} = "perl"
9 9
10inherit autotools-brokensep ptest 10inherit autotools-brokensep ptest
11 11
12LIC_FILES_CHKSUM = "file://README;beginline=19;endline=32;md5=5644cc3851cb2499f6c48e52fe198bd9" 12LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb"
13 13
14SRCREV = "ea3a70681c2f523fe58e1d44527f478ca76db74e" 14SRCREV = "841253d1313b01a968c380cae4f498f20c46e5aa"
15PV = "2.0.11+git${SRCPV}" 15PV = "2.0.12+git${SRCPV}"
16 16
17SRC_URI = "git://github.com/numactl/numactl \ 17SRC_URI = "git://github.com/numactl/numactl \
18 file://fix-null-pointer.patch \ 18 file://0001-fix-NULL-pointer-problem.patch \
19 file://Fix-the-test-output-format.patch \ 19 file://Fix-the-test-output-format.patch \
20 file://Makefile \ 20 file://Makefile \
21 file://run-ptest \ 21 file://run-ptest \