summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-19 10:16:33 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 11:00:54 +0200
commit0e27972d970fc7ef24fc8a79805e09b71dfeef00 (patch)
treec2ce0514dbecadd46c7c64f34ae62878aae535a4 /meta-oe
parent07bbd665e6f22e133964c20326c2ec60a7e2841f (diff)
downloadmeta-openembedded-0e27972d970fc7ef24fc8a79805e09b71dfeef00.tar.gz
ne10: Fix build errors on cortex-a7 cpus
GCC7 warns and errors about incompatible cmdline switches for mcpu and march Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch38
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb3
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch b/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch
new file mode 100644
index 000000000..a8fea82dc
--- /dev/null
+++ b/meta-oe/recipes-support/ne10/ne10/0001-Dont-specify-march-explicitly.patch
@@ -0,0 +1,38 @@
1From 66d332e4b631eef800c6f62cd347b164ee3b59d4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 19 Apr 2017 10:11:21 -0700
4Subject: [PATCH] Dont specify -march explicitly
5
6it assumes armv7-a for all armv7 based machines but that may
7not be true e.g. machines based on armv7ve and cortexa-7
8it causes conflicts in OE builds because it specifies -march
9in recipes anyway so this is redundant in CMakeLists.txt
10
11Fixes
12
13| cc1: warning: switch -mcpu=cortex-a7 conflicts with -march=armv7-a switch
14| cc1: warning: switch -mcpu=cortex-a7 conflicts with -march=armv7-a switch
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 CMakeLists.txt | 4 ++--
19 1 file changed, 2 insertions(+), 2 deletions(-)
20
21diff --git a/CMakeLists.txt b/CMakeLists.txt
22index 68da920..a4b94b9 100644
23--- a/CMakeLists.txt
24+++ b/CMakeLists.txt
25@@ -138,8 +138,8 @@ if(ANDROID_PLATFORM)
26 ${CMAKE_C_FLAGS}")
27 elseif(GNULINUX_PLATFORM)
28 if("${NE10_TARGET_ARCH}" STREQUAL "armv7")
29- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=vfp3 -funsafe-math-optimizations")
30- set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=neon")
31+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -mfpu=vfp3 -funsafe-math-optimizations")
32+ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb -mfpu=neon")
33 # Turn on asm optimization for Linux on ARM v7.
34 set(NE10_ASM_OPTIMIZATION on)
35 endif()
36--
372.12.2
38
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index 951086f77..e5b50ce75 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -6,7 +6,8 @@ SECTION = "libs"
6 6
7SRC_URI = "git://github.com/projectNe10/Ne10.git \ 7SRC_URI = "git://github.com/projectNe10/Ne10.git \
8 file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \ 8 file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \
9" 9 file://0001-Dont-specify-march-explicitly.patch \
10 "
10SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f" 11SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f"
11 12
12S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"