summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-08-30 18:34:03 +0200
committerKhem Raj <raj.khem@gmail.com>2023-08-30 14:45:47 -0700
commit9b37c1cc8841ef397f3b812085e2c70841246db0 (patch)
treea3234572abfaa5aa1d2f842a03be27a7726e5ec3 /meta-oe
parentb0c46ce73a0e3a67edb2bfd992bd457f2871ede8 (diff)
downloadmeta-openembedded-9b37c1cc8841ef397f3b812085e2c70841246db0.tar.gz
json-schema-validator: restore 0004-cmake-Use-GNUInstallDirs.patch
* it was removed in: https://git.openembedded.org/meta-openembedded/commit/?id=0697d52777cd530dc59bb05a506327c365bc78a2 * but the patch wasn't applied upstream yet and now fails in multilib builds with: ERROR: lib32-json-schema-validator-2.2.0-r0 do_package: QA Issue: lib32-json-schema-validator: Files/directories were installed but not shipped in any package: /usr/lib/libnlohmann_json_schema_validator.so.2 /usr/lib/libnlohmann_json_schema_validator.so.2.2.0 /usr/lib/libnlohmann_json_schema_validator.so /usr/lib/cmake /usr/lib/cmake/nlohmann_json_schema_validator /usr/lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorConfig.cmake /usr/lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorConfigVersion.cmake /usr/lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorTargets.cmake /usr/lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorTargets-noconfig.cmake Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. lib32-json-schema-validator: 9 installed and not shipped files. [installed-vs-shipped] https://github.com/pboettch/json-schema-validator/pull/197 was closed due to branch rename, but I don't see this change applied in: https://github.com/pboettch/json-schema-validator/commits/main/CMakeLists.txt so I guess the .patch is still needed. * adjust the patch to apply on new version and restore it Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/json-schema-validator/json-schema-validator/0004-cmake-Use-GNUInstallDirs.patch43
-rw-r--r--meta-oe/recipes-devtools/json-schema-validator/json-schema-validator_2.2.0.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator/0004-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator/0004-cmake-Use-GNUInstallDirs.patch
new file mode 100644
index 000000000..8199e4f8d
--- /dev/null
+++ b/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator/0004-cmake-Use-GNUInstallDirs.patch
@@ -0,0 +1,43 @@
1From a42d374aa260caec5f683c75d0db322811e51ab9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 19 Mar 2022 22:40:49 -0700
4Subject: [PATCH] cmake: Use GNUInstallDirs
5
6This helps it make it platform independent, some platforms e.g.
7ppc64/linux use /usr/lib64 for system libraries
8
9Upstream-Status: Submitted [https://github.com/pboettch/json-schema-validator/pull/197]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 CMakeLists.txt | 8 +++++---
13 1 file changed, 5 insertions(+), 3 deletions(-)
14
15diff --git a/CMakeLists.txt b/CMakeLists.txt
16index 9e4587f..3eff234 100644
17--- a/CMakeLists.txt
18+++ b/CMakeLists.txt
19@@ -93,11 +93,13 @@ if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
20 endif()
21 endif()
22
23+include(GNUInstallDirs)
24+
25 if(JSON_VALIDATOR_INSTALL)
26 install(TARGETS nlohmann_json_schema_validator
27 EXPORT ${PROJECT_NAME}Targets
28- LIBRARY DESTINATION lib
29- ARCHIVE DESTINATION lib
30+ LIBRARY DESTINATION ${LIBDIR}
31+ ARCHIVE DESTINATION ${LIBDIR}
32 RUNTIME DESTINATION bin)
33
34 install(FILES src/nlohmann/json-schema.hpp
35@@ -129,7 +131,7 @@ endif()
36
37 if(JSON_VALIDATOR_INSTALL)
38 # Set the install path to the cmake config files (Relative, so install works correctly under Hunter as well)
39- set(INSTALL_CMAKE_DIR "lib/cmake/${PROJECT_NAME}")
40+ set(INSTALL_CMAKE_DIR ${CMAKE_INSTALL_LIBDIR}/cmake/${PROJECT_NAME})
41 set(INSTALL_CMAKEDIR_ROOT share/cmake)
42
43 # Install Targets
diff --git a/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator_2.2.0.bb b/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator_2.2.0.bb
index 6f0b42402..02dcdb269 100644
--- a/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator_2.2.0.bb
+++ b/meta-oe/recipes-devtools/json-schema-validator/json-schema-validator_2.2.0.bb
@@ -6,6 +6,7 @@ SRC_URI = "git://github.com/pboettch/json-schema-validator;branch=main;protocol=
6 file://0001-Set-Json_validator-Install-off-if-it-finds-it-via-li.patch \ 6 file://0001-Set-Json_validator-Install-off-if-it-finds-it-via-li.patch \
7 file://0002-Fix-assumed-signed-char.patch \ 7 file://0002-Fix-assumed-signed-char.patch \
8 file://0003-For-root-value-use-empty-pointer.patch \ 8 file://0003-For-root-value-use-empty-pointer.patch \
9 file://0004-cmake-Use-GNUInstallDirs.patch \
9 " 10 "
10 11
11SRCREV = "6b17782d6a5d1dee5d2c4fc5d25ffb1123913431" 12SRCREV = "6b17782d6a5d1dee5d2c4fc5d25ffb1123913431"