summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-05-13 14:55:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-15 12:57:46 +0200
commite2d9735404c30b8434c12ef32f93c0d09bc5a350 (patch)
tree2cab6bc514996a2b8ce3a615e609cb5d30f5c8cf /meta-oe
parentc7a31944695145d3c48372ae9051f1ed212aa3c5 (diff)
downloadmeta-openembedded-e2d9735404c30b8434c12ef32f93c0d09bc5a350.tar.gz
rrdtool: fix S!=B failure
Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.4.7.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.7.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.7.bb
index 2994df28e..df3dc8a80 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.7.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.4.7.bb
@@ -15,7 +15,7 @@ SRC_URI = "http://oss.oetiker.ch/rrdtool/pub/rrdtool-${PV}.tar.gz \
15SRC_URI[md5sum] = "ffe369d8921b4dfdeaaf43812100c38f" 15SRC_URI[md5sum] = "ffe369d8921b4dfdeaaf43812100c38f"
16SRC_URI[sha256sum] = "956aaf431c955ba88dd7d98920ade3a8c4bad04adb1f9431377950a813a7af11" 16SRC_URI[sha256sum] = "956aaf431c955ba88dd7d98920ade3a8c4bad04adb1f9431377950a813a7af11"
17 17
18inherit autotools gettext pythonnative perlnative python-dir 18inherit autotools-brokensep gettext pythonnative perlnative python-dir
19 19
20EXTRA_AUTORECONF = "-I m4" 20EXTRA_AUTORECONF = "-I m4"
21 21
@@ -78,11 +78,11 @@ do_configure() {
78 sed -i -e "s:\$(PYTHON) setup.py install:\$(PYTHON) setup.py install \ 78 sed -i -e "s:\$(PYTHON) setup.py install:\$(PYTHON) setup.py install \
79 --install-lib=${D}${PYTHON_SITEPACKAGES_DIR}:" \ 79 --install-lib=${D}${PYTHON_SITEPACKAGES_DIR}:" \
80 -e "s:perl-shared/Makefile.PL Makefile:perl-shared/Makefile.PL:" \ 80 -e "s:perl-shared/Makefile.PL Makefile:perl-shared/Makefile.PL:" \
81 ${S}/bindings/Makefile 81 ${B}/bindings/Makefile
82 82
83 #redo the perl bindings 83 #redo the perl bindings
84 ( 84 (
85 cd bindings/perl-shared; 85 cd ${S}/bindings/perl-shared;
86 perl -I${STAGING_LIBDIR}/perl/$perl_version Makefile.PL INSTALLDIRS="vendor" 86 perl -I${STAGING_LIBDIR}/perl/$perl_version Makefile.PL INSTALLDIRS="vendor"
87 INSTALLPRIVLIB="abc"; 87 INSTALLPRIVLIB="abc";
88 sed -i -e "s| ${libdir}/perl/| ${STAGING_LIBDIR}/perl/|g" Makefile; 88 sed -i -e "s| ${libdir}/perl/| ${STAGING_LIBDIR}/perl/|g" Makefile;
@@ -94,9 +94,9 @@ do_configure() {
94 94
95 #change the interpreter in file 95 #change the interpreter in file
96 sed -i -e "s|^PERL = ${STAGING_BINDIR_NATIVE}/.*|PERL = /usr/bin/perl|g" \ 96 sed -i -e "s|^PERL = ${STAGING_BINDIR_NATIVE}/.*|PERL = /usr/bin/perl|g" \
97 ${S}/examples/Makefile 97 ${B}/examples/Makefile
98 sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl|/usr/bin/perl|g" \ 98 sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl|/usr/bin/perl|g" \
99 ${S}/examples/*.pl 99 ${B}/examples/*.pl
100} 100}
101 101
102PACKAGES =+ "${PN}-perl ${PN}-python" 102PACKAGES =+ "${PN}-perl ${PN}-python"