summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-03-20 09:59:04 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-03-21 13:50:41 +0100
commitbea124794b17bd87d4b1a3a0df30a1f02869c7f0 (patch)
tree1d7fb700e6a123dcddea012cdb684a7a58c0ef63 /meta-oe
parent0148de029c33ca496b51700ddf1fcd035a38fc77 (diff)
downloadmeta-openembedded-bea124794b17bd87d4b1a3a0df30a1f02869c7f0.tar.gz
python-imaging: remove
Fixes from this version have now been merged into OE-Core, so remove it here. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch55
-rw-r--r--meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb41
2 files changed, 0 insertions, 96 deletions
diff --git a/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch b/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
deleted file mode 100644
index c6e2ee452..000000000
--- a/meta-oe/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
+++ /dev/null
@@ -1,55 +0,0 @@
1From 07d4f095a9e22ae676a8d68073101131e65012dc Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 15 Nov 2011 13:16:54 +0100
4Subject: [PATCH] python imaging setup.py: force paths for zlib, freetype and jpeg and don't add host paths
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7
8Upstream-Status: Unknown
9---
10 setup.py | 14 +++-----------
11 1 files changed, 3 insertions(+), 11 deletions(-)
12
13diff --git a/setup.py b/setup.py
14index 5d4d53a..b1a22ec 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -34,10 +34,10 @@ def libinclude(root):
18 # TIFF_ROOT = libinclude("/opt/tiff")
19
20 TCL_ROOT = None
21-JPEG_ROOT = None
22-ZLIB_ROOT = None
23+JPEG_ROOT = os.environ['STAGING_LIBDIR']
24+ZLIB_ROOT = os.environ['STAGING_LIBDIR']
25 TIFF_ROOT = None
26-FREETYPE_ROOT = None
27+FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
28 LCMS_ROOT = None
29
30 # FIXME: add mechanism to explicitly *disable* the use of a library
31@@ -147,7 +147,6 @@ class pil_build_ext(build_ext):
32 add_directory(library_dirs, "/opt/local/lib")
33 add_directory(include_dirs, "/opt/local/include")
34
35- add_directory(library_dirs, "/usr/local/lib")
36 # FIXME: check /opt/stuff directories here?
37
38 prefix = sysconfig.get_config_var("prefix")
39@@ -207,13 +206,6 @@ class pil_build_ext(build_ext):
40 if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
41 add_directory(include_dirs, tcl_dir)
42
43- # standard locations
44- add_directory(library_dirs, "/usr/local/lib")
45- add_directory(include_dirs, "/usr/local/include")
46-
47- add_directory(library_dirs, "/usr/lib")
48- add_directory(include_dirs, "/usr/include")
49-
50 #
51 # insert new dirs *before* default libs, to avoid conflicts
52 # between Python PYD stub libs and real libraries
53--
541.7.2.5
55
diff --git a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb b/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
deleted file mode 100644
index c8dd8147c..000000000
--- a/meta-oe/recipes-devtools/python/python-imaging_1.1.7.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1DESCRIPTION = "Python Imaging Library"
2SECTION = "devel/python"
3
4PR = "r1"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://README;beginline=92;endline=117;md5=003338c482e1d2eb2e4d862897f3abbf"
8
9DEPENDS = "freetype jpeg tiff"
10SRCNAME = "Imaging"
11
12SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
13 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
14"
15SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
16SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils
21
22do_compile() {
23 export STAGING_LIBDIR=${STAGING_LIBDIR}
24 export STAGING_INCDIR=${STAGING_INCDIR}
25 distutils_do_compile
26}
27
28do_install() {
29 export STAGING_LIBDIR=${STAGING_LIBDIR}
30 export STAGING_INCDIR=${STAGING_INCDIR}
31 distutils_do_install
32 install -d ${D}${datadir}/doc/${PN}/html/
33 install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
34 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
35
36 # get rid of #!/usr/local/bin/python
37 sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
38
39}
40RDEPENDS_${PN} = "python-lang python-stringold"
41