summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-07-18 15:31:20 +0800
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:07:12 -0700
commitb4e6b08e05783a8ecafa8274939ce3f5f0511291 (patch)
treee1719405638ae937a0efe2a19df46539278657ee /meta-oe
parent34988c5319b08a14a145d82ed1057468f22632f9 (diff)
downloadmeta-openembedded-b4e6b08e05783a8ecafa8274939ce3f5f0511291.tar.gz
libblockdev: 2.16 -> 2.18
Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/libblockdev/files/0001-fix-configure-and-compile-failures.patch64
-rw-r--r--meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb (renamed from meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb)12
2 files changed, 41 insertions, 35 deletions
diff --git a/meta-oe/recipes-extended/libblockdev/files/0001-fix-configure-and-compile-failures.patch b/meta-oe/recipes-extended/libblockdev/files/0001-fix-configure-and-compile-failures.patch
index 745883ebe..9c050b781 100644
--- a/meta-oe/recipes-extended/libblockdev/files/0001-fix-configure-and-compile-failures.patch
+++ b/meta-oe/recipes-extended/libblockdev/files/0001-fix-configure-and-compile-failures.patch
@@ -1,7 +1,7 @@
1From 86686ccbf43c5d9e8c8dc97c66ba09e522050e5e Mon Sep 17 00:00:00 2001 1From 21654e3719e0a289e735918b234f7aae6766e3a1 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com> 2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 27 Jul 2017 10:06:24 +0800 3Date: Wed, 18 Jul 2018 11:26:28 +0800
4Subject: [PATCH 1/3] fix configure and compile failures 4Subject: [PATCH] fix configure and compile failures
5 5
61. Fix do_configure failure 61. Fix do_configure failure
7--------------------------- 7---------------------------
@@ -9,9 +9,6 @@ Subject: [PATCH 1/3] fix configure and compile failures
9../tmp/6tvtK.c:1:38: fatal error: volume_key/libvolume_key.h: 9../tmp/6tvtK.c:1:38: fatal error: volume_key/libvolume_key.h:
10No such file or directory 10No such file or directory
11| #include <volume_key/libvolume_key.h> 11| #include <volume_key/libvolume_key.h>
12|Checking header dmraid/dmraid.h existence and usability.../tmp/
13ktVJ6.c:1:27: fatal error: dmraid/dmraid.h: No such file or directory
14| #include <dmraid/dmraid.h>
15--------------------------- 12---------------------------
16We explictly add volume_key and dmraid to DEPENDS, do not need 13We explictly add volume_key and dmraid to DEPENDS, do not need
17configure to test. 14configure to test.
@@ -28,12 +25,20 @@ autoheader: Use AC_DEFINE([LIBMOUNT_NEW_ERR_API], [], [Description])
28Upstream-Status: Inappropriate [oe specific] 25Upstream-Status: Inappropriate [oe specific]
29 26
30Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> 27Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
28
29Checking header dmraid/dmraid.h existence and usability.../tmp/
30ktVJ6.c:1:27: fatal error: dmraid/dmraid.h: No such file or directory
31| #include <dmraid/dmraid.h>
32
33fix this by add --disable-dmraid
34
35Signed-off-by: Changqing Li <changqing.li@windriver.com>
31--- 36---
32 configure.ac | 10 ++++------ 37 configure.ac | 12 +++++++-----
33 1 file changed, 4 insertions(+), 6 deletions(-) 38 1 file changed, 7 insertions(+), 5 deletions(-)
34 39
35diff --git a/configure.ac b/configure.ac 40diff --git a/configure.ac b/configure.ac
36index d41a307..b036e04 100644 41index a37f337..a8cfe2f 100644
37--- a/configure.ac 42--- a/configure.ac
38+++ b/configure.ac 43+++ b/configure.ac
39@@ -9,6 +9,8 @@ AC_DISABLE_STATIC 44@@ -9,6 +9,8 @@ AC_DISABLE_STATIC
@@ -45,35 +50,38 @@ index d41a307..b036e04 100644
45 AM_PATH_PYTHON 50 AM_PATH_PYTHON
46 51
47 AM_PROG_AR 52 AM_PROG_AR
48@@ -154,7 +156,6 @@ LIBBLOCKDEV_PKG_CHECK_MODULES([KMOD], [libkmod >= 19]) 53@@ -194,10 +196,9 @@ LIBBLOCKDEV_PKG_CHECK_MODULES([KMOD], [libkmod >= 19])
49 AS_IF([test "x$with_crypto" != "xno"], 54 AS_IF([test "x$with_crypto" != "xno"],
50 [LIBBLOCKDEV_PKG_CHECK_MODULES([CRYPTSETUP], [libcryptsetup >= 1.6.7]) 55 [LIBBLOCKDEV_PKG_CHECK_MODULES([CRYPTSETUP], [libcryptsetup >= 1.6.7])
51 LIBBLOCKDEV_PKG_CHECK_MODULES([NSS], [nss >= 3.18.0]) 56 AS_IF([$PKG_CONFIG --atleast-version=2.0 libcryptsetup],
52- LIBBLOCKDEV_CHECK_HEADER([volume_key/libvolume_key.h], [$GLIB_CFLAGS $NSS_CFLAGS], [libvolume_key.h not available]) 57- [AC_DEFINE([LIBCRYPTSETUP_2])], [])
58+ [AC_DEFINE([LIBCRYPTSETUP_2], [1], [new version of libcryptsetup])])
59 AS_IF([test "x$with_escrow" != "xno"],
60- [LIBBLOCKDEV_PKG_CHECK_MODULES([NSS], [nss >= 3.18.0])
61- LIBBLOCKDEV_CHECK_HEADER([volume_key/libvolume_key.h], [$GLIB_CFLAGS $NSS_CFLAGS], [libvolume_key.h not available])],
62+ [LIBBLOCKDEV_PKG_CHECK_MODULES([NSS], [nss >= 3.18.0])],
63 [])
53 ], 64 ],
54 []) 65 [])
55 66@@ -218,7 +219,8 @@ AS_IF([test "x$with_fs" != "xno"],
56@@ -162,10 +163,6 @@ AS_IF([test "x$with_dm" != "xno" -o "x$with_lvm" != "xno" -o "x$with_lvm_dbus" !
57 [LIBBLOCKDEV_PKG_CHECK_MODULES([DEVMAPPER], [devmapper >= 1.02.93])],
58 [])
59
60-AS_IF([test "x$with_dm" != "xno"],
61- [LIBBLOCKDEV_CHECK_HEADER([dmraid/dmraid.h], [], [dmraid.h not available])],
62- [])
63-
64 AS_IF([test "x$with_part" != "xno" -o "x$with_fs" != "xno"],
65 [LIBBLOCKDEV_PKG_CHECK_MODULES([PARTED], [libparted >= 3.1])]
66 [])
67@@ -174,7 +171,8 @@ AS_IF([test "x$with_fs" != "xno"],
68 [LIBBLOCKDEV_PKG_CHECK_MODULES([MOUNT], [mount >= 2.23.0]) 67 [LIBBLOCKDEV_PKG_CHECK_MODULES([MOUNT], [mount >= 2.23.0])
69 # new versions of libmount has some new functions we can use 68 # new versions of libmount has some new functions we can use
70 AS_IF([$PKG_CONFIG --atleast-version=2.30.0 mount], 69 AS_IF([$PKG_CONFIG --atleast-version=2.30.0 mount],
71- [AC_DEFINE([LIBMOUNT_NEW_ERR_API])], []) 70- [AC_DEFINE([LIBMOUNT_NEW_ERR_API])], [])
72+ [AC_DEFINE([LIBMOUNT_NEW_ERR_API], [1], [new versions of libmount has some new functions we can use])], 71+ [AC_DEFINE([LIBMOUNT_NEW_ERR_API], [1], [new versions of libmount has some new functions we can use])],
73+ []) 72+ [])
74 73
75 LIBBLOCKDEV_PKG_CHECK_MODULES([BLKID], [blkid >= 2.23.0]) 74 LIBBLOCKDEV_PKG_CHECK_MODULES([BLKID], [blkid >= 2.23.0])
76 # older versions of libblkid don't support BLKID_SUBLKS_BADCSUM so let's just 75 # older versions of libblkid don't support BLKID_SUBLKS_BADCSUM so let's just
76@@ -243,7 +245,7 @@ AS_IF([test "x$with_nvdimm" != "xno"],
77 LIBBLOCKDEV_PKG_CHECK_MODULES([NDCTL], [libndctl >= 58.4])
78 # new versions of libndctl new modes
79 AS_IF([$PKG_CONFIG --atleast-version=60 libndctl],
80- [AC_DEFINE([LIBNDCTL_NEW_MODES])], [])]
81+ [AC_DEFINE([LIBNDCTL_NEW_MODES], [1], [new version of libndctl new modes])], [])]
82 [])
83
84 AS_IF([test "x$with_vdo" != "xno"],
77-- 85--
782.14.3 862.7.4
79 87
diff --git a/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
index 0c954aa39..4dbd04cd7 100644
--- a/meta-oe/recipes-extended/libblockdev/libblockdev_2.16.bb
+++ b/meta-oe/recipes-extended/libblockdev/libblockdev_2.18.bb
@@ -18,16 +18,10 @@ DEPENDS += " \
18 btrfs-tools \ 18 btrfs-tools \
19" 19"
20 20
21SRCREV = "e2e0899efe8dd3f111ff955fb6c1dc10b0bd2075" 21SRCREV = "0debeb45562ac3d8f6f43f6f942b238abab55be9"
22SRC_URI = " \ 22SRC_URI = " \
23 git://github.com/rhinstaller/libblockdev;branch=master \ 23 git://github.com/rhinstaller/libblockdev;branch=master \
24 file://0001-fix-configure-and-compile-failures.patch \ 24 file://0001-fix-configure-and-compile-failures.patch \
25 file://0002-remove-python2-support.patch \
26 file://0003-remove-dmraid-while-compiling-with-with-dm.patch \
27 file://0005-fix-a-clang-compiling-issue.patch \
28"
29SRC_URI_append_libc-musl = " \
30 file://0004-fix-compile-failure-against-musl-C-library.patch \
31" 25"
32 26
33S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"
@@ -40,12 +34,16 @@ FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
40 34
41PACKAGECONFIG ??= "python3 lvm dm kmod parted fs" 35PACKAGECONFIG ??= "python3 lvm dm kmod parted fs"
42PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" 36PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
37PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2"
43PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools" 38PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools"
44PACKAGECONFIG[dm] = "--with-dm, --without-dm" 39PACKAGECONFIG[dm] = "--with-dm, --without-dm"
40PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
45PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod" 41PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
46PACKAGECONFIG[parted] = "--with-part, --without-part, parted" 42PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
47PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" 43PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
48PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" 44PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
45PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm"
46PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
49 47
50export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" 48export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"
51 49