diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2011-05-29 21:05:15 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-05-29 21:37:56 +0200 |
commit | a0629d7a76c6c05496e4bbbc0c87b7614c05a791 (patch) | |
tree | 80fe9f03aa125f48b16ba6f130f12c5cbf25ae73 /meta-oe | |
parent | d75d2ce3baf58a94eadbf08f35e5626b74e6a1ae (diff) | |
download | meta-openembedded-a0629d7a76c6c05496e4bbbc0c87b7614c05a791.tar.gz |
alsa-oss: import from OE rev d4f0211e2078d5033ae0dee74664de5520d8392d
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch | 43 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.17.bb | 22 |
2 files changed, 65 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch b/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch new file mode 100644 index 000000000..a053e4c60 --- /dev/null +++ b/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Index: alsa-oss-1.0.15/alsa/stdioemu.c | ||
2 | =================================================================== | ||
3 | --- alsa-oss-1.0.15.orig/alsa/stdioemu.c 2007-10-15 10:50:40.000000000 +0200 | ||
4 | +++ alsa-oss-1.0.15/alsa/stdioemu.c 2008-07-21 22:17:06.303161438 +0200 | ||
5 | @@ -37,7 +37,9 @@ | ||
6 | #endif | ||
7 | |||
8 | #include <stdio.h> | ||
9 | +#ifdef HAVE_LIBIO_H | ||
10 | #include <libio.h> | ||
11 | +#endif | ||
12 | |||
13 | struct fd_cookie { | ||
14 | int fd; | ||
15 | @@ -99,7 +101,11 @@ | ||
16 | |||
17 | if (open_mode && fdc->fd > 0) { | ||
18 | result = fopencookie (fdc,"w", fns); | ||
19 | +#ifdef HAVE_FILENO | ||
20 | result->_fileno = fdc->fd; /* ugly patchy slimy kludgy hack */ | ||
21 | +#else | ||
22 | + result->__filedes = fdc->fd; | ||
23 | +#endif | ||
24 | } | ||
25 | return result; | ||
26 | } | ||
27 | Index: alsa-oss-1.0.15/configure.in | ||
28 | =================================================================== | ||
29 | --- alsa-oss-1.0.15.orig/configure.in 2007-10-15 10:50:40.000000000 +0200 | ||
30 | +++ alsa-oss-1.0.15/configure.in 2008-07-21 22:16:11.719837298 +0200 | ||
31 | @@ -33,6 +33,12 @@ | ||
32 | LIBS="$OLD_LIBS" | ||
33 | fi | ||
34 | |||
35 | +AC_CHECK_HEADERS_ONCE([libio.h]) | ||
36 | + | ||
37 | +AC_CHECK_MEMBER([struct _IO_FILE._fileno], | ||
38 | + [AC_DEFINE([HAVE_FILENO], [1],[Define if _fileno exists.])], | ||
39 | + [],[]) | ||
40 | + | ||
41 | AC_OUTPUT(Makefile alsa/Makefile alsa/aoss alsa/aoss.old \ | ||
42 | oss-redir/Makefile test/Makefile \ | ||
43 | alsa/testaoss test/testaoss) | ||
diff --git a/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.17.bb b/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.17.bb new file mode 100644 index 000000000..52634c156 --- /dev/null +++ b/meta-oe/recipes-multimedia/alsa/alsa-oss_1.0.17.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | DESCRIPTION = "Alsa OSS Compatibility Package" | ||
2 | SECTION = "libs/multimedia" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" | ||
5 | DEPENDS = "alsa-lib" | ||
6 | PR = "r1" | ||
7 | |||
8 | SRC_URI = "ftp://ftp.alsa-project.org/pub/oss-lib/alsa-oss-${PV}.tar.bz2 \ | ||
9 | file://libio.patch \ | ||
10 | " | ||
11 | |||
12 | inherit autotools | ||
13 | |||
14 | LEAD_SONAME = "libaoss.so.0" | ||
15 | |||
16 | do_configure_prepend () { | ||
17 | touch NEWS README AUTHORS ChangeLog | ||
18 | sed -i "s/libaoss.so/${LEAD_SONAME}/" ${S}/alsa/aoss.in | ||
19 | } | ||
20 | |||
21 | SRC_URI[md5sum] = "1b1850c2fc91476a73d50f537cbd402f" | ||
22 | SRC_URI[sha256sum] = "8d009e23e2cbee1691ec3c95d1838056a804d98440eae7715d6c3aebc710f9ca" | ||