summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorIoan-Adrian Ratiu <adrian.ratiu@ni.com>2015-12-03 12:14:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:36:55 +0100
commit7a28b679a6ec2e19dc61f73929cf852ab59e5024 (patch)
treeedebb9d5870f652d80b1b5aec49ba23f7b345e83 /meta-oe
parent50d303bc462603ed8e478281d8cfcce5f42cd78d (diff)
downloadmeta-openembedded-7a28b679a6ec2e19dc61f73929cf852ab59e5024.tar.gz
x11vnc: move recipe from oe-core
x11vnc will be configured to use the external libvncserver which is added to meta-oe. Since oe-core recipes should not depend on meta-oe recipes, we move x11vnc to meta-oe. Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch24
-rw-r--r--meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch25
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb25
3 files changed, 74 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch b/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch
new file mode 100644
index 000000000..f2a538bf6
--- /dev/null
+++ b/meta-oe/recipes-graphics/x11vnc/files/endian-fix.patch
@@ -0,0 +1,24 @@
1libvncserver: replace LIBVNCSERVER_WORDS_BIGENDIAN with WORDS_BIGENDIAN
2
3since macro AC_C_BIGENDIAN is used in autoconf and WORDS_BIGENDIAN is
4automatically set for different arch, it is better to use WORDS_BIGENDIAN
5instead of LIBVNCSERVER_WORDS_BIGENDIAN, which cuase issue in mips.
6
7Signed-off-by: Yu Ke <ke.yu@intel.com>
8
9Upstream-Status: Pending
10
11diff --git a/libvncserver/main.c b/libvncserver/main.c
12index b6bd930..8bbb7bf 100644
13--- a/libvncserver/main.c
14+++ b/libvncserver/main.c
15@@ -47,7 +47,7 @@ static MUTEX(extMutex);
16
17 static int rfbEnableLogging=1;
18
19-#ifdef LIBVNCSERVER_WORDS_BIGENDIAN
20+#ifdef WORDS_BIGENDIAN
21 char rfbEndianTest = (1==0);
22 #else
23 char rfbEndianTest = (1==1);
24
diff --git a/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch b/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch
new file mode 100644
index 000000000..f62e405dd
--- /dev/null
+++ b/meta-oe/recipes-graphics/x11vnc/files/starting-fix.patch
@@ -0,0 +1,25 @@
1"-gui" & "-rfbport" require "wish" installed, or else x11vnc fails to start.
2Removing these 2 parameters makes x11vnc works well on poky sato image.
3
4Add also -skip_lockkeys option to ignore all Caps_Lock, Shift_Lock, Num_Lock,
5Scroll_Lock keysyms received from viewers, in order to leave the lock state on
6the server side unchanged. Yet, the keys will appear correctly.
7
8Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
9Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
10
11Upstream-Status: Inappropriate [configuration]
12
13Index: x11vnc-0.9.12/x11vnc/x11vnc.desktop
14===================================================================
15--- x11vnc-0.9.12.orig/x11vnc/x11vnc.desktop 2011-03-03 10:33:18.000000000 +0800
16+++ x11vnc-0.9.12/x11vnc/x11vnc.desktop 2011-03-03 10:35:20.000000000 +0800
17@@ -1,7 +1,7 @@
18 [Desktop Entry]
19 Name=X11VNC Server
20 Comment=Share this desktop by VNC
21-Exec=x11vnc -gui tray=setpass -rfbport PROMPT -bg -o %%HOME/.x11vnc.log.%%VNCDISPLAY
22+Exec=x11vnc -bg -rfbport 5900 -skip_lockkeys -o %%HOME/.x11vnc.log.%%VNCDISPLAY
23 Icon=computer
24 Terminal=false
25 Type=Application
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
new file mode 100644
index 000000000..ec0241fb2
--- /dev/null
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.13.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Exports your X session on-the-fly via VNC"
2HOMEPAGE = "http://www.karlrunge.com/x11vnc/"
3
4SECTION = "x11/utils"
5AUTHOR = "Karl Runge"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f \
8 file://x11vnc/x11vnc.h;endline=33;md5=6f95dc6535467d7ee1563fd434fb372e"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/x11vnc/${PV}/x11vnc-${PV}.tar.gz\
11 file://starting-fix.patch \
12 file://endian-fix.patch "
13
14SRC_URI[md5sum] = "a372ec4fe8211221547b1c108cf56e4c"
15SRC_URI[sha256sum] = "f6829f2e629667a5284de62b080b13126a0736499fe47cdb447aedb07a59f13b"
16
17DEPENDS = "openssl virtual/libx11 libxext jpeg zlib libxfixes libxrandr libxdamage libxtst"
18
19inherit autotools-brokensep distro_features_check
20# depends on virtual/libx11
21REQUIRED_DISTRO_FEATURES = "x11"
22
23PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)}"
24PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
25PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama"