summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-05-28 11:19:10 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-28 16:42:55 +0200
commit086a042fb75d79902c84d81dc1e3caa5dd995c16 (patch)
tree1d36939f285bd7c9d724da81fcb5c51bff84354c /meta-oe
parentede2ce2942a350394bed0af4a48a2877497b9c22 (diff)
downloadmeta-openembedded-086a042fb75d79902c84d81dc1e3caa5dd995c16.tar.gz
systemd: use PKGV and create 'lock' group in postinst
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index 6c34f7555..9f92f8ace 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,15 +14,12 @@ SECTION = "base/shell"
14inherit gitpkgv 14inherit gitpkgv
15PKGV = "v${GITPKGVTAG}" 15PKGV = "v${GITPKGVTAG}"
16 16
17# This gets reset to the proper version with PKGV above 17PV = "git"
18# Except that PKGV doesn't work in OE-core :(
19# PV = "git"
20PV = "v28"
21PR = "r1" 18PR = "r1"
22 19
23inherit autotools vala update-alternatives 20inherit autotools vala update-alternatives
24 21
25SRCREV = "0e8eb2d2e2446a3f6ba1eee1940fc96167ae332a" 22SRCREV = "9a66640832d103f906c2ef609a1d19d43fc542f6"
26 23
27SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ 24SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \
28 file://execute.patch \ 25 file://execute.patch \
@@ -93,3 +90,11 @@ RDEPENDS_${PN} += "dbus-systemd udev-systemd"
93# kbd -> loadkeys,setfont 90# kbd -> loadkeys,setfont
94RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty" 91RRECOMMENDS_${PN} += "kbd kbd-consolefonts ${PN}-serialgetty"
95 92
93pkg_postinst_${PN} () {
94 # can't do this offline
95 if [ "x$D" != "x" ]; then
96 exit 1
97 fi
98 grep "^lock:" /etc/group > /dev/null || addgroup lock
99}
100