diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-06-27 19:08:16 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-01 09:59:27 +0200 |
commit | dab4099c96f3d9304e85c02436df770d7304c148 (patch) | |
tree | 0f4a2dd2622a2ca4a3efedf004bfcc8ee30ab859 /meta-oe | |
parent | 499d19e10a5eb2ac121bada9eb44195be95ba3ea (diff) | |
download | meta-openembedded-dab4099c96f3d9304e85c02436df770d7304c148.tar.gz |
lmbench: Fix build with hardening flags
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | 3 |
2 files changed, 28 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch new file mode 100644 index 000000000..18ed43d06 --- /dev/null +++ b/meta-oe/recipes-benchmark/lmbench/lmbench-3.0-a9/0001-lat_http.c-Add-printf-format.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 6faa6acdf20aa6f738eed1483b7dceed94286adb Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 27 Jun 2017 14:39:10 -0700 | ||
4 | Subject: [PATCH] lat_http.c: Add printf format | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/lat_http.c | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/lat_http.c b/src/lat_http.c | ||
12 | index c630d59..28d04f7 100644 | ||
13 | --- a/src/lat_http.c | ||
14 | +++ b/src/lat_http.c | ||
15 | @@ -27,7 +27,7 @@ http(char *server, char *file, int prog) | ||
16 | sock = tcp_connect(server, prog, SOCKOPT_REUSE); | ||
17 | sprintf(buf, "GET /%s HTTP/1.0\r\n\r\n\n", file); | ||
18 | if (debug) { | ||
19 | - printf(buf); | ||
20 | + printf("%s", buf); | ||
21 | } | ||
22 | write(sock, buf, strlen(buf)); | ||
23 | while ((n = read(sock, buf, XFERSIZE)) > 0) { | ||
24 | -- | ||
25 | 2.13.2 | ||
26 | |||
diff --git a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb index 62906fd68..43ac1d038 100644 --- a/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb +++ b/meta-oe/recipes-benchmark/lmbench/lmbench_3.0-a9.bb | |||
@@ -19,7 +19,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/lmbench/lmbench-${PV}.tgz \ | |||
19 | file://lmbench_result_html_report.patch \ | 19 | file://lmbench_result_html_report.patch \ |
20 | file://fix-lmbench-memory-check-failure.patch \ | 20 | file://fix-lmbench-memory-check-failure.patch \ |
21 | file://0001-avoid-gcc-optimize-away-the-loops.patch \ | 21 | file://0001-avoid-gcc-optimize-away-the-loops.patch \ |
22 | " | 22 | file://0001-lat_http.c-Add-printf-format.patch \ |
23 | " | ||
23 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" | 24 | SRC_URI[md5sum] = "b3351a3294db66a72e2864a199d37cbf" |
24 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" | 25 | SRC_URI[sha256sum] = "cbd5777d15f44eab7666dcac418054c3c09df99826961a397d9acf43d8a2a551" |
25 | 26 | ||