diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-13 22:39:57 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-24 18:57:33 +0200 |
commit | 77c757f414ac89742a5e7bc76ceecedd7a2eb01f (patch) | |
tree | 93cf6ccc4fab77aecf490e289960a01fbf92b375 /meta-oe | |
parent | cafe21e8a20610deffa3b79af223b939518ef9a8 (diff) | |
download | meta-openembedded-77c757f414ac89742a5e7bc76ceecedd7a2eb01f.tar.gz |
libteam: Upgrade to 1.27
Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch | 40 | ||||
-rw-r--r-- | meta-oe/recipes-support/libteam/libteam_1.27.bb (renamed from meta-oe/recipes-support/libteam/libteam_1.26.bb) | 7 |
3 files changed, 73 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch b/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch new file mode 100644 index 000000000..a4a17ed85 --- /dev/null +++ b/meta-oe/recipes-support/libteam/libteam/0001-include-sys-select.h-for-fd_set-definition.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 0ab69dc18a2057ff5bf41abcdf2b983b72d5a903 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 12 Jul 2017 15:34:49 -0700 | ||
4 | Subject: [PATCH 1/2] include sys/select.h for fd_set definition | ||
5 | |||
6 | Fixes | ||
7 | teamnl.c:160:2: error: unknown type name 'fd_set'; did you mean 'fpos_t'? | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | utils/teamnl.c | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/utils/teamnl.c b/utils/teamnl.c | ||
15 | index e8de7e2..25129e8 100644 | ||
16 | --- a/utils/teamnl.c | ||
17 | +++ b/utils/teamnl.c | ||
18 | @@ -24,6 +24,7 @@ | ||
19 | #include <getopt.h> | ||
20 | #include <errno.h> | ||
21 | #include <sys/signalfd.h> | ||
22 | +#include <sys/select.h> | ||
23 | #include <signal.h> | ||
24 | #include <unistd.h> | ||
25 | #include <team.h> | ||
26 | -- | ||
27 | 2.13.2 | ||
28 | |||
diff --git a/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch b/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch new file mode 100644 index 000000000..beabf63ca --- /dev/null +++ b/meta-oe/recipes-support/libteam/libteam/0002-teamd-Re-adjust-include-header-order.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From a5b945cb3c62a18dcd7047f62707c09076c4e48b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 12 Jul 2017 15:35:51 -0700 | ||
4 | Subject: [PATCH 2/2] teamd: Re-adjust include header order | ||
5 | |||
6 | So it gets the library definition before kernel definition | ||
7 | |||
8 | usr/include/ne | ||
9 | tinet/if_ether.h:101:8: error: redefinition of 'struct ethhdr' | ||
10 | struct ethhdr { | ||
11 | ^~~~~~ | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | teamd/teamd_runner_lacp.c | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/teamd/teamd_runner_lacp.c b/teamd/teamd_runner_lacp.c | ||
19 | index 9c77fae..8800854 100644 | ||
20 | --- a/teamd/teamd_runner_lacp.c | ||
21 | +++ b/teamd/teamd_runner_lacp.c | ||
22 | @@ -23,6 +23,7 @@ | ||
23 | #include <unistd.h> | ||
24 | #include <limits.h> | ||
25 | #include <sys/ioctl.h> | ||
26 | +#include <net/ethernet.h> | ||
27 | #include <linux/if_ether.h> | ||
28 | #include <sys/socket.h> | ||
29 | #include <linux/netdevice.h> | ||
30 | @@ -30,7 +31,6 @@ | ||
31 | #include <errno.h> | ||
32 | #include <team.h> | ||
33 | #include <private/misc.h> | ||
34 | -#include <net/ethernet.h> | ||
35 | |||
36 | #include "teamd.h" | ||
37 | #include "teamd_config.h" | ||
38 | -- | ||
39 | 2.13.2 | ||
40 | |||
diff --git a/meta-oe/recipes-support/libteam/libteam_1.26.bb b/meta-oe/recipes-support/libteam/libteam_1.27.bb index 2cb9e8f3f..32227009e 100644 --- a/meta-oe/recipes-support/libteam/libteam_1.26.bb +++ b/meta-oe/recipes-support/libteam/libteam_1.27.bb | |||
@@ -7,8 +7,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" | |||
7 | 7 | ||
8 | DEPENDS = "libnl libdaemon jansson" | 8 | DEPENDS = "libnl libdaemon jansson" |
9 | 9 | ||
10 | SRC_URI = "git://github.com/jpirko/libteam" | 10 | SRC_URI = "git://github.com/jpirko/libteam \ |
11 | SRCREV = "8c1cea00a21950089058e4e33ea1f7bf4deaddeb" | 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
12 | file://0002-teamd-Re-adjust-include-header-order.patch \ | ||
13 | " | ||
14 | SRCREV = "91a928a56a501daac5ce8b3c16bd9943661f1d16" | ||
12 | 15 | ||
13 | SRC_URI[md5sum] = "565114d70c41bff6093d8e57be284e8a" | 16 | SRC_URI[md5sum] = "565114d70c41bff6093d8e57be284e8a" |
14 | SRC_URI[sha256sum] = "d65286379141db141bea33424ec0507bb0f827a0bf03d9c65004bb593e3d5545" | 17 | SRC_URI[sha256sum] = "d65286379141db141bea33424ec0507bb0f827a0bf03d9c65004bb593e3d5545" |