diff options
author | Jan Luebbe <jluebbe@debian.org> | 2012-03-06 10:36:13 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-16 21:11:44 +0100 |
commit | 77a7c689948fa16b1d8fafae9519dc03fa88977d (patch) | |
tree | 3bcda5b386e3abdc8dbaa23e8e4dcaafef7ff92e /meta-oe | |
parent | 65b7d5b45718400b2b7b049d216b4a3613c60259 (diff) | |
download | meta-openembedded-77a7c689948fa16b1d8fafae9519dc03fa88977d.tar.gz |
libspatialite: add recipe
Signed-off-by: Jan Luebbe <jluebbe@debian.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 225 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite.inc b/meta-oe/recipes-navigation/libspatialite/libspatialite.inc new file mode 100644 index 000000000..f51b3a5f4 --- /dev/null +++ b/meta-oe/recipes-navigation/libspatialite/libspatialite.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Library extending the SQLite core to support fully fledged Spatial SQL capabilities" | ||
2 | HOMEPAGE = "https://www.gaia-gis.it/fossil/libspatialite/" | ||
3 | SECTION = "libs" | ||
4 | DEPENDS = "proj geos" | ||
5 | |||
6 | INC_PR = "r0" | ||
7 | |||
8 | LICENSE = "MPLv1.1 GPLv2+ LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0e92e1a36cc384b60f5b31dde0bdd39e" | ||
10 | |||
11 | SRC_URI = "http://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-${PV}.tar.gz" | ||
12 | |||
13 | inherit autotools pkgconfig | ||
14 | |||
15 | EXTRA_OECONF = "--enable-freexl=no" | ||
16 | |||
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite/fix-the-configure-script-and-freexl.patch b/meta-oe/recipes-navigation/libspatialite/libspatialite/fix-the-configure-script-and-freexl.patch new file mode 100644 index 000000000..0cd0c3f6a --- /dev/null +++ b/meta-oe/recipes-navigation/libspatialite/libspatialite/fix-the-configure-script-and-freexl.patch | |||
@@ -0,0 +1,200 @@ | |||
1 | From upstream fossil repo, extracted via git, dropping configure.ac for amalgamation | ||
2 | |||
3 | From: sandro <sandro> | ||
4 | Date: Sat, 21 Jan 2012 16:53:28 +0000 | ||
5 | Subject: [PATCH] fixing the ./configure script: --enable-geocallbacks=no is | ||
6 | the new default and fixing some flaws for | ||
7 | --enable-freexl=no | ||
8 | |||
9 | --- | ||
10 | configure | 20 ++++++++++---------- | ||
11 | configure.ac | 20 ++++++++++---------- | ||
12 | src/shapefiles/shapefiles.c | 2 ++ | ||
13 | 4 files changed, 32 insertions(+), 30 deletions(-) | ||
14 | |||
15 | diff --git a/configure b/configure | ||
16 | index e8cf620..917bfca 100755 | ||
17 | --- a/configure | ||
18 | +++ b/configure | ||
19 | @@ -1410,7 +1410,7 @@ Optional Features: | ||
20 | optimize for fast installation [default=yes] | ||
21 | --disable-libtool-lock avoid locking (might break parallel builds) | ||
22 | --enable-mathsql enables SQL math functions [default=yes] | ||
23 | - --enable-geocallbacks enables geometry callbacks [default=yes] | ||
24 | + --enable-geocallbacks enables geometry callbacks [default=no] | ||
25 | --enable-proj enables PROJ.4 inclusion [default=yes] | ||
26 | --enable-geos enables GEOS inclusion [default=yes] | ||
27 | --enable-geosadvanced enables GEOS advanced features [default=yes] | ||
28 | @@ -16980,7 +16980,7 @@ ac_config_files="$ac_config_files Makefile src/Makefile src/headers/Makefile src | ||
29 | if test "${enable_mathsql+set}" = set; then : | ||
30 | enableval=$enable_mathsql; | ||
31 | else | ||
32 | - mathsql=yes | ||
33 | + enable_mathsql=yes | ||
34 | fi | ||
35 | |||
36 | if test x"$enable_mathsql" != "xno"; then | ||
37 | @@ -16998,10 +16998,10 @@ fi | ||
38 | if test "${enable_geocallbacks+set}" = set; then : | ||
39 | enableval=$enable_geocallbacks; | ||
40 | else | ||
41 | - geocallbacks=yes | ||
42 | + enable_geocallbacks=no | ||
43 | fi | ||
44 | |||
45 | -if test x"$enable_geocallbacks" != "xno"; then | ||
46 | +if test x"$enable_geocallbacks" == "xyes"; then | ||
47 | OMIT_GEOCALLBACKS_FLAGS= | ||
48 | { $as_echo "$as_me:${as_lineno-$LINENO}: checking for sqlite3_rtree_geometry_callback in -lsqlite3" >&5 | ||
49 | $as_echo_n "checking for sqlite3_rtree_geometry_callback in -lsqlite3... " >&6; } | ||
50 | @@ -17063,7 +17063,7 @@ fi | ||
51 | if test "${enable_proj+set}" = set; then : | ||
52 | enableval=$enable_proj; | ||
53 | else | ||
54 | - proj=yes | ||
55 | + enable_proj=yes | ||
56 | fi | ||
57 | |||
58 | if test x"$enable_proj" != "xno"; then | ||
59 | @@ -17153,7 +17153,7 @@ fi | ||
60 | if test "${enable_geos+set}" = set; then : | ||
61 | enableval=$enable_geos; | ||
62 | else | ||
63 | - geos=yes | ||
64 | + enable_geos=yes | ||
65 | fi | ||
66 | |||
67 | if test x"$enable_geos" != "xno"; then | ||
68 | @@ -17237,7 +17237,7 @@ fi | ||
69 | if test "${enable_geosadvanced+set}" = set; then : | ||
70 | enableval=$enable_geosadvanced; | ||
71 | else | ||
72 | - geosadvanced=yes | ||
73 | + enable_geosadvanced=yes | ||
74 | fi | ||
75 | |||
76 | if test x"$enable_geosadvanced" != "xno"; then | ||
77 | @@ -17316,7 +17316,7 @@ fi | ||
78 | if test "${enable_iconv+set}" = set; then : | ||
79 | enableval=$enable_iconv; | ||
80 | else | ||
81 | - geos=yes | ||
82 | + enable_iconv=yes | ||
83 | fi | ||
84 | |||
85 | if test x"$enable_iconv" != "xno"; then | ||
86 | @@ -17579,7 +17579,7 @@ fi | ||
87 | if test "${enable_freexl+set}" = set; then : | ||
88 | enableval=$enable_freexl; | ||
89 | else | ||
90 | - proj=yes | ||
91 | + enable_freexl=yes | ||
92 | fi | ||
93 | |||
94 | if test x"$enable_freexl" != "xno"; then | ||
95 | @@ -17669,7 +17669,7 @@ fi | ||
96 | if test "${enable_epsg+set}" = set; then : | ||
97 | enableval=$enable_epsg; | ||
98 | else | ||
99 | - epsg=yes | ||
100 | + enable_epsg=yes | ||
101 | fi | ||
102 | |||
103 | if test x"$enable_epsg" != "xno"; then | ||
104 | diff --git a/configure.ac b/configure.ac | ||
105 | index 216cc9f..69cb6c5 100644 | ||
106 | --- a/configure.ac | ||
107 | +++ b/configure.ac | ||
108 | @@ -79,7 +79,7 @@ AC_CONFIG_FILES([Makefile \ | ||
109 | # | ||
110 | AC_ARG_ENABLE(mathsql, [AS_HELP_STRING( | ||
111 | [--enable-mathsql], [enables SQL math functions [default=yes]])], | ||
112 | - [], [mathsql=yes]) | ||
113 | + [], [enable_mathsql=yes]) | ||
114 | if test x"$enable_mathsql" != "xno"; then | ||
115 | OMIT_MATHSQL_FLAGS= | ||
116 | else | ||
117 | @@ -92,9 +92,9 @@ AC_SUBST(OMIT_MATHSQL_FLAGS) | ||
118 | # --enable-geocallbacks | ||
119 | # | ||
120 | AC_ARG_ENABLE(geocallbacks, [AS_HELP_STRING( | ||
121 | - [--enable-geocallbacks], [enables geometry callbacks [default=yes]])], | ||
122 | - [], [geocallbacks=yes]) | ||
123 | -if test x"$enable_geocallbacks" != "xno"; then | ||
124 | + [--enable-geocallbacks], [enables geometry callbacks [default=no]])], | ||
125 | + [], [enable_geocallbacks=no]) | ||
126 | +if test x"$enable_geocallbacks" == "xyes"; then | ||
127 | OMIT_GEOCALLBACKS_FLAGS= | ||
128 | AC_CHECK_LIB(sqlite3,sqlite3_rtree_geometry_callback,,AC_MSG_ERROR([obsolete 'libsqlite3' (< v.3.7.3). please retry specifying: --disable-geocallbacks]),-lm) | ||
129 | else | ||
130 | @@ -108,7 +108,7 @@ AC_SUBST(OMIT_GEOCALLBACKS_FLAGS) | ||
131 | # | ||
132 | AC_ARG_ENABLE(proj, [AS_HELP_STRING( | ||
133 | [--enable-proj], [enables PROJ.4 inclusion [default=yes]])], | ||
134 | - [], [proj=yes]) | ||
135 | + [], [enable_proj=yes]) | ||
136 | if test x"$enable_proj" != "xno"; then | ||
137 | OMIT_PROJ_FLAGS= | ||
138 | AC_CHECK_HEADERS(proj_api.h,, [AC_MSG_ERROR([cannot find proj_api.h, bailing out])]) | ||
139 | @@ -124,7 +124,7 @@ AC_SUBST(OMIT_PROJ_FLAGS) | ||
140 | # | ||
141 | AC_ARG_ENABLE(geos, [AS_HELP_STRING( | ||
142 | [--enable-geos], [enables GEOS inclusion [default=yes]])], | ||
143 | - [], [geos=yes]) | ||
144 | + [], [enable_geos=yes]) | ||
145 | if test x"$enable_geos" != "xno"; then | ||
146 | OMIT_GEOS_FLAGS= | ||
147 | AC_CHECK_HEADERS(geos_c.h,, [AC_MSG_ERROR([cannot find geos_c.h, bailing out])]) | ||
148 | @@ -134,7 +134,7 @@ if test x"$enable_geos" != "xno"; then | ||
149 | # | ||
150 | AC_ARG_ENABLE(geosadvanced, [AS_HELP_STRING( | ||
151 | [--enable-geosadvanced], [enables GEOS advanced features [default=yes]])], | ||
152 | - [], [geosadvanced=yes]) | ||
153 | + [], [enable_geosadvanced=yes]) | ||
154 | if test x"$enable_geosadvanced" != "xno"; then | ||
155 | GEOSADVANCED_FLAGS=-DGEOS_ADVANCED | ||
156 | AC_SEARCH_LIBS(GEOSCoveredBy,geos_c,,AC_MSG_ERROR([obsolete 'libgeos_c' (< v.3.3.0). please retry specifying: --disable-geosadvanced.]),-lm -lgeos) | ||
157 | @@ -152,7 +152,7 @@ AC_SUBST(OMIT_GEOS_FLAGS) | ||
158 | # | ||
159 | AC_ARG_ENABLE(iconv, [AS_HELP_STRING( | ||
160 | [--enable-iconv], [enables ICONV inclusion [default=yes]])], | ||
161 | - [], [geos=yes]) | ||
162 | + [], [enable_iconv=yes]) | ||
163 | if test x"$enable_iconv" != "xno"; then | ||
164 | OMIT_ICONV_FLAGS= | ||
165 | AC_CHECK_HEADERS(iconv.h,, [AC_MSG_ERROR([cannot find iconv.h, bailing out])]) | ||
166 | @@ -172,7 +172,7 @@ AC_SUBST(OMIT_ICONV_FLAGS) | ||
167 | # | ||
168 | AC_ARG_ENABLE(freexl, [AS_HELP_STRING( | ||
169 | [--enable-freexl], [enables FreeXL inclusion [default=yes]])], | ||
170 | - [], [proj=yes]) | ||
171 | + [], [enable_freexl=yes]) | ||
172 | if test x"$enable_freexl" != "xno"; then | ||
173 | OMIT_FREEXL_FLAGS= | ||
174 | AC_CHECK_HEADERS(freexl.h,, [AC_MSG_ERROR([cannot find freexl.h, bailing out])]) | ||
175 | @@ -188,7 +188,7 @@ AC_SUBST(OMIT_FREEXL_FLAGS) | ||
176 | # | ||
177 | AC_ARG_ENABLE(epsg, [AS_HELP_STRING( | ||
178 | [--enable-epsg], [enables full EPSG dataset support [default=yes]])], | ||
179 | - [], [epsg=yes]) | ||
180 | + [], [enable_epsg=yes]) | ||
181 | if test x"$enable_epsg" != "xno"; then | ||
182 | OMIT_EPSG_FLAGS= | ||
183 | else | ||
184 | diff --git a/src/shapefiles/shapefiles.c b/src/shapefiles/shapefiles.c | ||
185 | index 4bf5fd0..09e3cd3 100644 | ||
186 | --- a/src/shapefiles/shapefiles.c | ||
187 | +++ b/src/shapefiles/shapefiles.c | ||
188 | @@ -62,7 +62,9 @@ the terms of any one of the MPL, the GPL or the LGPL. | ||
189 | #include <spatialite/gaiageo.h> | ||
190 | #include <spatialite.h> | ||
191 | |||
192 | +#ifndef OMIT_FREEXL | ||
193 | #include <freexl.h> | ||
194 | +#endif | ||
195 | |||
196 | #if defined(_WIN32) && !defined(__MINGW32__) | ||
197 | #define strcasecmp _stricmp | ||
198 | -- | ||
199 | 1.7.9.1 | ||
200 | |||
diff --git a/meta-oe/recipes-navigation/libspatialite/libspatialite_3.0.1.bb b/meta-oe/recipes-navigation/libspatialite/libspatialite_3.0.1.bb new file mode 100644 index 000000000..1cb72e828 --- /dev/null +++ b/meta-oe/recipes-navigation/libspatialite/libspatialite_3.0.1.bb | |||
@@ -0,0 +1,9 @@ | |||
1 | require libspatialite.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI[md5sum] = "450d1a0d9da1bd9f770b7db3f2509f69" | ||
6 | SRC_URI[sha256sum] = "4983d6584069fd5ff0cfcccccee1015088dab2db177c0dc7050ce8306b68f8e6" | ||
7 | |||
8 | SRC_URI =+ "file://fix-the-configure-script-and-freexl.patch" | ||
9 | |||