diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-08 16:37:23 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-09-23 15:34:26 +0200 |
commit | 57f718ec3eb75b10278b0ea0d7e3dbd8e8d8bd74 (patch) | |
tree | 7e4bed6e777e038022a1456612ca4092b7def9b6 /meta-oe | |
parent | 11d91e658ff2f9c38481f96c7b162ef6883da023 (diff) | |
download | meta-openembedded-57f718ec3eb75b10278b0ea0d7e3dbd8e8d8bd74.tar.gz |
postgresql.inc: fix indentation to use 4 spaces
* like rest of meta-oe and other sane layers
* never mix tabs and spaces (especially on the same line)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/postgresql/postgresql.inc | 165 |
1 files changed, 82 insertions, 83 deletions
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc index 2b8db3452..f3ff22583 100644 --- a/meta-oe/recipes-support/postgresql/postgresql.inc +++ b/meta-oe/recipes-support/postgresql/postgresql.inc | |||
@@ -12,11 +12,11 @@ DESCRIPTION = "\ | |||
12 | server over a network connection. This package contains the docs \ | 12 | server over a network connection. This package contains the docs \ |
13 | in HTML for the whole package, as well as command-line utilities for \ | 13 | in HTML for the whole package, as well as command-line utilities for \ |
14 | managing PostgreSQL databases on a PostgreSQL server. \ | 14 | managing PostgreSQL databases on a PostgreSQL server. \ |
15 | \ | 15 | \ |
16 | If you want to manipulate a PostgreSQL database on a local or remote \ | 16 | If you want to manipulate a PostgreSQL database on a local or remote \ |
17 | PostgreSQL server, you need this package. You also need to install \ | 17 | PostgreSQL server, you need this package. You also need to install \ |
18 | this package if you're installing the postgresql-server package. \ | 18 | this package if you're installing the postgresql-server package. \ |
19 | " | 19 | " |
20 | HOMEPAGE = "http://www.postgresql.com" | 20 | HOMEPAGE = "http://www.postgresql.com" |
21 | LICENSE = "BSD" | 21 | LICENSE = "BSD" |
22 | DEPENDS = "zlib readline tzcode-native" | 22 | DEPENDS = "zlib readline tzcode-native" |
@@ -25,13 +25,13 @@ INC_PR = "r0" | |||
25 | ARM_INSTRUCTION_SET = "arm" | 25 | ARM_INSTRUCTION_SET = "arm" |
26 | 26 | ||
27 | SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \ | 27 | SRC_URI = "http://ftp.postgresql.org/pub/source/v${PV}/${BP}.tar.bz2 \ |
28 | file://postgresql.init \ | 28 | file://postgresql.init \ |
29 | file://postgresql-bashprofile \ | 29 | file://postgresql-bashprofile \ |
30 | file://postgresql.pam \ | 30 | file://postgresql.pam \ |
31 | file://postgresql-setup \ | 31 | file://postgresql-setup \ |
32 | file://postgresql.service \ | 32 | file://postgresql.service \ |
33 | file://0001-Use-pkg-config-for-libxml2-detection.patch \ | 33 | file://0001-Use-pkg-config-for-libxml2-detection.patch \ |
34 | " | 34 | " |
35 | 35 | ||
36 | LEAD_SONAME = "libpq.so" | 36 | LEAD_SONAME = "libpq.so" |
37 | 37 | ||
@@ -60,22 +60,21 @@ PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," | |||
60 | PACKAGECONFIG[python] = "--with-python,--without-python,python,python" | 60 | PACKAGECONFIG[python] = "--with-python,--without-python,python,python" |
61 | PACKAGECONFIG[uuid] = "--with-ossp-uuid,--without-ossp-uuid,ossp-uuid," | 61 | PACKAGECONFIG[uuid] = "--with-ossp-uuid,--without-ossp-uuid,ossp-uuid," |
62 | # when tcl native package is fixed change WORKDIR to STAGING_BINDIR_CROSS | 62 | # when tcl native package is fixed change WORKDIR to STAGING_BINDIR_CROSS |
63 | PACKAGECONFIG[tcl] = \ | 63 | PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl," |
64 | "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl," | ||
65 | PACKAGECONFIG[nls] = "--enable-nls,--disable-nls,," | 64 | PACKAGECONFIG[nls] = "--enable-nls,--disable-nls,," |
66 | PACKAGECONFIG[libxml] = "--with-libxml,--without-libxml,libxml2,libxml2" | 65 | PACKAGECONFIG[libxml] = "--with-libxml,--without-libxml,libxml2,libxml2" |
67 | PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl" | 66 | PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl" |
68 | 67 | ||
69 | EXTRA_OECONF += "--enable-thread-safety --disable-rpath \ | 68 | EXTRA_OECONF += "--enable-thread-safety --disable-rpath \ |
70 | --datadir=${datadir}/${BPN} \ | 69 | --datadir=${datadir}/${BPN} \ |
71 | --sysconfdir=${sysconfdir}/${BPN} \ | 70 | --sysconfdir=${sysconfdir}/${BPN} \ |
72 | " | 71 | " |
73 | EXTRA_OECONF_sh4 += "--disable-spinlocks" | 72 | EXTRA_OECONF_sh4 += "--disable-spinlocks" |
74 | EXTRA_OECONF_aarch64 += "--disable-spinlocks" | 73 | EXTRA_OECONF_aarch64 += "--disable-spinlocks" |
75 | 74 | ||
76 | PACKAGES_DYNAMIC += "^${PN}-plperl ^${PN}-plperl-dbg \ | 75 | PACKAGES_DYNAMIC += "^${PN}-plperl ^${PN}-plperl-dbg \ |
77 | ^${PN}-pltcl ^${PN}-pltcl-dbg \ | 76 | ^${PN}-pltcl ^${PN}-pltcl-dbg \ |
78 | ^${PN}-plpython ^${PN}-plpython-dbg \ | 77 | ^${PN}-plpython ^${PN}-plpython-dbg \ |
79 | " | 78 | " |
80 | 79 | ||
81 | python populate_packages_prepend() { | 80 | python populate_packages_prepend() { |
@@ -110,47 +109,47 @@ python populate_packages_prepend() { | |||
110 | } | 109 | } |
111 | 110 | ||
112 | do_configure() { | 111 | do_configure() { |
113 | # do_configure_prepend | 112 | # do_configure_prepend |
114 | # make sure configure finds python includdirs with these envs | 113 | # make sure configure finds python includdirs with these envs |
115 | export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | 114 | export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ |
116 | STAGING_INCDIR=${STAGING_INCDIR} \ | 115 | STAGING_INCDIR=${STAGING_INCDIR} \ |
117 | STAGING_LIBDIR=${STAGING_LIBDIR} | 116 | STAGING_LIBDIR=${STAGING_LIBDIR} |
118 | 117 | ||
119 | # do_configure | 118 | # do_configure |
120 | autotools_do_configure | 119 | autotools_do_configure |
121 | 120 | ||
122 | # do_configure_append | 121 | # do_configure_append |
123 | # workaround perl package related bugs | 122 | # workaround perl package related bugs |
124 | sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \ | 123 | sed -i -e "s:-L/usr/local/lib:-L=/usr/local/lib:g" \ |
125 | ${B}/src/Makefile.global | 124 | ${B}/src/Makefile.global |
126 | LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native" | 125 | LIBPNA="\${STAGING_LIBDIR_NATIVE}/perl-native" |
127 | LIBNA="\${STAGING_LIBDIR_NATIVE}" | 126 | LIBNA="\${STAGING_LIBDIR_NATIVE}" |
128 | BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}" | 127 | BLIBNA="\${STAGING_BASE_LIBDIR_NATIVE}" |
129 | sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 128 | sed -i -e "/^perl_archlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
130 | ${B}/src/Makefile.global | 129 | ${B}/src/Makefile.global |
131 | sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 130 | sed -i -e "/^perl_privlibexp/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
132 | ${B}/src/Makefile.global | 131 | ${B}/src/Makefile.global |
133 | # remove the rpath, replace with correct lib path | 132 | # remove the rpath, replace with correct lib path |
134 | sed -i \ | 133 | sed -i \ |
135 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \ | 134 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${LIBNA}::g" \ |
136 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${BLIBNA}::g" \ | 135 | -e "/^perl_embed_ldflags/s:-Wl,-rpath,${BLIBNA}::g" \ |
137 | -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${LIBNA}::g" \ | 136 | -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${LIBNA}::g" \ |
138 | -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${BLIBNA}::g" \ | 137 | -e "/^perl_embed_ldflags/s:-Wl,-rpath-link,${BLIBNA}::g" \ |
139 | -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ | 138 | -e "/^perl_embed_ldflags/s:${LIBPNA}:${STAGING_LIBDIR}:g" \ |
140 | -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \ | 139 | -e "/^perl_embed_ldflags/s:${LIBNA}:${STAGING_LIBDIR}:g" \ |
141 | -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \ | 140 | -e "/^perl_embed_ldflags/s:${BLIBNA}:${STAGING_BASELIBDIR}:g" \ |
142 | -e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \ | 141 | -e "/^TCLSH/s:=.*:= ${bindir}/tclsh:g" \ |
143 | ${B}/src/Makefile.global | 142 | ${B}/src/Makefile.global |
144 | 143 | ||
145 | # workaround perl package's libperl.so problem | 144 | # workaround perl package's libperl.so problem |
146 | # we are using perlnative so this perl should have same version | 145 | # we are using perlnative so this perl should have same version |
147 | perl_version=`perl -v 2>/dev/null | \ | 146 | perl_version=`perl -v 2>/dev/null | \ |
148 | sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'` | 147 | sed -n 's/This is perl.*v[a-z ]*\([0-9]\.[0-9][0-9.]*\).*$/\1/p'` |
149 | if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \ | 148 | if [ ! -h "${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so" -a \ |
150 | ! -h "${STAGING_LIBDIR}/libperl.so" ]; then | 149 | ! -h "${STAGING_LIBDIR}/libperl.so" ]; then |
151 | ln -sf ../../../libperl.so.5 \ | 150 | ln -sf ../../../libperl.so.5 \ |
152 | ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so | 151 | ${STAGING_LIBDIR}/perl/$perl_version/CORE/libperl.so |
153 | fi | 152 | fi |
154 | } | 153 | } |
155 | 154 | ||
156 | do_compile_append() { | 155 | do_compile_append() { |
@@ -209,11 +208,11 @@ do_install_append() { | |||
209 | SSTATE_SCAN_FILES += "Makefile.global" | 208 | SSTATE_SCAN_FILES += "Makefile.global" |
210 | 209 | ||
211 | PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \ | 210 | PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \ |
212 | libecpg-compat-dbg libecpg-compat libecpg-compat-dev \ | 211 | libecpg-compat-dbg libecpg-compat libecpg-compat-dev \ |
213 | libecpg-dbg libecpg libecpg-dev libecpg-staticdev libecpg-doc \ | 212 | libecpg-dbg libecpg libecpg-dev libecpg-staticdev libecpg-doc \ |
214 | libpq-dbg libpq libpq-dev libpq-staticdev \ | 213 | libpq-dbg libpq libpq-dev libpq-staticdev \ |
215 | libpgtypes-dbg libpgtypes libpgtypes-staticdev libpgtypes-dev \ | 214 | libpgtypes-dbg libpgtypes libpgtypes-staticdev libpgtypes-dev \ |
216 | ${PN}-contrib ${PN}-contrib-dbg \ | 215 | ${PN}-contrib ${PN}-contrib-dbg \ |
217 | " | 216 | " |
218 | 217 | ||
219 | FILES_${PN} += "${sysconfdir}/init.d/${BPN}-server \ | 218 | FILES_${PN} += "${sysconfdir}/init.d/${BPN}-server \ |
@@ -236,21 +235,21 @@ FILES_${PN}-dbg += " ${libdir}/${BPN}/.debug/dict_snowball.so \ | |||
236 | " | 235 | " |
237 | 236 | ||
238 | FILES_${PN}-client = "${bindir}/clusterdb \ | 237 | FILES_${PN}-client = "${bindir}/clusterdb \ |
239 | ${bindir}/createdb \ | 238 | ${bindir}/createdb \ |
240 | ${bindir}/createlang \ | 239 | ${bindir}/createlang \ |
241 | ${bindir}/createuser \ | 240 | ${bindir}/createuser \ |
242 | ${bindir}/dropdb \ | 241 | ${bindir}/dropdb \ |
243 | ${bindir}/droplang \ | 242 | ${bindir}/droplang \ |
244 | ${bindir}/dropuser \ | 243 | ${bindir}/dropuser \ |
245 | ${bindir}/pg_dump \ | 244 | ${bindir}/pg_dump \ |
246 | ${bindir}/pg_dumpall \ | 245 | ${bindir}/pg_dumpall \ |
247 | ${bindir}/pg_restore \ | 246 | ${bindir}/pg_restore \ |
248 | ${bindir}/psql \ | 247 | ${bindir}/psql \ |
249 | ${bindir}/reindexdb \ | 248 | ${bindir}/reindexdb \ |
250 | ${bindir}/vacuumdb \ | 249 | ${bindir}/vacuumdb \ |
251 | ${bindir}/vacuumlo \ | 250 | ${bindir}/vacuumlo \ |
252 | ${datadir}/${BPN}/psqlrc.sample" | 251 | ${datadir}/${BPN}/psqlrc.sample \ |
253 | 252 | " | |
254 | FILES_${PN}-client-doc = "${mandir}/man1/clusterdb.* \ | 253 | FILES_${PN}-client-doc = "${mandir}/man1/clusterdb.* \ |
255 | ${mandir}/man1/createdb.* ${mandir}/man1/createlang.* \ | 254 | ${mandir}/man1/createdb.* ${mandir}/man1/createlang.* \ |
256 | ${mandir}/man1/createuser.* ${mandir}/man1/dropdb.* \ | 255 | ${mandir}/man1/createuser.* ${mandir}/man1/dropdb.* \ |
@@ -260,13 +259,11 @@ FILES_${PN}-client-doc = "${mandir}/man1/clusterdb.* \ | |||
260 | ${mandir}/man1/reindexdb.* ${mandir}/man1/vacuumdb.* \ | 259 | ${mandir}/man1/reindexdb.* ${mandir}/man1/vacuumdb.* \ |
261 | ${mandir}/man7/* \ | 260 | ${mandir}/man7/* \ |
262 | " | 261 | " |
263 | |||
264 | FILES_${PN}-doc += "${docdir}/${BPN}/html ${libdir}/${BPN}/tutorial/ \ | 262 | FILES_${PN}-doc += "${docdir}/${BPN}/html ${libdir}/${BPN}/tutorial/ \ |
265 | ${mandir}/man1/initdb.* ${mandir}/man1/pg_controldata.* \ | 263 | ${mandir}/man1/initdb.* ${mandir}/man1/pg_controldata.* \ |
266 | ${mandir}/man1/pg_ctl.* ${mandir}/man1/pg_resetxlog.* \ | 264 | ${mandir}/man1/pg_ctl.* ${mandir}/man1/pg_resetxlog.* \ |
267 | ${mandir}/man1/postgres.* ${mandir}/man1/postmaster.* \ | 265 | ${mandir}/man1/postgres.* ${mandir}/man1/postmaster.* \ |
268 | " | 266 | " |
269 | |||
270 | FILES_${PN}-timezone = "${datadir}/${BPN}/timezone \ | 267 | FILES_${PN}-timezone = "${datadir}/${BPN}/timezone \ |
271 | ${datadir}/${BPN}/timezonesets \ | 268 | ${datadir}/${BPN}/timezonesets \ |
272 | " | 269 | " |
@@ -276,10 +273,11 @@ FILES_${PN}-server-dev = "${includedir}/${BPN}/server" | |||
276 | FILES_libecpg = "${libdir}/libecpg*${SOLIBS}" | 273 | FILES_libecpg = "${libdir}/libecpg*${SOLIBS}" |
277 | FILES_libecpg-dbg = "${libdir}/.debug/libecpg*" | 274 | FILES_libecpg-dbg = "${libdir}/.debug/libecpg*" |
278 | FILES_libecpg-dev = "${libdir}/libecpg*${SOLIBSDEV} \ | 275 | FILES_libecpg-dev = "${libdir}/libecpg*${SOLIBSDEV} \ |
279 | ${libdir}/libpgtypes*${SOLIBSDEV} \ | 276 | ${libdir}/libpgtypes*${SOLIBSDEV} \ |
280 | ${includedir}/ecpg*.h ${includedir}/${BPN}/ecpg*.h \ | 277 | ${includedir}/ecpg*.h ${includedir}/${BPN}/ecpg*.h \ |
281 | ${includedir}/pgtypes*.h ${includedir}/${BPN}/informix \ | 278 | ${includedir}/pgtypes*.h ${includedir}/${BPN}/informix \ |
282 | ${includedir}/sql3types.h ${includedir}/sqlca.h" | 279 | ${includedir}/sql3types.h ${includedir}/sqlca.h \ |
280 | " | ||
283 | FILES_libecpg-doc = "${mandir}/man1/ecpg.*" | 281 | FILES_libecpg-doc = "${mandir}/man1/ecpg.*" |
284 | FILES_libecpg-staticdev = "${libdir}/libecpg*.a" | 282 | FILES_libecpg-staticdev = "${libdir}/libecpg*.a" |
285 | SECTION_libecpg-staticdev = "devel" | 283 | SECTION_libecpg-staticdev = "devel" |
@@ -288,7 +286,8 @@ RDEPENDS_libecpg-staticdev = "libecpg-dev (= ${EXTENDPKGV})" | |||
288 | FILES_libpq = "${libdir}/libpq*${SOLIBS}" | 286 | FILES_libpq = "${libdir}/libpq*${SOLIBS}" |
289 | FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${BPN}/pgxs/src/test/regress/.debug/*" | 287 | FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${BPN}/pgxs/src/test/regress/.debug/*" |
290 | FILES_libpq-dev = "${libdir}/libpq*${SOLIBSDEV} \ | 288 | FILES_libpq-dev = "${libdir}/libpq*${SOLIBSDEV} \ |
291 | ${includedir}" | 289 | ${includedir} \ |
290 | " | ||
292 | FILES_libpq-staticdev = "${libdir}/libpq*.a ${libdir}/libpgport.a" | 291 | FILES_libpq-staticdev = "${libdir}/libpq*.a ${libdir}/libpgport.a" |
293 | SECTION_libpq-staticdev = "devel" | 292 | SECTION_libpq-staticdev = "devel" |
294 | RDEPENDS_libpq-staticdev = "libpq-dev (= ${EXTENDPKGV})" | 293 | RDEPENDS_libpq-staticdev = "libpq-dev (= ${EXTENDPKGV})" |