diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-07-08 06:17:40 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-07-14 23:44:31 +0200 |
commit | 5693b474a5014b27db5d842ebd1a690dec9ccc17 (patch) | |
tree | 2570677c9d9c8f50589970cdf31c974f9b5e3115 /meta-oe | |
parent | 5c98b0fd943beeec3efe8ab89f3a85b3b3729136 (diff) | |
download | meta-openembedded-5693b474a5014b27db5d842ebd1a690dec9ccc17.tar.gz |
libdbus-c++: Fix build with gcc7 and unblacklist
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/0001-pipe.c-Use-a-string-instead-of-char.patch | 27 | ||||
-rw-r--r-- | meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb | 20 |
2 files changed, 36 insertions, 11 deletions
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/0001-pipe.c-Use-a-string-instead-of-char.patch b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/0001-pipe.c-Use-a-string-instead-of-char.patch new file mode 100644 index 000000000..6883f9a0b --- /dev/null +++ b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/0001-pipe.c-Use-a-string-instead-of-char.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 6bcb58bd69c38b9200e8ec6c382247167571189d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 1 Jul 2017 16:44:15 -0700 | ||
4 | Subject: [PATCH] pipe.c: Use a string instead of char | ||
5 | |||
6 | Fixes | ||
7 | error: invalid conversion from 'char' to 'const void*' [-fpermissive] | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/pipe.cpp | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/src/pipe.cpp b/src/pipe.cpp | ||
15 | index 45c2ba6..1303c2d 100644 | ||
16 | --- a/src/pipe.cpp | ||
17 | +++ b/src/pipe.cpp | ||
18 | @@ -83,5 +83,5 @@ ssize_t Pipe::read(void *buffer, unsigned int &nbytes) | ||
19 | void Pipe::signal() | ||
20 | { | ||
21 | // TODO: ignoring return of read/write generates warning; maybe relevant for eventloop work... | ||
22 | - ::write(_fd_write, '\0', 1); | ||
23 | + ::write(_fd_write, "", 1); | ||
24 | } | ||
25 | -- | ||
26 | 2.13.2 | ||
27 | |||
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb index 4412716a6..4cc133301 100644 --- a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb +++ b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb | |||
@@ -6,15 +6,15 @@ LICENSE = "LGPLv2.1" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
7 | DEPENDS = "dbus expat glib-2.0 libpcre" | 7 | DEPENDS = "dbus expat glib-2.0 libpcre" |
8 | 8 | ||
9 | SRC_URI = "\ | 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \ |
10 | ${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BP}.tar.gz \ | 10 | file://fix-missing-unistd.h-include.patch \ |
11 | file://fix-missing-unistd.h-include.patch \ | 11 | file://remove-CXX_FOR_BUILD-stuff.patch \ |
12 | file://remove-CXX_FOR_BUILD-stuff.patch \ | 12 | file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \ |
13 | file://0001-src-eventloop.cpp-use-portable-method-for-initializi.patch \ | 13 | file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \ |
14 | file://0002-tools-generate_proxy.cpp-avoid-possibly-undefined-ui.patch \ | 14 | file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \ |
15 | file://0003-Fixed-undefined-ssize_t-for-clang-3.8.0-on-FreeBSD.patch \ | 15 | file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \ |
16 | file://0004-use-POSIX-poll.h-instead-of-sys-poll.h.patch \ | 16 | file://0001-pipe.c-Use-a-string-instead-of-char.patch \ |
17 | " | 17 | " |
18 | SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2" | 18 | SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2" |
19 | SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61" | 19 | SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61" |
20 | 20 | ||
@@ -27,5 +27,3 @@ PACKAGE_BEFORE_PN = "${PN}-tools" | |||
27 | FILES_${PN}-tools = "${bindir}" | 27 | FILES_${PN}-tools = "${bindir}" |
28 | 28 | ||
29 | BBCLASSEXTEND = "native" | 29 | BBCLASSEXTEND = "native" |
30 | |||
31 | PNBLACKLIST[libdbus-c++] ?= "Fails to build with RSS http://errors.yoctoproject.org/Errors/Details/130644/ - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||