diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-03-22 19:26:44 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-04-05 19:26:13 +0200 |
commit | 4ecaaf8c1d62d05a82a086c9ca5327ee9358502d (patch) | |
tree | 9996f8e3f8d76138c5b9b51951c1d66b8df4037a /meta-oe | |
parent | c142219d33d80fe9525dfda10650fb6f88270b29 (diff) | |
download | meta-openembedded-4ecaaf8c1d62d05a82a086c9ca5327ee9358502d.tar.gz |
tcsh: Update to 6.20.00 release
Fix segfaults on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
15 files changed, 134 insertions, 261 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.1.patch b/meta-oe/recipes-extended/tcsh/files/01_build.1.patch deleted file mode 100644 index b9f41ade9..000000000 --- a/meta-oe/recipes-extended/tcsh/files/01_build.1.patch +++ /dev/null | |||
@@ -1,16 +0,0 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Original comment: Fix build | ||
3 | Not sure why we have this patch. Let's keep it for compatibility. | ||
4 | --- a/pathnames.h | ||
5 | +++ b/pathnames.h | ||
6 | @@ -92,6 +92,10 @@ | ||
7 | # define _PATH_TCSHELL "/local/bin/tcsh" /* use ram disk */ | ||
8 | #endif /* _MINIX && !_PATH_TCSHELL */ | ||
9 | |||
10 | +#ifndef _PATH_TCSHELL | ||
11 | +# define _PATH_TCSHELL "/bin/tcsh" /* Debian */ | ||
12 | +#endif /* !_PATH_TCSHELL */ | ||
13 | + | ||
14 | #if defined(__EMX__) && !defined(_PATH_DEVNULL) | ||
15 | # define _PATH_DEVNULL "nul" | ||
16 | #endif /* __EMX__ && !_PATH_DEVNULL */ | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.2.patch b/meta-oe/recipes-extended/tcsh/files/01_build.2.patch deleted file mode 100644 index ff2753154..000000000 --- a/meta-oe/recipes-extended/tcsh/files/01_build.2.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Update manpage. | ||
3 | --- a/tcsh.man | ||
4 | +++ b/tcsh.man | ||
5 | @@ -578,7 +578,7 @@ Repeating \fIdabbrev-expand\fR without a | ||
6 | changes to the next previous word etc., skipping identical matches | ||
7 | much like \fIhistory-search-backward\fR does. | ||
8 | .TP 8 | ||
9 | -.B delete-char \fR(not bound) | ||
10 | +.B delete-char \fR(bound to `Del' if using the standard \fI/etc/csh.cshrc\fR) | ||
11 | Deletes the character under the cursor. | ||
12 | See also \fIdelete-char-or-list-or-eof\fR. | ||
13 | .TP 8 | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.3.patch b/meta-oe/recipes-extended/tcsh/files/01_build.3.patch deleted file mode 100644 index d36c177af..000000000 --- a/meta-oe/recipes-extended/tcsh/files/01_build.3.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Enable NODOT | ||
3 | --- a/config_f.h | ||
4 | +++ b/config_f.h | ||
5 | @@ -98,7 +98,7 @@ | ||
6 | /* | ||
7 | * NODOT Don't put "." in the default path, for security reasons | ||
8 | */ | ||
9 | -#undef NODOT | ||
10 | +#define NODOT | ||
11 | |||
12 | /* | ||
13 | * AUTOLOGOUT tries to determine if it should set autologout depending | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch b/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch deleted file mode 100644 index faa59cc80..000000000 --- a/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Don't die on unknown LS_COLORS values | ||
3 | Removing the patch causes a segfault when dircolors is set by coreutils' dircolors. | ||
4 | Debian-Bug: #592089 | ||
5 | |||
6 | --- a/tw.color.c | ||
7 | +++ b/tw.color.c | ||
8 | @@ -239,13 +239,10 @@ parseLS_COLORS(const Char *value) | ||
9 | if ((Char)variables[i].variable[0] == (v[0] & CHAR) && | ||
10 | (Char)variables[i].variable[1] == (v[1] & CHAR)) | ||
11 | break; | ||
12 | - if (i < nvariables) { | ||
13 | - v += 3; | ||
14 | + v += 3; | ||
15 | + if (i < nvariables) | ||
16 | getstring(&c, &v, &variables[i].color, ':'); | ||
17 | - continue; | ||
18 | - } | ||
19 | - else | ||
20 | - stderror(ERR_BADCOLORVAR, v[0], v[1]); | ||
21 | + continue; | ||
22 | } | ||
23 | break; | ||
24 | } | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch b/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch deleted file mode 100644 index cbc9f65d0..000000000 --- a/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: do not strip binary | ||
3 | Stripping should be handled by dh_strip instead, so DEB_BUILD_OPTIONS=nostrip works. | ||
4 | Closes: #438109, #411607 | ||
5 | --- a/Makefile.in | ||
6 | +++ b/Makefile.in | ||
7 | @@ -596,7 +596,6 @@ install: tcsh$(EXEEXT) | ||
8 | -mkdir -p ${DESTBIN} | ||
9 | -mv -f ${DESTBIN}/tcsh$(EXEEXT) ${DESTBIN}/tcsh.old | ||
10 | cp tcsh$(EXEEXT) ${DESTBIN}/tcsh$(EXEEXT) | ||
11 | - -strip ${DESTBIN}/tcsh$(EXEEXT) | ||
12 | chmod 755 ${DESTBIN}/tcsh$(EXEEXT) | ||
13 | |||
14 | install.man: tcsh.man | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch b/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch deleted file mode 100644 index 0bda0ba10..000000000 --- a/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: disable syntactically incorrect test | ||
3 | --- a/tests/lexical.at | ||
4 | +++ b/tests/lexical.at | ||
5 | @@ -172,9 +172,6 @@ | ||
6 | AT_DATA([nohist.csh], | ||
7 | [echo ! space ! tab != "!(" newline ! | ||
8 | ]) | ||
9 | -AT_CHECK([tcsh -f nohist.csh], , | ||
10 | -[[! space ! tab != !( newline ! | ||
11 | -]]) | ||
12 | |||
13 | AT_CLEANUP | ||
14 | |||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch b/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch deleted file mode 100644 index 98a9b2e1d..000000000 --- a/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | --- a/tests/lexical.at | ||
2 | +++ b/tests/lexical.at | ||
3 | @@ -27,27 +27,6 @@ AT_CHECK([tcsh -f oneword.csh], , | ||
4 | |||
5 | AT_CLEANUP | ||
6 | |||
7 | - | ||
8 | -AT_SETUP([Comments]) | ||
9 | - | ||
10 | -AT_CHECK([echo 'echo OK@%:@comment' | tcsh -f], , [OK | ||
11 | -]) | ||
12 | - | ||
13 | -AT_CHECK([tcsh -f -c 'echo @%:@no comment'], , | ||
14 | -[@%:@no comment | ||
15 | -]) | ||
16 | - | ||
17 | -AT_DATA([comment2.csh], | ||
18 | -[[echo testing...@%:@\ | ||
19 | -OK | ||
20 | -]]) | ||
21 | -AT_CHECK([tcsh -f comment2.csh], , | ||
22 | -[testing... OK | ||
23 | -]) | ||
24 | - | ||
25 | -AT_CLEANUP | ||
26 | - | ||
27 | - | ||
28 | AT_SETUP([Escaping special characters]) | ||
29 | |||
30 | AT_DATA([nosplit.csh], | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch deleted file mode 100644 index 79f918c08..000000000 --- a/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: disable test that fails on the buildd with | ||
3 | "setpriority: Permission denied". | ||
4 | --- a/tests/commands.at | ||
5 | +++ b/tests/commands.at | ||
6 | @@ -888,17 +888,6 @@ TCSH_UNTESTED([migrate]) | ||
7 | TCSH_UNTESTED([newgrp]) | ||
8 | |||
9 | |||
10 | -AT_SETUP([nice]) | ||
11 | - | ||
12 | -# Nothing really tested | ||
13 | -AT_CHECK([tcsh -f -c 'nice set var=1; echo $?var'], , | ||
14 | -[0 | ||
15 | -]) | ||
16 | - | ||
17 | - | ||
18 | -AT_CLEANUP | ||
19 | - | ||
20 | - | ||
21 | AT_SETUP([nohup]) | ||
22 | |||
23 | AT_DATA([nohup.csh], | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch deleted file mode 100644 index 69f0564e8..000000000 --- a/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch +++ /dev/null | |||
@@ -1,30 +0,0 @@ | |||
1 | From: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: Those tests fail when running the testsuite without a tty. Disabling them. | ||
3 | |||
4 | --- a/tests/commands.at | ||
5 | +++ b/tests/commands.at | ||
6 | @@ -1203,11 +1203,6 @@ AT_SETUP([source]) | ||
7 | AT_DATA([script.csh], | ||
8 | [[set var=$1 | ||
9 | ]]) | ||
10 | -AT_CHECK([[tcsh -f -c 'source -h script.csh foo; history' \ | ||
11 | - | sed 's/ [^ ]* / TIME /']], , | ||
12 | -[ 1 TIME source -h script.csh foo ; history | ||
13 | - 2 TIME set var=$1 | ||
14 | -]) | ||
15 | |||
16 | AT_CHECK([tcsh -f -c 'source -h script.csh foo; echo $var'], 1, [], | ||
17 | [var: Undefined variable. | ||
18 | --- a/tests/variables.at | ||
19 | +++ b/tests/variables.at | ||
20 | @@ -319,10 +319,6 @@ AT_CLEANUP | ||
21 | |||
22 | AT_SETUP([$ edit]) | ||
23 | |||
24 | -AT_CHECK([TERM=something tcsh -f -c 'echo $?edit'], , | ||
25 | -[1 | ||
26 | -]) | ||
27 | - | ||
28 | AT_CHECK([TERM=dumb tcsh -f -c 'echo $?edit'], , | ||
29 | [0 | ||
30 | ]) | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch b/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch deleted file mode 100644 index acc2ce93d..000000000 --- a/meta-oe/recipes-extended/tcsh/files/fix-gcc6-wait-union.patch +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | --- tcsh-6.18.01/sh.proc.c.orig 2016-06-08 16:11:02.902326725 +0000 | ||
2 | +++ tcsh-6.18.01/sh.proc.c 2016-06-08 16:38:22.150304901 +0000 | ||
3 | @@ -48,7 +48,7 @@ | ||
4 | #endif /* aiws */ | ||
5 | |||
6 | #if defined(_BSD) || (defined(IRIS4D) && __STDC__) || defined(__lucid) || defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) | ||
7 | -# if !defined(__ANDROID__) | ||
8 | +# if !defined(__ANDROID__) && !defined(__GLIBC__) | ||
9 | # define BSDWAIT | ||
10 | # endif | ||
11 | #endif /* _BSD || (IRIS4D && __STDC__) || __lucid || glibc */ | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch deleted file mode 100644 index 3dd420a0e..000000000 --- a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org> | ||
2 | Description: fix broken globbing expansion | ||
3 | Debian-Bug: #603545 | ||
4 | Index: tcsh-6.18.01/tc.str.c | ||
5 | =================================================================== | ||
6 | --- tcsh-6.18.01.orig/tc.str.c 2012-01-10 13:34:31.000000000 -0800 | ||
7 | +++ tcsh-6.18.01/tc.str.c 2013-02-26 13:12:13.429153489 -0800 | ||
8 | @@ -122,8 +122,9 @@ | ||
9 | #else | ||
10 | ret = mbtowc(&tmp, s, n); | ||
11 | #endif | ||
12 | - if (ret > 0) { | ||
13 | + if (ret >= 0) | ||
14 | *pwc = tmp; | ||
15 | + if (ret >= 0) { | ||
16 | #if defined(UTF16_STRINGS) && defined(HAVE_MBRTOWC) | ||
17 | if (tmp >= 0xd800 && tmp <= 0xdbff) { | ||
18 | /* UTF-16 surrogate pair. Fetch second half and compute | ||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch b/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch new file mode 100644 index 000000000..ff2f6a3b6 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/tcsh/0001-Enable-system-malloc-on-all-linux.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 0553455813a1f717ef50cc911e4db73da3d23c32 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Mar 2017 18:47:40 -0700 | ||
4 | Subject: [PATCH 1/2] Enable system malloc on all linux | ||
5 | |||
6 | Dont trigger on being just android or glibc | ||
7 | internal malloc falls flat on musl based systems | ||
8 | as well. So switch to using system malloc | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | config_f.h | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/config_f.h b/config_f.h | ||
16 | index 6a632a5..0a66960 100644 | ||
17 | --- a/config_f.h | ||
18 | +++ b/config_f.h | ||
19 | @@ -139,7 +139,7 @@ | ||
20 | * This can be much slower and no memory statistics will be | ||
21 | * provided. | ||
22 | */ | ||
23 | -#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__GLIBC__) || defined(__OpenBSD__) || defined(__APPLE__) || defined (__ANDROID__) | ||
24 | +#if defined(__MACHTEN__) || defined(PURIFY) || defined(MALLOC_TRACE) || defined(_OSD_POSIX) || defined(__MVS__) || defined (__CYGWIN__) || defined(__linux__) || defined(__OpenBSD__) || defined(__APPLE__) | ||
25 | # define SYSMALLOC | ||
26 | #else | ||
27 | # undef SYSMALLOC | ||
28 | -- | ||
29 | 2.12.1 | ||
30 | |||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch b/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch new file mode 100644 index 000000000..e4de6f7fe --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/tcsh/0002-Add-debian-csh-scripts.patch | |||
@@ -0,0 +1,60 @@ | |||
1 | From 60271713025f6b17dda29721be012a8428e77185 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 22 Mar 2017 18:56:49 -0700 | ||
4 | Subject: [PATCH 2/2] Add debian csh scripts | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | csh.cshrc | 15 +++++++++++++++ | ||
9 | csh.login | 8 ++++++++ | ||
10 | csh.logout | 1 + | ||
11 | 3 files changed, 24 insertions(+) | ||
12 | create mode 100644 csh.cshrc | ||
13 | create mode 100644 csh.login | ||
14 | create mode 100644 csh.logout | ||
15 | |||
16 | diff --git a/csh.cshrc b/csh.cshrc | ||
17 | new file mode 100644 | ||
18 | index 0000000..29c934a | ||
19 | --- /dev/null | ||
20 | +++ b/csh.cshrc | ||
21 | @@ -0,0 +1,15 @@ | ||
22 | +# /etc/csh.cshrc: system-wide .cshrc file for csh(1) and tcsh(1) | ||
23 | + | ||
24 | +if ($?tcsh && $?prompt) then | ||
25 | + | ||
26 | + bindkey "\e[1~" beginning-of-line # Home | ||
27 | + bindkey "\e[7~" beginning-of-line # Home rxvt | ||
28 | + bindkey "\e[2~" overwrite-mode # Ins | ||
29 | + bindkey "\e[3~" delete-char # Delete | ||
30 | + bindkey "\e[4~" end-of-line # End | ||
31 | + bindkey "\e[8~" end-of-line # End rxvt | ||
32 | + | ||
33 | + set autoexpand | ||
34 | + set autolist | ||
35 | + set prompt = "%U%m%u:%B%~%b%# " | ||
36 | +endif | ||
37 | diff --git a/csh.login b/csh.login | ||
38 | new file mode 100644 | ||
39 | index 0000000..2455c3c | ||
40 | --- /dev/null | ||
41 | +++ b/csh.login | ||
42 | @@ -0,0 +1,8 @@ | ||
43 | +# /etc/csh.login: system-wide .login file for csh(1) and tcsh(1) | ||
44 | + | ||
45 | +# allow for other packages/system admins to customize the shell environment | ||
46 | +if (-e /etc/csh/login.d && `/bin/ls /etc/csh/login.d` != "") then | ||
47 | + foreach FILE (`/bin/ls /etc/csh/login.d/*`) | ||
48 | + source $FILE; | ||
49 | + end; | ||
50 | +endif | ||
51 | diff --git a/csh.logout b/csh.logout | ||
52 | new file mode 100644 | ||
53 | index 0000000..a207eba | ||
54 | --- /dev/null | ||
55 | +++ b/csh.logout | ||
56 | @@ -0,0 +1 @@ | ||
57 | +# /etc/csh.logout: system-wide .logout file for csh(1) and tcsh(1) | ||
58 | -- | ||
59 | 2.12.1 | ||
60 | |||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb deleted file mode 100644 index 1cfd96c54..000000000 --- a/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ | ||
2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ | ||
3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ | ||
4 | programmable word completion, spelling correction and more." | ||
5 | |||
6 | HOMEPAGE = "http://www.tcsh.org/" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780" | ||
9 | SECTION = "base" | ||
10 | DEPENDS = "ncurses gettext-native" | ||
11 | SRC_URI = " \ | ||
12 | ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \ | ||
13 | ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs2 \ | ||
14 | ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-5.diff.gz;name=diffs5 \ | ||
15 | file://01_build.1.patch \ | ||
16 | file://01_build.2.patch \ | ||
17 | file://01_build.3.patch \ | ||
18 | file://15_no-strip.patch \ | ||
19 | file://disable-test-notty.patch \ | ||
20 | file://disable-test-nice.patch \ | ||
21 | file://disable-lexical.at-31.patch \ | ||
22 | file://12_unknown_lscolors.patch \ | ||
23 | file://tcsh-6.17.02-multibyte.patch \ | ||
24 | file://disable-broken-test.patch \ | ||
25 | file://fix-gcc6-wait-union.patch \ | ||
26 | " | ||
27 | SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a" | ||
28 | SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8" | ||
29 | SRC_URI[diffs2.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9" | ||
30 | SRC_URI[diffs2.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c" | ||
31 | SRC_URI[diffs5.md5sum] = "d536c12a02dc48c332cc472b86927319" | ||
32 | SRC_URI[diffs5.sha256sum] = "7548d64bf996548bfbc13f3e0959fd2e8455f8375381a31da67d79554aabc7af" | ||
33 | |||
34 | inherit autotools | ||
35 | |||
36 | do_install_append () { | ||
37 | oe_runmake install.man DESTDIR=${D} | ||
38 | |||
39 | install -d ${D}${base_bindir} | ||
40 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh | ||
41 | |||
42 | install -d ${D}${sysconfdir}/csh/login.d | ||
43 | install -m 0644 ${S}/debian/csh.cshrc ${S}/debian/csh.login ${S}/debian/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} | ||
44 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el | ||
45 | } | ||
46 | |||
47 | FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" | ||
48 | |||
49 | |||
50 | pkg_postinst_${PN} () { | ||
51 | #!/bin/sh -e | ||
52 | echo /usr/bin/tcsh >> $D/etc/shells | ||
53 | } | ||
54 | |||
55 | PNBLACKLIST[tcsh] ?= "Doesn't respect CC variable and fails with HOSTTOOLS http://errors.yoctoproject.org/Errors/Details/138244/" | ||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb new file mode 100644 index 000000000..b59d88f5d --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/tcsh_6.20.00.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ | ||
2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ | ||
3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ | ||
4 | programmable word completion, spelling correction and more." | ||
5 | |||
6 | HOMEPAGE = "http://www.tcsh.org/" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | LIC_FILES_CHKSUM = "file://Copyright;md5=575cf2715c3bf894e1f79aec1d4eaaf5" | ||
9 | SECTION = "base" | ||
10 | DEPENDS = "ncurses gettext-native" | ||
11 | SRC_URI = " \ | ||
12 | http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/${BP}.tar.gz \ | ||
13 | file://0001-Enable-system-malloc-on-all-linux.patch \ | ||
14 | file://0002-Add-debian-csh-scripts.patch \ | ||
15 | " | ||
16 | SRC_URI[md5sum] = "59d40ef40a68e790d95e182069431834" | ||
17 | SRC_URI[sha256sum] = "b89de7064ab54dac454a266cfe5d8bf66940cb5ed048d0c30674ea62e7ecef9d" | ||
18 | |||
19 | EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'" | ||
20 | inherit autotools | ||
21 | |||
22 | do_compile_prepend() { | ||
23 | oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost | ||
24 | } | ||
25 | |||
26 | do_install_append () { | ||
27 | oe_runmake install.man DESTDIR=${D} | ||
28 | |||
29 | install -d ${D}${base_bindir} | ||
30 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh | ||
31 | ln -s /usr/bin/tcsh ${D}${base_bindir}/csh | ||
32 | install -d ${D}${sysconfdir}/csh/login.d | ||
33 | install -m 0644 ${S}/csh.cshrc ${S}/csh.login ${S}/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} | ||
34 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el | ||
35 | } | ||
36 | |||
37 | FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" | ||
38 | |||
39 | |||
40 | pkg_postinst_${PN} () { | ||
41 | #!/bin/sh -e | ||
42 | echo /usr/bin/tcsh >> $D/etc/shells | ||
43 | echo /usr/bin/csh >> $D/etc/shells | ||
44 | } | ||