diff options
author | Jack Mitchell <jack@embed.me.uk> | 2016-05-09 17:31:29 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-19 12:02:38 +0200 |
commit | 44a13e69ba5f24f7c02d87ad2afbdc4a04f06f43 (patch) | |
tree | 5bdace7ed6295317b56ee4d7c4bbc64017f74a85 /meta-oe | |
parent | 901b9a2ec805b3be0dfdd9a399c5969c2b580029 (diff) | |
download | meta-openembedded-44a13e69ba5f24f7c02d87ad2afbdc4a04f06f43.tar.gz |
libsoc: update to 0.8.1
- New python bindings supported
- New board config options supported
- PACKAGECONFIG options added for other configure flags
Signed-off-by: Jack Mitchell <jack@embed.me.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb | 17 | ||||
-rw-r--r-- | meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb | 32 |
2 files changed, 32 insertions, 17 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb deleted file mode 100644 index 911e0ba9f..000000000 --- a/meta-oe/recipes-support/libsoc/libsoc_0.7.1.bb +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | SUMMARY = "Library for interfacing with common SoC peripherals" | ||
2 | DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \ | ||
3 | found in SoC (System on Chips) through generic Linux Kernel interfaces." | ||
4 | |||
5 | HOMEPAGE = "https://github.com/jackmitch/libsoc" | ||
6 | |||
7 | LICENSE = "LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5" | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | SRCREV = "2919c35e706fe7c311f83f9343865420fa4b37fe" | ||
13 | SRC_URI = "git://github.com/jackmitch/libsoc.git" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | RDEPENDS_${PN} = "libgcc" | ||
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb new file mode 100644 index 000000000..cf39278a6 --- /dev/null +++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.1.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "Library for interfacing with common SoC peripherals" | ||
2 | DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \ | ||
3 | found in SoC (System on Chips) through generic Linux Kernel interfaces." | ||
4 | |||
5 | HOMEPAGE = "https://github.com/jackmitch/libsoc" | ||
6 | |||
7 | LICENSE = "LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=e0bfebea12a718922225ba987b2126a5" | ||
9 | |||
10 | inherit autotools pkgconfig python-dir | ||
11 | |||
12 | SRCREV = "7fc953f980f4a51f0272ad691d3aa06b6aedbf16" | ||
13 | SRC_URI = "git://github.com/jackmitch/libsoc.git" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | BOARD ??= "devboard" | ||
18 | |||
19 | PACKAGECONFIG ?= "" | ||
20 | |||
21 | PACKAGECONFIG[disabledebug] = "--disable-debug,," | ||
22 | PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," | ||
23 | PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," | ||
24 | PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}" | ||
25 | |||
26 | PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ | ||
27 | '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" | ||
28 | |||
29 | RDEPENDS_${PN} = "libgcc" | ||
30 | |||
31 | FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a" | ||
32 | FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}" | ||