diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-05-03 18:12:36 -0300 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-06 12:40:26 +0200 |
commit | 3132af1d1d15209f3512eba8d8885b909b3b13ca (patch) | |
tree | d627665cb7ca02b64c6fd5f28fd4792559ff0b1b /meta-oe | |
parent | 5bece73f64ae7f736cd08eef387d67d74e31a424 (diff) | |
download | meta-openembedded-3132af1d1d15209f3512eba8d8885b909b3b13ca.tar.gz |
opencv: Fix metapkg dependencies for opencv-java and opencv-locales
The opencv-java is not always generated so we ought to include it,
only if it is available. The opencv-locales is not available and ought
to be skipped.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/opencv/opencv_3.1.bb | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_3.1.bb b/meta-oe/recipes-support/opencv/opencv_3.1.bb index c1f980262..789512f9e 100644 --- a/meta-oe/recipes-support/opencv/opencv_3.1.bb +++ b/meta-oe/recipes-support/opencv/opencv_3.1.bb | |||
@@ -79,7 +79,8 @@ export ANT_DIR="${STAGING_DIR_NATIVE}/usr/share/ant/" | |||
79 | 79 | ||
80 | TARGET_CC_ARCH += "-I${S}/include " | 80 | TARGET_CC_ARCH += "-I${S}/include " |
81 | 81 | ||
82 | PACKAGES += "${PN}-java-dbg ${PN}-java ${PN}-samples-dbg ${PN}-samples ${PN}-apps python-opencv" | 82 | PACKAGES += "${PN}-samples-dbg ${PN}-samples ${PN}-apps python-opencv \ |
83 | ${@bb.utils.contains('PACKAGECONFIG', 'oracle-java', '${PN}-java-dbg ${PN}-java', '', d)}" | ||
83 | 84 | ||
84 | python populate_packages_prepend () { | 85 | python populate_packages_prepend () { |
85 | cv_libdir = d.expand('${libdir}') | 86 | cv_libdir = d.expand('${libdir}') |
@@ -104,7 +105,7 @@ python populate_packages_prepend () { | |||
104 | blacklist = [ metapkg ] | 105 | blacklist = [ metapkg ] |
105 | metapkg_rdepends = [ ] | 106 | metapkg_rdepends = [ ] |
106 | for pkg in packages[1:]: | 107 | for pkg in packages[1:]: |
107 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') : | 108 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.endswith('-dev') and not pkg.endswith('-dbg') and not pkg.endswith('-doc') and not pkg.endswith('-locale'): |
108 | metapkg_rdepends.append(pkg) | 109 | metapkg_rdepends.append(pkg) |
109 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) | 110 | bb.data.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends), d) |
110 | 111 | ||