summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2016-11-03 03:14:59 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-26 01:04:53 +0100
commitbf1de4db269729dcf62c18f5c15aa53df8e5a534 (patch)
tree91effd6f94f7308765cb0d47104f521e401306b2 /meta-oe
parentc5fd46f74a5b4f1af67b18493b9de31666e13dcf (diff)
downloadmeta-openembedded-bf1de4db269729dcf62c18f5c15aa53df8e5a534.tar.gz
libvdpau: Add recipe
Needed for x86 machines Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/vdpau/libvdpau_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/vdpau/libvdpau_git.bb b/meta-oe/recipes-graphics/vdpau/libvdpau_git.bb
new file mode 100644
index 000000000..31f4df486
--- /dev/null
+++ b/meta-oe/recipes-graphics/vdpau/libvdpau_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Video Decode and Presentation API for UNIX"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=83af8811a28727a13f04132cc33b7f58"
5
6DEPENDS = "virtual/libx11 libxext dri2proto"
7
8PV = "1.1.1+git${SRCPV}"
9
10SRCREV = "a21bf7aa438f5dd40d0a300a3167aa3d6f26dccc"
11SRC_URI = "git://anongit.freedesktop.org/vdpau/libvdpau"
12
13S = "${WORKDIR}/git"
14
15inherit autotools pkgconfig
16
17do_install_append() {
18 rm -f ${D}${libdir}/*/*.la
19}
20
21FILES_${PN}-dbg += "${libdir}/vdpau/.debug"
22FILES_${PN}-dev += "${libdir}/vdpau/lib*${SOLIBSDEV}"
23FILES_${PN} += "${libdir}/vdpau/lib*${SOLIBS}"