diff options
author | Koen Kooi <koen.kooi@linaro.org> | 2014-01-17 13:06:13 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-01-22 12:22:48 +0100 |
commit | ef03b5a1180e89afae8ab80ec826c27905d88e52 (patch) | |
tree | e0c5cd98d372199eaee010f0d238e878dd4626aa /meta-oe | |
parent | 6deef6adf3d59feaeae678ad693f2ba36e34e550 (diff) | |
download | meta-openembedded-ef03b5a1180e89afae8ab80ec826c27905d88e52.tar.gz |
acpica: replace patch with EXTRA_OEMAKE args
No need to patch the makefile when you can just passs CC=${TARGET_PREFIX}gcc to make.
Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/acpica/acpica_20140114.bb | 3 | ||||
-rw-r--r-- | meta-oe/recipes-extended/acpica/files/cross-compile.patch | 19 |
2 files changed, 1 insertions, 21 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpica_20140114.bb b/meta-oe/recipes-extended/acpica/acpica_20140114.bb index 5cc2d5a94..2bb7ad7bf 100644 --- a/meta-oe/recipes-extended/acpica/acpica_20140114.bb +++ b/meta-oe/recipes-extended/acpica/acpica_20140114.bb | |||
@@ -12,7 +12,6 @@ LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c | |||
12 | DEPENDS = "bison flex" | 12 | DEPENDS = "bison flex" |
13 | 13 | ||
14 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ | 14 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ |
15 | file://cross-compile.patch \ | ||
16 | file://no-werror.patch \ | 15 | file://no-werror.patch \ |
17 | " | 16 | " |
18 | SRC_URI[md5sum] = "fcd4b7304f1bfabc7d4b9cfdecc6b0c6" | 17 | SRC_URI[md5sum] = "fcd4b7304f1bfabc7d4b9cfdecc6b0c6" |
@@ -20,7 +19,7 @@ SRC_URI[sha256sum] = "0d5bd32690ab77e21ab143ef25361c314a4ed13c33a5fb3ddd6f5559ab | |||
20 | 19 | ||
21 | S = "${WORKDIR}/acpica-unix2-${PV}" | 20 | S = "${WORKDIR}/acpica-unix2-${PV}" |
22 | 21 | ||
23 | EXTRA_OEMAKE = "'OPT_CFLAGS=-Wall'" | 22 | EXTRA_OEMAKE = "CC=${TARGET_PREFIX}gcc 'OPT_CFLAGS=-Wall'" |
24 | 23 | ||
25 | do_install() { | 24 | do_install() { |
26 | install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl | 25 | install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl |
diff --git a/meta-oe/recipes-extended/acpica/files/cross-compile.patch b/meta-oe/recipes-extended/acpica/files/cross-compile.patch deleted file mode 100644 index f2917ca99..000000000 --- a/meta-oe/recipes-extended/acpica/files/cross-compile.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | Description: add cross compile support | ||
2 | Forwarded: not-needed | ||
3 | Author: Fathi Boudra <fathi.boudra@linaro.org> | ||
4 | |||
5 | --- | ||
6 | generate/unix/Makefile.config | 2 +- | ||
7 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
8 | |||
9 | --- a/generate/unix/Makefile.config | ||
10 | +++ b/generate/unix/Makefile.config | ||
11 | @@ -35,7 +35,7 @@ | ||
12 | .SUFFIXES : | ||
13 | PROGS = acpibin acpidump acpiexec acpihelp acpinames acpisrc acpixtract iasl | ||
14 | HOST ?= _CYGWIN | ||
15 | -CC = gcc | ||
16 | +CC ?= $(CROSS_COMPILE)gcc | ||
17 | |||
18 | # | ||
19 | # Common defines | ||