diff options
author | Yang Lyu <yang.lyu@axis.com> | 2018-03-21 12:40:54 +0100 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-13 12:40:56 -0700 |
commit | ed70b4f91f5fd6776f120cd5c9f915a8b999adfd (patch) | |
tree | 3329907a23ec3d062b8743ca30215228339b1f2b /meta-oe | |
parent | fa1913215275899b09c49c0bb5531f26909c5790 (diff) | |
download | meta-openembedded-ed70b4f91f5fd6776f120cd5c9f915a8b999adfd.tar.gz |
dbus-broker: Add recipe
DBus-broker is a drop-in replacement for dbus-daemon. It is an implementation of a message
bus as defined by the D-Bus specification. Its aim is to provide high performance and
reliability, while keeping compatibility to the D-Bus reference implementation.
0001-Comment-rst2man-related-stuff.patch avoids using rst2man.
0002-Correct-including-directory-for-conf.patch fixs path computation for <include> node.
The patch should be dropped when a newer version of dbus-broker that includes commit:
https://github.com/bus1/dbus-broker/commit/9af79016f0f6b1ee60779bc6dc4acd7b4b9e6c70
is available.
Signed-off-by: Yang Lyu <yang.lyu@axis.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
3 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch new file mode 100644 index 000000000..f10c49e7c --- /dev/null +++ b/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From a92fd7da3a262e21c0970a3908eb0b4502819a01 Mon Sep 17 00:00:00 2001 | ||
2 | From: Yang Lyu <yangl@axis.com> | ||
3 | Date: Fri, 23 Feb 2018 16:31:49 +0100 | ||
4 | Subject: [PATCH] Comment rst2man related stuff | ||
5 | |||
6 | --- | ||
7 | meson.build | 4 ++-- | ||
8 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
9 | |||
10 | diff --git a/meson.build b/meson.build | ||
11 | index 56d38e4..3c3b109 100644 | ||
12 | --- a/meson.build | ||
13 | +++ b/meson.build | ||
14 | @@ -15,7 +15,7 @@ add_project_arguments('-DBINDIR="' + join_paths(get_option('prefix'), get_option | ||
15 | cc = meson.get_compiler('c') | ||
16 | conf = configuration_data() | ||
17 | mod_pkgconfig = import('pkgconfig') | ||
18 | -prog_rst2man = find_program('rst2man', 'rst2man.py') | ||
19 | +#prog_rst2man = find_program('rst2man', 'rst2man.py') | ||
20 | |||
21 | sub_cdvar = subproject('c-dvar', version: '>=1') | ||
22 | sub_clist = subproject('c-list', version: '>=3') | ||
23 | @@ -56,7 +56,7 @@ endif | ||
24 | |||
25 | conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir'))) | ||
26 | |||
27 | -subdir('docs') | ||
28 | +#subdir('docs') | ||
29 | subdir('src') | ||
30 | |||
31 | if use_launcher | ||
32 | -- | ||
33 | 2.1.4 | ||
34 | |||
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch new file mode 100644 index 000000000..4909dea12 --- /dev/null +++ b/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | From 4b79f603b948709906c108796087de7b5643f61a Mon Sep 17 00:00:00 2001 | ||
2 | From: Yang Lyu <yangl@axis.com> | ||
3 | Date: Mon, 26 Feb 2018 12:48:34 +0100 | ||
4 | Subject: [PATCH] Correct including directory for conf | ||
5 | |||
6 | --- | ||
7 | src/launch/config.c | 2 +- | ||
8 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/src/launch/config.c b/src/launch/config.c | ||
11 | index 6a68699..579471b 100644 | ||
12 | --- a/src/launch/config.c | ||
13 | +++ b/src/launch/config.c | ||
14 | @@ -1022,7 +1022,7 @@ static void config_parser_end_fn(void *userdata, const XML_Char *name) { | ||
15 | state->file, | ||
16 | state->current->include.selinux_root_relative ? | ||
17 | bus_selinux_policy_root() : | ||
18 | - state->file->path, | ||
19 | + NULL, | ||
20 | state->current->cdata); | ||
21 | if (r) { | ||
22 | state->error = error_trace(r); | ||
23 | -- | ||
24 | 2.1.4 | ||
25 | |||
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb new file mode 100644 index 000000000..51dfe8c0a --- /dev/null +++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "dbus broker" | ||
2 | DESCRIPTION = "Drop-in replacement for dbus-daemon." | ||
3 | |||
4 | SECTION = "base" | ||
5 | |||
6 | LICENSE = "Apache-2.0" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8" | ||
8 | |||
9 | DEPENDS = "dbus glib-2.0 expat systemd" | ||
10 | |||
11 | PV = "9+git${SRCPV}" | ||
12 | SRCREV = "ccd06b284892182af569e69046262331150e3536" | ||
13 | |||
14 | SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git" | ||
15 | SRC_URI += "file://0001-Comment-rst2man-related-stuff.patch" | ||
16 | SRC_URI += "file://0002-Correct-including-directory-for-conf.patch" | ||
17 | |||
18 | S = "${WORKDIR}/git" | ||
19 | |||
20 | inherit meson pkgconfig systemd | ||
21 | |||
22 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" | ||
23 | |||
24 | FILES_${PN} += "${systemd_system_unitdir}" | ||
25 | FILES_${PN} += "${systemd_user_unitdir}" | ||
26 | |||
27 | RDEPENDS_${PN} = "dbus systemd" | ||
28 | |||
29 | BBCLASSEXTEND = "native" | ||