diff options
author | Kai Kang <kai.kang@windriver.com> | 2016-03-11 14:25:23 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-25 11:26:56 +0100 |
commit | ea5f03e641bf6f5aa7f9b72b2e64ee4496145d11 (patch) | |
tree | 66d9f740da54763e3ed9ac3dfef4f3e57c38b56d /meta-oe | |
parent | d017f375c41488a2b3910e156abdc33b93821d01 (diff) | |
download | meta-openembedded-ea5f03e641bf6f5aa7f9b72b2e64ee4496145d11.tar.gz |
crash: add native package
Add crash-native package.
* append EXTRA_OEMAKE option to find ncurses library
* pass right install DESTDIR
Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-kernel/crash/crash_7.1.3.bb | 17 |
1 files changed, 14 insertions, 3 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb b/meta-oe/recipes-kernel/crash/crash_7.1.3.bb index f6934f746..d057300f4 100644 --- a/meta-oe/recipes-kernel/crash/crash_7.1.3.bb +++ b/meta-oe/recipes-kernel/crash/crash_7.1.3.bb | |||
@@ -32,6 +32,8 @@ SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5 | |||
32 | 32 | ||
33 | inherit gettext | 33 | inherit gettext |
34 | 34 | ||
35 | BBCLASSEXTEND = "native" | ||
36 | |||
35 | # crash 7.1.3 and before don't support mips64 | 37 | # crash 7.1.3 and before don't support mips64 |
36 | COMPATIBLE_HOST = "^(?!mips64).*" | 38 | COMPATIBLE_HOST = "^(?!mips64).*" |
37 | 39 | ||
@@ -40,6 +42,7 @@ EXTRA_OEMAKE = 'RPMPKG="${PV}" \ | |||
40 | GDB_HOST="${BUILD_SYS}" \ | 42 | GDB_HOST="${BUILD_SYS}" \ |
41 | GDB_MAKE_JOBS="${PARALLEL_MAKE}" \ | 43 | GDB_MAKE_JOBS="${PARALLEL_MAKE}" \ |
42 | ' | 44 | ' |
45 | EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'" | ||
43 | 46 | ||
44 | do_configure() { | 47 | do_configure() { |
45 | : | 48 | : |
@@ -65,17 +68,25 @@ do_compile() { | |||
65 | oe_runmake ${EXTRA_OEMAKE} | 68 | oe_runmake ${EXTRA_OEMAKE} |
66 | } | 69 | } |
67 | 70 | ||
68 | do_install () { | 71 | do_install_prepend () { |
69 | install -d ${D}${bindir} | 72 | install -d ${D}${bindir} |
70 | install -d ${D}/${mandir}/man8 | 73 | install -d ${D}/${mandir}/man8 |
71 | install -d ${D}${includedir}/crash | 74 | install -d ${D}${includedir}/crash |
72 | 75 | ||
73 | oe_runmake DESTDIR=${D} install | ||
74 | install -m 0644 ${S}/crash.8 ${D}/${mandir}/man8/ | 76 | install -m 0644 ${S}/crash.8 ${D}/${mandir}/man8/ |
75 | install -m 0644 ${S}/defs.h ${D}${includedir}/crash | 77 | install -m 0644 ${S}/defs.h ${D}${includedir}/crash |
76 | } | 78 | } |
79 | |||
80 | do_install_class-target () { | ||
81 | oe_runmake DESTDIR=${D} install | ||
82 | } | ||
83 | |||
84 | do_install_class-native () { | ||
85 | oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install | ||
86 | } | ||
77 | 87 | ||
78 | RDEPENDS_${PN} += "liblzma" | 88 | RDEPENDS_${PN} += "liblzma" |
89 | RDEPENDS_${PN}_class-native = "" | ||
79 | 90 | ||
80 | # Causes gcc to get stuck and eat all available memory in qemuarm builds | 91 | # Causes gcc to get stuck and eat all available memory in qemuarm builds |
81 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - | 92 | # jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - |