diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2016-04-13 17:00:54 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-21 21:33:20 +0200 |
commit | 1eac35d508320257a63d49a661d3e3b7ba5c36e5 (patch) | |
tree | 2bb3bc144f77aa99af10b91aa5c6631f3c6fae62 /meta-oe | |
parent | 9676ebb7d14090126f667671d525ce3f3ee89279 (diff) | |
download | meta-openembedded-1eac35d508320257a63d49a661d3e3b7ba5c36e5.tar.gz |
libmodbus: add support for the libmodbus development release
libmodbus has two release streams:
- stable: which currently is 3.0.x and does only receive fixes
- development: 3.1.x which receives new features and according to upstream is also very stable
Some users require access to the newer features.
So a recipe for the development branch but leave the stable branch the default.
This is similar to what is done for the nginx recipe which also has two release streams.
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-extended/libmodbus/libmodbus.inc | 13 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libmodbus/libmodbus_3.0.6.bb | 14 | ||||
-rw-r--r-- | meta-oe/recipes-extended/libmodbus/libmodbus_3.1.2.bb | 7 |
3 files changed, 21 insertions, 13 deletions
diff --git a/meta-oe/recipes-extended/libmodbus/libmodbus.inc b/meta-oe/recipes-extended/libmodbus/libmodbus.inc new file mode 100644 index 000000000..a01659a72 --- /dev/null +++ b/meta-oe/recipes-extended/libmodbus/libmodbus.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | SUMMARY = "A Modbus library" | ||
2 | DESCRIPTION = "libmodbus is a C library designed to provide a fast and robust \ | ||
3 | implementation of the Modbus protocol. It runs on Linux, Mac OS X, FreeBSD, \ | ||
4 | QNX and Windows." | ||
5 | HOMEPAGE = "http://www.libmodbus.org/" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | LICENSE = "LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=4fbd65380cdd255951079008b364516c" | ||
10 | |||
11 | SRC_URI = "http://libmodbus.org/releases/${BP}.tar.gz" | ||
12 | |||
13 | inherit autotools pkgconfig | ||
diff --git a/meta-oe/recipes-extended/libmodbus/libmodbus_3.0.6.bb b/meta-oe/recipes-extended/libmodbus/libmodbus_3.0.6.bb index c5e6ae865..b4d32fb2c 100644 --- a/meta-oe/recipes-extended/libmodbus/libmodbus_3.0.6.bb +++ b/meta-oe/recipes-extended/libmodbus/libmodbus_3.0.6.bb | |||
@@ -1,16 +1,4 @@ | |||
1 | SUMMARY = "A Modbus library" | 1 | require libmodbus.inc |
2 | DESCRIPTION = "libmodbus is a C library designed to provide a fast and robust \ | ||
3 | implementation of the Modbus protocol. It runs on Linux, Mac OS X, FreeBSD, \ | ||
4 | QNX and Windows." | ||
5 | HOMEPAGE = "http://www.libmodbus.org/" | ||
6 | SECTION = "libs" | ||
7 | |||
8 | LICENSE = "LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=4fbd65380cdd255951079008b364516c" | ||
10 | |||
11 | SRC_URI = "http://libmodbus.org/site_media/build/${BP}.tar.gz" | ||
12 | |||
13 | inherit autotools pkgconfig | ||
14 | 2 | ||
15 | SRC_URI[md5sum] = "c80f88b6ca19cabc4ceffc195ca07771" | 3 | SRC_URI[md5sum] = "c80f88b6ca19cabc4ceffc195ca07771" |
16 | SRC_URI[sha256sum] = "046d63f10f755e2160dc56ef681e5f5ad3862a57c1955fd82e0ce036b69471b6" | 4 | SRC_URI[sha256sum] = "046d63f10f755e2160dc56ef681e5f5ad3862a57c1955fd82e0ce036b69471b6" |
diff --git a/meta-oe/recipes-extended/libmodbus/libmodbus_3.1.2.bb b/meta-oe/recipes-extended/libmodbus/libmodbus_3.1.2.bb new file mode 100644 index 000000000..6fcfc3a1f --- /dev/null +++ b/meta-oe/recipes-extended/libmodbus/libmodbus_3.1.2.bb | |||
@@ -0,0 +1,7 @@ | |||
1 | require libmodbus.inc | ||
2 | |||
3 | # Use the stable branch by default | ||
4 | DEFAULT_PREFERENCE = "-1" | ||
5 | |||
6 | SRC_URI[md5sum] = "dd4262f87ed835c4d1e560f8321a222c" | ||
7 | SRC_URI[sha256sum] = "661e14f9dc904f3f1b034464ddaa5fd4b8472f8f5d1ea10a1148af85591b7ee9" | ||