diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2013-05-13 06:55:00 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-16 11:04:34 +0200 |
commit | f93c6fd16efcf5acd90c3449350731b0bdf69910 (patch) | |
tree | d661d6becabfbb5ffed7c2b72d75cccdfb705854 /meta-oe | |
parent | d3fd0666c9b725ece67c18972f18c5d321efccc9 (diff) | |
download | meta-openembedded-f93c6fd16efcf5acd90c3449350731b0bdf69910.tar.gz |
read-edid: add 2.0.0
only build parse-edid, get-edid uses x86.h
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch | 28 | ||||
-rw-r--r-- | meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb | 23 |
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch b/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch new file mode 100644 index 000000000..440800235 --- /dev/null +++ b/meta-oe/recipes-support/read-edid/read-edid/0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From eb7590cc2cdd5c35403af4567d8524e017010f1c Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Sat, 11 May 2013 07:58:17 +0200 | ||
4 | Subject: [PATCH] configure: remove check for x86.h, we don't build get-edid | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | |||
8 | Upstream-status: Inappropriate [OE specific] | ||
9 | --- | ||
10 | configure.in | 2 -- | ||
11 | 1 file changed, 2 deletions(-) | ||
12 | |||
13 | diff --git a/configure.in b/configure.in | ||
14 | index ac85a21..f53e904 100644 | ||
15 | --- a/configure.in | ||
16 | +++ b/configure.in | ||
17 | @@ -8,8 +8,6 @@ dnl Checks for programs | ||
18 | |||
19 | AC_PROG_CC | ||
20 | |||
21 | -AC_CHECK_HEADER([libx86.h], [], [AC_MSG_ERROR([libx86.h not found])]) | ||
22 | - | ||
23 | dnl Simple, huh? | ||
24 | |||
25 | AC_OUTPUT([Makefile]) | ||
26 | -- | ||
27 | 1.8.1.4 | ||
28 | |||
diff --git a/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb b/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb new file mode 100644 index 000000000..b002906fa --- /dev/null +++ b/meta-oe/recipes-support/read-edid/read-edid_2.0.0.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "read-edid elucidates various very useful informations from a conforming PnP monitor" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d0bf70fa1ef81fe4741ec0e6231dadfd" | ||
4 | |||
5 | SRC_URI = "http://polypux.org/projects/read-edid/read-edid-${PV}.tar.gz \ | ||
6 | file://0001-configure-remove-check-for-x86.h-we-don-t-build-get-.patch" | ||
7 | |||
8 | SRC_URI[md5sum] = "586e7fa1167773b27f4e505edc93274b" | ||
9 | SRC_URI[sha256sum] = "246ec14ec509e09ac26fe6862b120481b2cc881e2f142ba40886d6eec15e77e8" | ||
10 | |||
11 | inherit autotools | ||
12 | |||
13 | do_compile() { | ||
14 | oe_runmake parse-edid | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${bindir} | ||
19 | install -m 0755 parse-edid ${D}${bindir} | ||
20 | } | ||
21 | |||
22 | PACKAGES =+ "parse-edid" | ||
23 | FILES_parse-edid = "${bindir}/parse-edid" | ||