summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPawel Langowski <pawel.langowski@3mdeb.com>2023-08-23 13:50:33 +0200
committerKhem Raj <raj.khem@gmail.com>2023-08-26 17:32:44 -0700
commitedda40dd00fdfce3b0f9731b7a6f7e1e840fbc0d (patch)
tree509ff028364092f4875e76134b221b5d65d3024b /meta-oe
parent7bfbf9eee8b45ad294d1a79523e16bba5fab7a11 (diff)
downloadmeta-openembedded-edda40dd00fdfce3b0f9731b7a6f7e1e840fbc0d.tar.gz
qcbor: add recipe
This adds QCBOR - a CBOR encoder/decoder library Signed-off-by: Pawel Langowski <pawel.langowski@3mdeb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/qcbor/qcbor_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/qcbor/qcbor_git.bb b/meta-oe/recipes-extended/qcbor/qcbor_git.bb
new file mode 100644
index 000000000..9c562d5a6
--- /dev/null
+++ b/meta-oe/recipes-extended/qcbor/qcbor_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = " \
2 QCBOR is a powerful, commercial-quality CBOR encoder/decoder that \
3 implements these RFCs: RFC8949, RFC7049, RFC8742, RFC8943 \
4"
5
6HOMEPAGE = "https://github.com/laurencelundblade/QCBOR"
7
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://README.md;beginline=442;endline=463;md5=b55643261d6d221dac2b7a395105af62"
10
11SRC_URI = "git://github.com/laurencelundblade/QCBOR;protocol=https;branch=master"
12
13SRCREV = "44754f738c6534a4304a83d4c6e97b3d3193d887"
14
15PV = "1.2+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19inherit pkgconfig
20
21CFLAGS += " \
22 -DUSEFULBUF_DISABLE_ALL_FLOAT \
23"
24
25do_install(){
26 install -d ${D}${libdir}
27 install -m 755 ${S}/libqcbor.a ${D}${libdir}/
28 install -d ${D}${includedir}/qcbor
29 install -m 644 ${S}/inc/*.h ${D}${includedir}
30 install -m 644 ${S}/inc/qcbor/*.h ${D}${includedir}/qcbor
31}
32