diff options
author | Andre McCurdy <armccurdy@gmail.com> | 2017-01-25 15:31:59 -0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-02-13 18:43:23 +0100 |
commit | ebef44963866d3231ccfe79d66d21c96ca0b4113 (patch) | |
tree | 3eae06de942ade83dfaac41f506f32d77b5a13e7 /meta-oe | |
parent | e79566f51dde46145cfdc3732a6e1464ff27f4f3 (diff) | |
download | meta-openembedded-ebef44963866d3231ccfe79d66d21c96ca0b4113.tar.gz |
remove some more True options to getVar calls
getVar() now defaults to expanding by default, thus remove the True
option from getVar() calls. Fix a small number of cases not addressed
by the original patch:
http://git.openembedded.org/meta-openembedded/commit/?id=efd3696e70a6603f1a45faa4a172433514f0a487
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-core/glib-2.0/glibmm_2.50.0.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-core/libxml/libxml++_2.38.1.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-core/meta/distro-feed-configs.bb | 4 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/libgee/libgee_0.18.0.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/pango/pangomm_2.40.1.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-multimedia/live555/live555.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/nano/nano.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/openldap/openldap_2.4.44.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim_8.0.0022.bb | 2 |
9 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/glib-2.0/glibmm_2.50.0.bb b/meta-oe/recipes-core/glib-2.0/glibmm_2.50.0.bb index ebe7747ae..9479de980 100644 --- a/meta-oe/recipes-core/glib-2.0/glibmm_2.50.0.bb +++ b/meta-oe/recipes-core/glib-2.0/glibmm_2.50.0.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499 \ | |||
8 | DEPENDS = "mm-common glib-2.0 libsigc++-2.0" | 8 | DEPENDS = "mm-common glib-2.0 libsigc++-2.0" |
9 | inherit autotools pkgconfig | 9 | inherit autotools pkgconfig |
10 | 10 | ||
11 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 11 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
12 | 12 | ||
13 | SRC_URI = " \ | 13 | SRC_URI = " \ |
14 | ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.xz \ | 14 | ftp://ftp.gnome.org/pub/GNOME/sources/glibmm/${SHRT_VER}/glibmm-${PV}.tar.xz \ |
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb index 70965f313..2cb954835 100644 --- a/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb +++ b/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb | |||
@@ -6,7 +6,7 @@ SECTION = "libs" | |||
6 | LICENSE = "LGPL-2.1+" | 6 | LICENSE = "LGPL-2.1+" |
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 " | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 " |
8 | 8 | ||
9 | SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}" | 9 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
10 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \ | 10 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \ |
11 | file://libxml++_ptest.patch \ | 11 | file://libxml++_ptest.patch \ |
12 | file://run-ptest \ | 12 | file://run-ptest \ |
diff --git a/meta-oe/recipes-core/meta/distro-feed-configs.bb b/meta-oe/recipes-core/meta/distro-feed-configs.bb index ea5ca3848..2a8de54d2 100644 --- a/meta-oe/recipes-core/meta/distro-feed-configs.bb +++ b/meta-oe/recipes-core/meta/distro-feed-configs.bb | |||
@@ -22,8 +22,8 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
22 | 22 | ||
23 | #def distro_feed_configs(d): | 23 | #def distro_feed_configs(d): |
24 | # import bb | 24 | # import bb |
25 | # parchs = d.getVar( "PACKAGE_EXTRA_ARCHS", 1 ).split() | 25 | # parchs = d.getVar("PACKAGE_EXTRA_ARCHS").split() |
26 | # march = d.getVar( "MACHINE_ARCH", 1 ).split() | 26 | # march = d.getVar("MACHINE_ARCH").split() |
27 | # archs = [ "all" ] + parchs + march | 27 | # archs = [ "all" ] + parchs + march |
28 | # confs = [ ( "${sysconfdir}/opkg/%s-feed.conf" % feed ) for feed in archs ] | 28 | # confs = [ ( "${sysconfdir}/opkg/%s-feed.conf" % feed ) for feed in archs ] |
29 | # return " ".join( confs ) | 29 | # return " ".join( confs ) |
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.18.0.bb b/meta-oe/recipes-devtools/libgee/libgee_0.18.0.bb index 3fa9d9fc2..6386f1ffb 100644 --- a/meta-oe/recipes-devtools/libgee/libgee_0.18.0.bb +++ b/meta-oe/recipes-devtools/libgee/libgee_0.18.0.bb | |||
@@ -18,7 +18,7 @@ do_configure_prepend() { | |||
18 | done | 18 | done |
19 | } | 19 | } |
20 | 20 | ||
21 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 21 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
22 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" | 22 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz" |
23 | SRC_URI[md5sum] = "29ea6125e653d7e60b49a9a9544abc96" | 23 | SRC_URI[md5sum] = "29ea6125e653d7e60b49a9a9544abc96" |
24 | SRC_URI[sha256sum] = "4ad99ef937d071b4883c061df40bfe233f7649d50c354cf81235f180b4244399" | 24 | SRC_URI[sha256sum] = "4ad99ef937d071b4883c061df40bfe233f7649d50c354cf81235f180b4244399" |
diff --git a/meta-oe/recipes-graphics/pango/pangomm_2.40.1.bb b/meta-oe/recipes-graphics/pango/pangomm_2.40.1.bb index 7ff7b20c8..02bb1cc93 100644 --- a/meta-oe/recipes-graphics/pango/pangomm_2.40.1.bb +++ b/meta-oe/recipes-graphics/pango/pangomm_2.40.1.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499 \ | |||
6 | 6 | ||
7 | DEPENDS = "mm-common cairomm glibmm pango" | 7 | DEPENDS = "mm-common cairomm glibmm pango" |
8 | 8 | ||
9 | SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 9 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
10 | 10 | ||
11 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.xz" | 11 | SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/pangomm/${SHRT_VER}/pangomm-${PV}.tar.xz" |
12 | SRC_URI[md5sum] = "874eadd9434613dbacf0272c82c3ac23" | 12 | SRC_URI[md5sum] = "874eadd9434613dbacf0272c82c3ac23" |
diff --git a/meta-oe/recipes-multimedia/live555/live555.inc b/meta-oe/recipes-multimedia/live555/live555.inc index 0d11de904..710dbdec8 100644 --- a/meta-oe/recipes-multimedia/live555/live555.inc +++ b/meta-oe/recipes-multimedia/live555/live555.inc | |||
@@ -9,7 +9,7 @@ SECTION = "devel" | |||
9 | 9 | ||
10 | INC_PR = "r1" | 10 | INC_PR = "r1" |
11 | 11 | ||
12 | URLV = "${@d.getVar('PV',1)[0:4]}.${@d.getVar('PV',1)[4:6]}.${@d.getVar('PV',1)[6:8]}" | 12 | URLV = "${@d.getVar('PV')[0:4]}.${@d.getVar('PV')[4:6]}.${@d.getVar('PV')[6:8]}" |
13 | SRC_URI = "http://www.live555.com/liveMedia/public/live.${URLV}.tar.gz \ | 13 | SRC_URI = "http://www.live555.com/liveMedia/public/live.${URLV}.tar.gz \ |
14 | file://config.linux-cross" | 14 | file://config.linux-cross" |
15 | # only latest live version stays on http://www.live555.com/liveMedia/public/, add mirror for older | 15 | # only latest live version stays on http://www.live555.com/liveMedia/public/, add mirror for older |
diff --git a/meta-oe/recipes-support/nano/nano.inc b/meta-oe/recipes-support/nano/nano.inc index 8a1d71f64..22f0fb2a0 100644 --- a/meta-oe/recipes-support/nano/nano.inc +++ b/meta-oe/recipes-support/nano/nano.inc | |||
@@ -8,7 +8,7 @@ SECTION = "console/utils" | |||
8 | DEPENDS = "ncurses file" | 8 | DEPENDS = "ncurses file" |
9 | RDEPENDS_${PN} = "ncurses-terminfo" | 9 | RDEPENDS_${PN} = "ncurses-terminfo" |
10 | 10 | ||
11 | PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}" | 11 | PV_MAJOR = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
12 | 12 | ||
13 | SRC_URI = "https://nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.xz" | 13 | SRC_URI = "https://nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.xz" |
14 | 14 | ||
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb index 645a5179c..e8e0c857b 100644 --- a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb +++ b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb | |||
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c933fba6d89fda89f58df1e086e3f2e7 \ | |||
14 | " | 14 | " |
15 | SECTION = "libs" | 15 | SECTION = "libs" |
16 | 16 | ||
17 | LDAP_VER = "${@'.'.join(d.getVar('PV',1).split('.')[0:2])}" | 17 | LDAP_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}" |
18 | 18 | ||
19 | SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${BP}.tgz \ | 19 | SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${BP}.tgz \ |
20 | file://openldap-m4-pthread.patch \ | 20 | file://openldap-m4-pthread.patch \ |
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0022.bb b/meta-oe/recipes-support/vim/vim_8.0.0022.bb index 112ae80a2..126fe6162 100644 --- a/meta-oe/recipes-support/vim/vim_8.0.0022.bb +++ b/meta-oe/recipes-support/vim/vim_8.0.0022.bb | |||
@@ -14,7 +14,7 @@ SRCREV = "ec68a99464055029c01082762517e97245ddae0c" | |||
14 | 14 | ||
15 | S = "${WORKDIR}/git/src" | 15 | S = "${WORKDIR}/git/src" |
16 | 16 | ||
17 | VIMDIR = "vim${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}" | 17 | VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}" |
18 | 18 | ||
19 | inherit autotools update-alternatives | 19 | inherit autotools update-alternatives |
20 | inherit autotools-brokensep | 20 | inherit autotools-brokensep |