diff options
author | Li Zhou <li.zhou@windriver.com> | 2017-12-19 09:31:56 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2017-12-27 07:25:03 -0800 |
commit | eaa4b4baa61813ef29fa436c0a1f863fbfc6a94e (patch) | |
tree | 2b8d1459ffffba04f1b3636af8ce3c58f0856347 /meta-oe | |
parent | c186045e8b753efb343b16518c907d5c97c90335 (diff) | |
download | meta-openembedded-eaa4b4baa61813ef29fa436c0a1f863fbfc6a94e.tar.gz |
vim: Security Advisory - vim - CVE-2017-17087
Porting the patch from <https://github.com/vim/vim/commit/
5a73e0ca54c77e067c3b12ea6f35e3e8681e8cf8> to solve CVE-2017-17087.
Signed-off-by: Li Zhou <li.zhou@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/vim/files/CVE-2017-17087.patch | 70 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim_8.0.0983.bb | 1 |
2 files changed, 71 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch new file mode 100644 index 000000000..937b9ba31 --- /dev/null +++ b/meta-oe/recipes-support/vim/files/CVE-2017-17087.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | From 9c11f80339372b7aa2f43153d574f2b5abb79708 Mon Sep 17 00:00:00 2001 | ||
2 | From: Li Zhou <li.zhou@windriver.com> | ||
3 | Date: Sun, 17 Dec 2017 23:09:35 -0800 | ||
4 | Subject: [PATCH] vim: patch 8.0.1263: others can read the swap file if a user | ||
5 | is careless | ||
6 | |||
7 | Problem: Others can read the swap file if a user is careless with his | ||
8 | primary group. | ||
9 | Solution: If the group permission allows for reading but the world | ||
10 | permissions doesn't, make sure the group is right. | ||
11 | |||
12 | Upstream-Status: Backport | ||
13 | CVE: CVE-2017-17087 | ||
14 | Signed-off-by: Li Zhou <li.zhou@windriver.com> | ||
15 | --- | ||
16 | src/fileio.c | 24 +++++++++++++++++++++++- | ||
17 | src/version.c | 2 ++ | ||
18 | 2 files changed, 25 insertions(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/fileio.c b/src/fileio.c | ||
21 | index f54fb8465..2c7740af9 100644 | ||
22 | --- a/src/fileio.c | ||
23 | +++ b/src/fileio.c | ||
24 | @@ -716,7 +716,29 @@ readfile( | ||
25 | /* Set swap file protection bits after creating it. */ | ||
26 | if (swap_mode > 0 && curbuf->b_ml.ml_mfp != NULL | ||
27 | && curbuf->b_ml.ml_mfp->mf_fname != NULL) | ||
28 | - (void)mch_setperm(curbuf->b_ml.ml_mfp->mf_fname, (long)swap_mode); | ||
29 | + { | ||
30 | + char_u *swap_fname = curbuf->b_ml.ml_mfp->mf_fname; | ||
31 | + | ||
32 | + /* | ||
33 | + * If the group-read bit is set but not the world-read bit, then | ||
34 | + * the group must be equal to the group of the original file. If | ||
35 | + * we can't make that happen then reset the group-read bit. This | ||
36 | + * avoids making the swap file readable to more users when the | ||
37 | + * primary group of the user is too permissive. | ||
38 | + */ | ||
39 | + if ((swap_mode & 044) == 040) | ||
40 | + { | ||
41 | + stat_T swap_st; | ||
42 | + | ||
43 | + if (mch_stat((char *)swap_fname, &swap_st) >= 0 | ||
44 | + && st.st_gid != swap_st.st_gid | ||
45 | + && fchown(curbuf->b_ml.ml_mfp->mf_fd, -1, st.st_gid) | ||
46 | + == -1) | ||
47 | + swap_mode &= 0600; | ||
48 | + } | ||
49 | + | ||
50 | + (void)mch_setperm(swap_fname, (long)swap_mode); | ||
51 | + } | ||
52 | #endif | ||
53 | } | ||
54 | |||
55 | diff --git a/src/version.c b/src/version.c | ||
56 | index a5cb078f0..5c0df475f 100644 | ||
57 | --- a/src/version.c | ||
58 | +++ b/src/version.c | ||
59 | @@ -770,6 +770,8 @@ static char *(features[]) = | ||
60 | static int included_patches[] = | ||
61 | { /* Add new patch number below this line */ | ||
62 | /**/ | ||
63 | + 1263, | ||
64 | +/**/ | ||
65 | 983, | ||
66 | /**/ | ||
67 | 982, | ||
68 | -- | ||
69 | 2.11.0 | ||
70 | |||
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0983.bb b/meta-oe/recipes-support/vim/vim_8.0.0983.bb index 407ce5e73..f2edd5168 100644 --- a/meta-oe/recipes-support/vim/vim_8.0.0983.bb +++ b/meta-oe/recipes-support/vim/vim_8.0.0983.bb | |||
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=eea32ac1424bba14096736a | |||
9 | SRC_URI = "git://github.com/vim/vim.git \ | 9 | SRC_URI = "git://github.com/vim/vim.git \ |
10 | file://disable_acl_header_check.patch;patchdir=.. \ | 10 | file://disable_acl_header_check.patch;patchdir=.. \ |
11 | file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ | 11 | file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ |
12 | file://CVE-2017-17087.patch;patchdir=.. \ | ||
12 | " | 13 | " |
13 | SRCREV = "3f9a1ff141412e9e85f7dff47d02946cb9be9228" | 14 | SRCREV = "3f9a1ff141412e9e85f7dff47d02946cb9be9228" |
14 | 15 | ||